Trane Thermostat - tzemt400ab32maa


Does anyone have this thermostat working with ST?

Thanks in advance!


That looks very much like the Evolve series of thermostats. I have two of the Evolve’s and they work great. I found a user guide online for that Trane, and that is also the same as the Evolve.

I have written a device type for these thermos if you decide to get one:

Cool! But ST cant find it… Is there something special. Manual says go to settings for zwave and say yes.


Yes, first start the Include process by going into the app and Connect New Device, and then go to the settings on the thermostat and select yes to join a zwave network. While you’re at the thermostat, configure the Fan Cycler mode. I have mine set for 10 minutes on and 50 minutes off. That way the device type can manage your fan with the Circulate option.

If the thermo won’t join, try to exclude it first before trying to include it, and if it still won’t join, you may have a distance issue between the hub and thermostat.

Search the Community for how to create a custom device type, and use this code to use what I have in the image above:

Its working!!! THANKS!!!

Excellent! Glad I could help.

John- Any chance you could help me? I installed your smart app , but I can’t change the temp in there. The fan on/heat, auto all work, but not the temps up or down. Did I do something wrong?

Hi @mjt. That’s really odd. All the controls are just standard zwave command classes, and all I did was just play with the layout for the look and feel.

Do you get the same behavior if you use ST’s default zwave thermostat device type? If so, I’d recommend doing a factory reset via the Installer Settings menu. Look for something called Restore Defaults.

Same behavior here utilizing the default zwave thermostat device type on 2 Trane tzemt400ab32maa. I can issue on/off and mode changes successfully but can’t change temp up/down I also had the same behavior when paired with a Wink hub previously.

Any suggestions?

If you had the same behavior with both device types in ST (mine and theirs), as well as Wink’s, then I would have to conclude it’s got to be an issue with the thermostat (assuming a factory reset hasn’t bee performed).

If I read your last post correctly, this is happening on 2 thermostats? If so, I would (just to be absolutely safe and sure) perform a factory reset and General Exclude, and then try and re-include again.

Thanks for the help! I excluded the thermostat then I did a factory reset on the thermostat and then re-paired it to Smartthings, but its still doing the same thing. When I change the temp in the app its going to 1,2 or 3 degrees then resetting back to the default temp on the thermostat. The only thing in the app I am able to do is change mode (heat/cool etc) This used to work on v1 of the hub with the old app. Any other suggestions?

Yep, same exact behavior here (Wink and ST V2 hub). I suppose we should submit this to Smartthings as a bug?

@mjt @JSikes

Ok, well now I’m stumped. Give me a bit tonight to take a look. It could be something to send in to ST support. BRB!

Can you capture the Live Log events when you change the temperature? It should look something like this:

5:59:13 PM: debug Parse returned [[value:70, unit:F, displayed:false, name:heatingSetpoint, isStateChange:true, linkText:Thermostat Main Floor, descriptionText:Thermostat Main Floor heating setpoint is 70°F], [name:thermostatSetpoint, unit:F, value:70, isStateChange:true, displayed:true, linkText:Thermostat Main Floor, descriptionText:Thermostat Main Floor thermostat setpoint is 70°F]]
5:59:13 PM: debug Unit is in Heat Mode and is idle. Fan is in Auto Mode and is running.
5:59:13 PM: debug THERMOSTAT, adding setpoint event: [value:70, unit:F, displayed:false, name:heatingSetpoint, isStateChange:true, linkText:Thermostat Main Floor, descriptionText:Thermostat Main Floor heating setpoint is 70°F]
5:59:13 PM: info THERMOSTAT, latest mode = heat
5:59:10 PM: trace setHeatingSetpoint(70.0, 30000)
5:59:10 PM: debug Setting heat set point down to: 70

For what it’s worth I am experiencing the same issue. I just got a new V2 Smartthings hub and I am brand new to Smartthings, did a factory reset on my thermostat, re-added it and when I attempt to adjust the sliders on the temperatures they go to some low amount like 2 or 3. I then refresh and they go back to what the actual settings are. I can adjust the auto/cool/heat just not temperature it seems. Plus for some reason I only have a slider bar for the temperature and no up/down arrows for adjusting.

I see your template above, but I am brand new to smartthings and not sure exactly how to use it. I logged into the IDE, created a new device from code, pasted the code. now it asks me to choose location and device. I select my thermostat and choose install, and it stays stuck at installing. Is there something else I need to do in order to associate your template with my thermostat?

Appreciate the help with this.

This is all that is on there for live log. After I put in the new temp it goes to either 1,2,3 degrees then a minute later it resets back to the original. I really appreciate you looking into this…it is very strange!

540692ea-82a9-4f85-a62d-8c0065f3f96b 6:51:26 PM: trace setHeatingSetpoint(83.0, 100)
540692ea-82a9-4f85-a62d-8c0065f3f96b 6:51:21 PM: trace setCoolingSetpoint(44.0, 100)
540692ea-82a9-4f85-a62d-8c0065f3f96b 6:51:15 PM: trace setCoolingSetpoint(53.0, 100)
540692ea-82a9-4f85-a62d-8c0065f3f96b 6:51:09 PM: trace setHeatingSetpoint(72.0, 100)
540692ea-82a9-4f85-a62d-8c0065f3f96b 6:51:03 PM: trace setHeatingSetpoint(49.0, 100)
540692ea-82a9-4f85-a62d-8c0065f3f96b 6:50:55 PM: trace setHeatingSetpoint(39.0, 100)
540692ea-82a9-4f85-a62d-8c0065f3f96b 6:50:49 PM: trace setHeatingSetpoint(39.0, 100)


Do you mean you created a new device type from the code? If so, you’re very close.

Your thermostat is already in ST, right? If so, you don’t need to re-include it, just edit the device and change the “Type*” field to the device type you just created.

Ok, that’s good info. Thanks for getting that. This is the difference I see right off the bat:

setHeatingSetpoint(83.0, 100)

setHeatingSetpoint(70.0, 30000)

I think I know what may be causing the difference, but I need to do some testing tonight. Would you mind if I got back to you late tonight or tomorrow afternoon?

Of course, I just appreciate you getting back to me! Whenever you can is great…thank you so much! I read in another post about the same thermo that someone changed the heat/cool setpoint from 1000(I think?) to 100 and it fixed this same problem, but it didnt work for me.

Try something real quick? On lines 451 and 499, can you change “delay” to “30000” and see what happens? Just make sure to save and publish for yourself.