Zen Thermostat App


(Will) #1

Hi All,

I recently installed the Zen Thermostat but when reviewing the app I see several problem:

  • Temperature up and down isn’t consistent, pressing up sometime goes in increments of 10 and others in single units, my temp now reads as 77.4.
  • Pressing the configure button doesn’t do anything?
  • Refresh doesn’t refresh anything

I am running the new version of the smartthings app

Would the Ecobee3 be a better option?

Many thanks


(Mike Maxwell) #2

I have a zen, works fine, however I’m using a a community tweaked device.
Give it a shot:

I used to have 2 ecobees, and while nice, they were “too smart” for my setup…
I manage my zen using hello home actions and @slagle thermostat director…


#3

Config doesn’t do anything.

I’ve installed my thermostat and set up a schedule, but since I only have a furnace and it’s summer I haven’t actually tried using SmartThings to manually adjust the temperature. Hopefully the kinks will get worked out before winter.


(Mike Maxwell) #4

:confused: the zen thermostat doesn’t include any scheduling capabilities…
What thermostat are you talking about?


#5

I’m talking about the Zen Thermostat. Until the recent SmartThings update there was an action you could create that set the thermostat set point based on various conditions. I have time-based actions for wake and sleep, and presence-based actions for away and return. Unfortunately, this capability seems to have been removed in the update. I’ve got a ticket with support to learn how to accomplish this capability with the new organization. I can only hope my old actions will continue to work, as I’m reluctant to update my SmartThings mobile app until I can replicate my current actions.


(Mike Maxwell) #6

hello home actions (now called routines) are in the new app, and even easier to find and edit.


(Alyssa Thurston) #7

I’m having a similar issue with my Zen thermostat, but I think mine is a faulty device more than anything else, as the links don’t work on it.

Within my SmartThings App, I show “null” for the temperature selection, no matter if it is set to cool/heat/fan. The temperature reading that is supposed to come from the Zen won’t show, it instead shows 2 dashes. My SmartThings and the Zen thermostat almost appear to not be talking to each other, despite connecting to my hub flawlessly.

I was also told that configure wasn’t supposed to do anything, though I am skeptical of that. Why have a button there that isn’t going to do anything?

If you find any solutions let me know!


(Will) #8

I have to admit I was very disappointed at the lack of thought in the delivered app, the set to temp needs to be brighter and more responsive when pressing up and down, as you say, why have a config button if it doesn’t do anything. I have set several routines now to adjust the temp through the day based on time and my location etc…

Changing the subject a little, does anyone have an issue where if two phones are used as location sensors and you both leave at the same time, one adjust to away but the other remains at the home?


(Mike Maxwell) #9

I’m using hello home actions to set the thermostat set points, there’s three people (phones) in this house, all using life360, have not had any issues like you mention with presence I’ve been using this thermostat since May this year.


(Christine) #10

We just bought 2 of the zen thermostats and I have been messing around with the device types trying to improve on the “official” device type which has a lot of issues. @Mike_Maxwell thank you for the tweaks above. I had modified the original to give it different color coding, but this looks cleaner and crisper.

Does anyone know if we can get battery status from this? I have attempted to add in code others have used for other thermostats, but nothing seems to work. I even tried the modified Z-wave thermostat but that caused the entire device to stop working in smart things.

I have already loaded a smartapp to help keep track of battery status (so far we have 12 devices that require batteries and will most likely have more). It would be nice to find out how the battery is doing to make sure we have recharged batteries ready for when it dies.


(Jamie S.) #11

Hi @Mike_Maxwell… thanks for sharing! I would like to give this a whirl, but have NO idea what to do with what you’ve posted. Sorry for such a basic question, but thought I would see if you were willing to post a link to a how to or even just give me the proper search term so I can implement your code.

Thanks!!!


(Mike Maxwell) #12

I know there’s some faq’s on using the IDE to publish devices.
Of course I have no idea where they are, @JDRoberts ? would you be so kind?


(Jamie S.) #13

Thanks… knowing that it is something to be done on the IDE is a good start. I’ll take a look. Appreciate the response!


(Jamie S.) #14

That was the “push in the right direction” I needed… Thanks again!


(Patrick Cartwright) #15

I have some strange lines in my log, and I think I know what they are. They show as follows.

read attr - raw: 93670102010A2900190D00, dni: 9367, endpoint: 01, cluster: 0201, size: 0A, attrId: 0029, encoding: 19, value: 000d

They are for the thermostat operating state. I think the alpha characters in the get getOperatingStateMap are supposed to be lowercase. I requested the api doc from zen but pushed me off to openhome.io which is not helpful.

Also when comparing the this device type vs the official this one is missing 000d and the official is missing 000c. I think 000d is 2nd stage heat. I have seen both of these in operation.

Does anyone know where to get the actual API documentation for this thermostat?


(Nicholas Stock) #16

Hi, newbie here with the Zen thermostat and smartthings. Have been having issues with Routines occasionally not triggering when they should…i.e. the zen is supposed to turn heat off at 10 pm and nine times out of ten it works as expected and then some evenings it leaves the heat on…Anyone else have this issue?

Thanks for any help.

Nick


#17

The issue of time-based routines failing is not specific to the Zen thermostat. Some recommendations from others experiencing similar problems:

  1. Try changing the time the routine executes to something other than on the hour or half-hour, on the theory that you’ll be competing with fewer system resources if you pick a less commonly used time.

  2. Make the time-based routine as simple as possible. My thermostat’s time-based routine that includes a mode change fails more frequently than the one that only changes the set point.

  3. Consider setting up a redundant temperature change routine a short while later.

ST is aware of the problem, and in response to a recent support ticket for this very issue I did receive a response that they are working on an overhaul on how the system handles schedules. Knowing how the software world works, I didn’t bother asking when it will be released.


(Nicholas Stock) #18

Thanks for the reply! OK, so that makes more sense, but is a little frustrating no? I will make a few of the changes you recommend to see if it helps things…hopefully the software can develop quickly to squash bugs like these. I would have thought that robust scheduling would have been the first thing out of the gate given that it’s home ‘automation’…:wink:


(Nicholas Stock) #19

OK, so I changed the time off in the routine to something a little less common than 10 pm…still no dice, random if it works or not…the morning turn on is now flaky too…what on Earth is up with simple scheduling? I got forced in to the SmartThings platform through backing the Zen Thermostat program…I’m beginning to think I may need to search for another solution or go back to my trusty Honeywell with WiFi…


(Nicholas Stock) #20

OK, so now I have good news to report. For the last 5 nights and mornings in a row the routine has worked flawlessly, so I’m presuming issues on the back end have been fixed? If so, bravo!