TCP Lighting Experiences


(Ben Edwards) #1

Continuing the discussion from MyQ Garage Door Device Type:

How are you liking your TCP lights?


(Andrew Urman) #2

he’s in heaven …


(Anthony) #3

@Ben honestly I love them, but I need to use the TCP Gateway. Unfortunately the consistency isn’t there yet! I’m not sure if having that many lights is causing the issue. I’m still doing trial and error when I have some time.

@urman yes I’m in heaven LOL. I got the MyQ and NEST all hooked up perfectly. My home is truly becoming a future house.


(Ben Edwards) #4

There still seems to be an issue where you cannot issue commands to more than 3 TCP bulbs at a time. So an OFF command to 4 bulbs would not work. We are looking at this limitation. Is this what you are seeing?


(Anthony) #5

Ben yes that’s exactly the issue. I didn’t know that was an known issue and thank you for mentioning it. Any idea on a fix for that??

Thanks


(Dave) #6

I’ve yet to dip my toes into Groovy, but couldn’t you iterate through a list of bulbs, issuing out a command to one bulb at a time? Whatever Groovy’s equivalent of a For/Each loop would be?


(BBlack) #7

I am seeing an issue with 10 TCP bulbs in my system. When I use a Whole Home “switch” for all of them or from using Hello Home phrases. Many bulbs in the system don’t respond. At first I thought it was the lights I had grouped in fixtures but it is also single bulbs. The activity log and Hello Home will show the off or on command being sent and the icon in Smartthings app will change to off or on but the light does not change.


(Ben Edwards) #8

yeah I think this may be the same issue:


(Ronny Carr) #9

I’ve seen, even with less than three bulbs, they sometimes do not respond to SmartThings. I’ve never seen one set to the right level when turing on and changing the level at the same time either.

Not being able to control more than two bulbs at a time really stinks, though it’s better than the alternatives I suppose.


(Ben Edwards) #10

@wackware have you seen these issues as well, and have you solved them at your place?


(Anthony) #11

Todd is the man with a master plan!


(Greg) #12

For me the 5 min polling to show correct status in ST doesn’t work.


(Todd Wackford) #13

I’m looking into this. Please let me know the exact configuration on TCPI app.


(Anthony) #14

Todd, as you know I threw away the old gateway and the new gateway is paired up with ST’s and working fine. My issue was some lights would come on and off using Hello Home. My number one goal is to press my UP when it’s bed time and shut down everything including all the lights I have. In addition I’d like the use the sunrise/sunset app. I can’t do that now because the of the inconsistency. I’m aware of the can’t use more then 3 lights at a time, but even then it’s very sporadic. Anything I could help you with on this?

Anthony


(DawgOnKing) #15

I’m following this very closely as I entertain the purchase of the TCP Gateway kit. Thanks for the updates and hard work guys.

Will we reach the point where the gateway isn’t required? (One word answer is fine.)


(Ben Edwards) #16

We have a firmware version that is in the works that should help resolve the issues with the 3 bulb limit. There is no timeline for its release at this point. Unlike hue bulbs (which have a ZigBee radio in them) the TCP bulbs will likely always require their own hub. At least that is my thought.


(Anthony) #17

@dawgonking I can tell you the TCP Bulbs are like ST’s…“It just works”! Unless you can afford the Hue Bulbs for your entire house, then I’d say jump on them. Now if you use the TCP app only it’s really amazing how well they perform. Never had an issue with them not turing on or off on a schedule. Right now it’s useless with ST’s if you want them to work the way ST’s is designed to operate. I’m stocking up on bulbs before they jump in price because that’s a matter of time. I currently have 21 bulbs hooked up with 13 more pending. I’m waiting until ST’s can fix the issue that @Ben was just talking about. I am really looking forward to that update, for now I’ll wait LOL!!

Anthony


(Greg) #18

@antman2 you don’t have an issue where the correct state doesn’t show in ST? even after 5 min?


(Anthony) #19

@greg to prevent that from happening this is what you need to do.

The only way the lights will work on ST’s is if you ONLY use ST’s to control them. Now for me I can turn on and off all 21 lights with no problem showing the correct status every single time. My only problem when I want to perform a Hello Home action or even use certain apps, then some turn off and some don’t. This is the only issue I have and I’m positive it’ll be fixed. So if you turn on the light from ST’s and turn it off with TCP, then forget it ST’s will not see the current state. Same goes if you turn it on from TCP, then ST’s will not see the current state. If you turn on the light(s) from ST’s and turn off with ST’s then everything is fine. I have this same issue with MyQ. My goal is to delete the MyQ app and TCP once everything runs perfect. Fingers crossed that happens soon with TCP. The MyQ seems to work very well right now!


(Greg) #20

@antman2 I do intend to only use ST to control them. Just during spring storms we lose power a bit, which causes ALL tcp lights to turn on. If I’m not home I can’t tell that all the lights are on (through ST).

Kinda like you I’d like to delete my tcp app, but I guess I have to keep it for now to randomly see if my lights are on if I’m not home and suspect we lost power.