Can't re-connect with TCP bulbs

I’ve had five TCP lights working fine with ST, but this week they started losing functionality (lights would stay on, not respond to motion switch, etc.). I re-booted TCP and all control is working there through the TCP/Greenwave app, but still no ST.

I deleted all TCP lights and associated Labs from ST and now it can’t “find” any bulbs when I go to add the TCP lights back in. The icon just spins but none are discovered, even though things are working great from the TCP end.

I’ve rebooted the ST hub and the TCP gateway. I’ve read up on other people’s similar issues and it is possible the IP address of the TCP gateway may have changed after a router reboot, though I can’t say for sure as I don’t know what the IP address would have been prior to any changes. Is the ST hub “remembering” an old IP address that makes it impossible to find the gateway now? Or is it something else?

We really need a few of these lights back in the house!

Hmm… this same thing started for me on Sunday morning. No rebooting prior, just lack of scheduled tasks running using the TCP lights. I then rebooted all my equipment after initially trying to fix things as is.

I then removed 1 Bulb from SmartThings, and then from the TCP app. I added the bulb back to TCP (new room, new name), and am unable to find any new bulb from SmartThings.

In the IDE when I toggle on/off the device and command gets sent, and the Tile turn on/off, but it looks like its not communicating. I get a different error when I try to set the light brightness, etc. I tried switching the Device Type for the TCP bulb, but still things arent working…

It looks like something between SmartThings > TCP is no longer set properly?

My TCP bulbs are all working fine. One change that made my TCP infinitely more reliable was to create fixtures for all of my lights in the TCP app. For example, when you have a group of three lights without a fixture, ST sends three commands to turn them on/off. With a fixture those three lights behave has one unit, with a single command to toggle or dim the light.


So you had issues sending commands when your lights were not in a fixture then? I never had any issue sending 1 off commands before, just Sunday I woke up and none of my TCP bulbs were working. I’ll try the fixture and see if it changes anything remotely… though I probably wont know unless I’m home physically looking at my lights.

One thing that bothers me is that I can not find any new TCP bulbs after removing a bulb, and giving it a new name and room in TCP. My "lighting’ address has stayed the same, no change…

Trying the fixtures. Any other suggestions?

@jody.albritton … question for you, when you use the bright/dimm buttons on the TCP Bulb tile, do you get an error (in the IDE) along the lines of: org.codehaus.groovy.runtime.typehandling.GroovyCastException: Cannot cast object ‘null’ with class ‘null’ to class ‘float’. Try ‘java.lang.Float’ instead @ line 124

I dont get any errors turning on or off the bulbs, but I get that now… and I show 0 wattage (which makes sense, since the bulb doesnt appear connected to smartthings).


@johnessey I can use the level up and down buttons without error and my wattage is displaying too. I am able to add and remove bulbs as well. Might need to ping @wackware on this as he the one who wrote the TCP stack.

Are you using a custom TCP smart app or the one from the labs?

Thanks for the reply @jodyalbritton. I am using the TCP Bulb device type from SmartThings. The only custom things I have are via apps. Even as a basic device operating, the device by the tile is problematic for me.

I’ve pinged @wackware and support… just hoping its something simple that I can fix.

Also, doesnt appear that I can set up any fixtures unless I’m on the same network as the TCP Gateway, so I’ll have to wait until I’m home to try your suggestion.


One interesting thing is that the TCP web portal is no longer working either (typing “lighting.local” in browser address bar. And I got an email from TCP support today saying they no longer support the web interface – just the mobile apps.

It’s interesting that the TCP mobile app was recently updated as well, not least to fix the rampant crashing that was making it all but unusable for many of us recently. Not sure if there’s a connection, though - (?)

I’m guessing they did away with the lighting.local access because you could access anyone’s TCP lights if you were on their wifi

@davempls … funny, I noticed I can no longer call any of the local directories, I get forced to ‘trial.greenwave’ or whatever the site is. IP and hostname force me to sign in remotely now.

I actually didn’t have any issues with the mobile app update, and frankly havent looked to see if the firmware on the TCP hub changed or updated (I’m not even sure what I was running if that is the case).

Hi All,

We were just informed that TCP’s latest mandatory firmware update to their gateway breaks the integration.
You can read more about it here: TCP Lighting Integration Issue - 10/27

We’ll continue to update that thread as we get more info.


Sad news. Thanks for the official update, Gilbert.

If at any point the integration is not going to officially happen could you please post so I can promptly put my TCP stuff on Ebay (considering it anyways.).


Hi @johnessey,
I highly doubt this will be the case, but we will inform you as we get more updates. We’re also tweeting about it; subscribe to our tweets to stay informed outside of the forums.

1 Like

FWIW My current Firmware Version (TCP) is: 3.0.74.

My TCP hub worked fine prior to an Android update, and pretty much up until 2am EST on 10/26. About 6:30am on 10/26 my integration stopped randomly…

Curious what other users who still have integration working are running with for TCP Firmware. Good luck!

Mine is currently working
Firmware 3.0.39

Good/bad to know! At least I now understand the reason, and can stop wasting my own time trying to figure it out. Thanks for the update.

I have 3.0.74 too. As I mentioned before, it’s a mixed blessing – this new version has made my ST integration totally nonfunctional, but the previous TCP app was so buggy it crashed literally every time I went to use it.

Hopefully things will be straightened out soon!

A brief update, for those that did not receive a firmware upgrade, you will unlikely be forced to update. TCP advised us that they halted the firmware push. We’re going to get further updates in the next few days.

Stay up to date on this thread:

When will this be fixed? I contacted TCP and they didnt give my a time frame. It sucks not having it work. Seriously thinking of dumping TCP and going to the IQ bulbs