Successful Hampton Bay Ceiling Fan Installation


(Alan) #1

There’s one giant thread devoted to people doing this. I thought I’d share my story as a recent data point. Especially because I ran into several hiccups, but it all worked out in the end.

A couple months ago, I installed two Hampton Bay Ceiling fans, but the Zigbee controllers were all sold out, so I had been operating them as dumb fans. I put a watch on the coveted Hampton Bay Universal Fan Control, and it finally came into stock a couple weeks ago.


Yesterday, I went through the process of installing the control units. For the most part, it went smoothly, despite the fact the directions weren’t as descriptive as they could be. Basically, I undid 2 wire nuts: one tying together the fan, light, and house hot wires and another tying the unified fan/light neutral to the house neutral. I left alone the grounding wires, as the control unit doesn’t need to be grounded.

The control unit sits nicely in the space between the downrod mount and the outlet box. I tried to get all my wires aligned nicely in this phase. I found that a little planning helped a lot in figuring out how the wires and antennas would be routed.

Then, I connected the three wires from the fan to one side of the control unit and the two wires from the house to the other side. Since my fans are also Hampton Bay, the colors matched up nicely on the fan side. My house neutral was black but connected to a red wire on the control box. Here’s what it looks like ( I could probably have been tidier with my wire slack):


I agonized a bit over how best to handle the wall light switches. I ended up just buying simple switch guards and sticking the remotes next to the switches with command strips. It works great. I still instinctively reach for the switch, but having the guard redirects me for the remote.

Once I fired up power, everything worked well. My fan doesn’t allow me to completely hide the chain controls on the fan, unfortunately, and I don’t want to permanently sever them.

SmartThings Setup

It was a bit challenging to navigate these forums to get exactly the right information, and I found the developer web portal pretty finicky. But I eventually got it working.

First, I paired the control units with my hub. It took a while to successfully get the control units to enter pairing mode. I think what works is to alternate 3 seconds on and like a half second off. “3 seconds on, 3 seconds off” as the manual states wasn’t doing it. I named the devices, and they were registered as basically unknown devices.

Then, I added the 3 device handlers. I personally did this by working through the GitHub integration. I went to My Device Handlers -> Settings and in this panel I added the repo for the custom device handler. It then took me to a screen where I could import the device handlers from that repo, and I checked the Publish box.

(Prior, I had tried cutting and pasting the code, but it just disappeared, within the same session. Maybe because I didn’t publish it at the time.)

Next, I navigated to My Devices. I had to go through My Locations to actually see my devices though, for some reason. Otherwise, I see nothing. But anyway, under My Devices, I clicked into each of my ceiling fans, hit Edit, then under the Type drop down, I scrolled allllll the way down to select KOF Zigbee Fan Controller at the bottom (but not either of the two subdevices).

And voilá, it was done at last!

So far, everything works as expected. I’ve got a reliable connection with both my remote and my hub. I’m a happy camper!


I installed dimmable LED bulbs, which let me enable that function on the physical remotes and use the dimmer functionality of the smart app.

[BETA v0515] Hampton Bay Zigbee Ceiling Fan/Light Controller
Hampton Bay Zigbee Fan controller
(Greg) #2

Thanks for the success story. Will try this.


This will solve your ‘wall’ problem. (Although, it means in the future, if you have to re- pair got controller, you have to do it from the circuit breaker)

(I have a couple extras, if you can’t find them)

(Alan) #4

Yeah, I spotted that in one of the threads, but I just didn’t think it would be worth it. I’m actually just fine with having the remote stuck to the wall.

(Super Mouse Dv) #5

So funny I did not see this thread till now… I bought the same switch plate covers :slight_smile: I have 3 of these and need a 4th but waiting on getting my Smartthings V3 Mesh network so I can have a hub closer to the last fan (it never stayed on the network. ) nice descriptive install images.

(Jason "The Enabler" as deemed so by @Smart) #6

This is what you need…

(Alan) #7

That’s pretty neat! But I’m not sure it’s actually a more elegant solution for me.


genius, I will throw that on my printer soon as I get home

(Adrian) #9

That monster thread confuses me.

I have a Hampton bay fan with remote control.

The electrician installed a dumb stack switch on wall to control. Top toggle controls fan (on/off only), the remote controls fan speed. The bottom toggle controls the lights on/off, the remote light button is disabled, since the wall switch & fan is wired to have only wall switch control the Light.

So if I buy this zigbee fan controller, I have no idea where to begin.

(Adrian) #10

I pulled the trigger & ordered… this should be fun, I’ll be back here if I get stuck. Thx in advance for helping with anything I run into.

(Alan) #11

So, you’re probably in good shape, because the fact that you have two separate switches at the wall means that the circuits exist to control the fan and light separately, routed through the control unit. You should be able to use a voltmeter to figure out which terminal is which at the fan, if you don’t already know. You’ll have to decide what to do with that wall switch, since it won’t play nice with the control unit. For a setup like mine, with one master switch exposed but covered, you could tie the fan and light load wires together and connect to an ordinary single switch (not sure all my terminology is on-point here).

Good luck!

(Randeep Malhi) #12

This is great, if only I could get this working as well. I was able to add the device handlers and THANK YOU SO MUCH for making it so clear and simple on how to update it from the repositories. I honestly couldn’t figure it out from any other instructions, I don’t see what the need is to fork everything to yourself if you are just going to copy whatever someone else did, your way was so much easier. But now that I have my device connected it isn’t responding in the app at all and the status is unchanging. The light is constantly “off” and the fan is “high.” When I try changing anything it just freezes momentarily and goes back to the same status similar to how devices act when they are out of range, but it is definitely in range since it is almost directly below my hub and I even placed a zigbee repeater in the room. I think I have everything wired correctly because the remote works exactly as it should. I am just having no success with controlling it with smartthings. Did you run into anything like this? Was there some sort of calibration step? Do you like have to pair it when the fan is on High and the Light on or something? Any help would be greatly appreciated, I have 2 others I am planning on installing in the upcoming days but probably won’t get to it until I can figure out how to get this one functioning appropriately through smartthings. Any help is greatly appreciated!

(Alan) #13

Yeah, the online developer interface is certainly…something.

I didn’t experience anything like that :frowning: . Maybe try excluding and re-adding it and see if that helps?

You do have to set the fan itself to high for the control unit to be able to cycle through the full speed range, but this shouldn’t impact the basic responsiveness of the control unit.

If you have better luck with the other two, maybe the first one is a dud.

Good luck – this stuff can be really frustrating at times.

(Randeep Malhi) #14

Thanks Alan! I have removed and re-added it a few times with the same results but I just realized I should try a factory reset tomorrow on the fan itself. If that doesn’t work hopefully something clicks and I figure it out while I am installing the other 2, or at least if I can get one of those to work then it might actually be a dud. I guess we will find out soon enough

(Randeep Malhi) #15

I got it! So I did a factory restart of the fan and removed it from my smartthings. Then unplugged the hub for 2 hours so the zigbee mesh would reset (really only need 15+ mins). Before I reconnected the hub I unplugged my zigbee bulbs just in case because sometimes they work as (poor) repeaters and I don’t want the fan trying to connect to the hub through those, even though they are on the other side of the house as the hub and the fan but better safe then sorry. Once I reconnected the hub it was not finding the fan by adding a thing in the app so I did another factory reset white it was searching because I heard this puts it into pairing mode right off the bat, and voila! It recognized the fan and chose the handler without me doing anything and everything works as it should! This is magnificent. Can’t wait to get the other 2 fans installed. You are the man Alan!

FYI for anyone doing a factory reset on the fan, what I have found through both reading and my own experience is that to get a successful reset leave the fan off for at least 30 seconds first. Then cycle it on and off for 3 seconds at a time for at least 6 cycles. So “on, (1,2,3), off, (1,2,3)” and repeat. The lights will flash 3 times on and off when successful. The first time I did this it happened as I was going through the cycles, but if you are not getting a reset after a while just leave the lights on, within a minute or 2 the lights will flash indicating a reset. This is what happened for me the second time.

(Adrian) #16

My Hampton Bay Zigbee controller arrives trmw, but before I get started on upgrading the fans existing remote receiver, I have 2 pre-existing concerns.

  1. My Hampton bay fan has no chains or switches (remote only).

Will this cause issues with resetting or setup of ST syncing in general?

  1. since last year I’ve noticed somehow at some point that when controlling fan speed on the remote, the “medium” button actually is the “high” setting, & the “high” setting button turns on “medium” speed.

Should I try to correct this behavior now before moving fwd? If so, how? flipping the wall switch on/off few times didn’t fix it… med & high buttons are still backwards. Should I try flipping the breaker? I’ve previously searched google for answers about the buttons on remote being backwards, but nobody has ever ran into this.

(Alan) #17

Congratulations on wrestling your setup into submission! That seems to be what it take sometime!

Yeah, I don’t know why the factory reset is so finicky. It took me minutes of switch toggling at different cadences to get it right. My wife probably thought I was losing my marbles.

(Alan) #18

Both of those things sound concerning. I’d read the docs for your specific fan to see if there’s a reset, because I would guess this technique is specific to the Zigbee control unit. If you’ve got two separate wires for your light and fan hot wires, there might be hope, but it kind of sounds like your unit might be a fully integrated thing. Worst case, you may have to change fans. But that might not be that difficult since you already have one installed.

(Adrian) #20

Good news so far, I took your advice & tied both loads on same terminal on top toggle of wall switch. I did the same up top at fan, connected the new reciever as per instructions, flipped breaker on & flipped top toggle on wall switch on… nothing! Lol so then I remembered the new remote lol hit the light button & fan button & it worked! (Sadly the same issue from before, high is meduim).


My fan originally came with 3 speeds, as you know my original remote buttons were wrong, (meduim was high & high was actually med).

The new remote has 4 speeds, so that already isn’t adding up…

Finalized setup, pairing was super easy! Added the 3 device handlers & done.

Final result is that low is low, meduim is medium, medium-High is HIGH, & high is medium! Ughh why??!

Lastly I went to Alexa added ONLY the “medium-high (actually HIGH)” & Light… renamed them to “fan” & light”. So by voice it will work great… but it shows up on ST as medium-high & the remote will always require bunch of presses to get to the right fan setting, Sadly the remote doesn’t have a single fan on/off button.

(Alan) #21

Great! Hopefully you’re in the endgame now :slight_smile:

I discovered the devices before installing the device handlers (there are 3 of them), but I doubt it matters.