ST's Zigbee Thermostat Driver Bug : 513: Error creating Int16: Int16 value must be an integer

FYI for those with Zigbee thermostats using ST’s edge driver.

When you are trying to set the heating setpoint to a certain temperature, the mobile app errors out, voice assistants fail, and the Advanced Web App fails. The specific error is this:

513: Error creating Int16: Int16 value must be an integer


2023-11-06T12:45:13.830297150+00:00 DEBUG Zigbee Thermostat  driver device thread event handled
2023-11-06T12:45:37.068870042+00:00 TRACE Zigbee Thermostat  Received event with handler capability
2023-11-06T12:45:37.081741895+00:00 INFO Zigbee Thermostat  <ZigbeeDevice: f212f59b-c35e-4f43-a093-3329449895e5 [0xB922] (Downstairs Thermostat)> received command: {"capability":"thermostatHeatingSetpoint","args":{"setpoint":67},"positional_args":[67],"component":"main","command":"setHeatingSetpoint"}
2023-11-06T12:45:37.083711909+00:00 TRACE Zigbee Thermostat  Found CapabilityCommandDispatcher handler in zigbee-thermostat
2023-11-06T12:45:37.086923178+00:00 ERROR Zigbee Thermostat  Downstairs Thermostat thread encountered error: [string "st/dispatcher.lua"]:233: Error encountered while processing event for <ZigbeeDevice: f212f59b-c35e-4f43-a093-3329449895e5 [0xB922] (Downstairs Thermostat)>:
    arg1: table: 0x1b097e0
[string "st/zigbee/cluster_base.lua"]:513: Error creating Int16: Int16 value must be an integer

This is happening on all my thermostats (Lux Konoz’s) when trying to set the heating setpoint. I’ve not tried other thermostats, or a cooling setpoint.

I have an open ticket with ST on this #1546025 in case anyone else runs into this and would like to reference another instance of this bug.

Tagging @Ivan_Luis_Falleau @AlejandroPadilla

That sounds like it could be the bug that Steven put in a PR for on Friday.

1 Like

Where did you catch that, on Github?

Looks like this isn’t a new bug for ST either:

This is fixed in Zigbee Thermostat MC

I opened a ticket on this in early Jan and they never fixed it so I asked Mariano and he did it for me. I was also told back then that there was a bug opened and it wouldnt be long. We’ll. I guess not.

Yes, I am an avid reader of the Pull Requests and that one stuck in my mind. I haven’t really played with thermostats but it sounded like it ought to have had more impact than it seems to have had.


Yup I saw that, but I’m trying to use as many ST provided drivers as possible, for now at least.

Cool, thanks. I agree with you statement as well, especially since it’s been reported before.

I guess it all depends on how cold you get while you wait.

1 Like

Hi @johnconstantelo. Well is not too much to say here thanks to @orangebucket :muscle:. As he mentioned, there is a pull request working on that issue. You can see it here.


Hi @johnconstantelo

While they fix it, I think you could use °F values that, converted to °C, needed for zigbee attribute, do not have decimals. If the capability presentation allow decimal numbers. :wink:

64.4F = 18c
66.2F = 19c
68F = 20c
69.8F = 21c
71.6F = 22c

1 Like

Hi @mlchelp
Out of curiosity, I have been looking at the PR and it does not include the correction for the “stelpro-ki-zigbee-thermostat” subdriver, in case you want to tell smartthings about it.

I thikn is this PR

1 Like

Mariano, Zigbee Thermostat MC works fine for me and I will just continue to use it.

1 Like

Yeah, I’m going to switch drivers too. The update on my ticket last night from @SmartThings support was so ridiculous that I couldn’t see straight at 4am this morning. I gave them the benefit of the doubt that providing CLI logs, screenshots, and the github bug link that something would actually transpire from that. Nope, they’re useless as always.

1 Like

Been there done that many many times but they never seem to fix anything! If it wasn’t for Mariano and a few others on these forums, ST just wouldn’t work at all and I would have moved on to Hubitat or Home assistant.