Stories from a beginner


#1

I am a novice in technology. But I know just enough to be dangerous. Re-modeling the house and am going to try to integrate some smart home technology into the house. I am going to give it a run. I’ll try to document my story here from beginning to end. Here it goes.


#2

The smart thing arrived last Tuesday 1/26/16. I plugged it in and connected it to my router. I opened the app and followed the directions. While on the app, it just cycled and cycled looking for my hub about one hour. Lights blinked blue and red. Rebooted the hub, took batteries out, and disconnected it from the router. No luck. Reloaded the app. No luck. Did both several more times. Sent an e mail to customer support. Customer support responded the next day. Sent one more e mail to advise them of my problem. Customer service said that the blue and red light means that the hub is bad. Customer service said the would send a new hub. Should get the new hub in the next several days. Customer service was helpful.


(Keith) #3

I just got mine set up a couple days ago. It connected very easily, so no fear when you get a working one. And good luck!


#4

I got the new Smart Thing…it arrived as promised. I connected it to my router, plugged it in, put the batteries in, reloaded the app, logged in, put in the code, set up the location and … got a steady green light! Finished he setup and my hub is OFFLINE. I cannot figure out why the app is saying my hub is offline and/or why it won’t work… I’m going to look on line for some answers…


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #5

Just guessing that it may be downloading the latest firmware…?

Be sure to login to the IDE from a Browser where you can possibly get more detail:


#6

i figured it out. I went back into the settings and I reset My Location by Remove Location in the My Location settings. I think what that did was remove the first hub that I tried to sync with my I-pad, but had problems with the hub so Samsung sent me a new one without any headache. I think my I-pad was reading the first hub (inactive) as the primary hub and couldn’t read the second Active hub. My I-pad continued to recognize the first Hub as a functioning Inactive hub and so I was advised, by the program, that the hub was not connected. I conclud that the program couldn’t ignore the first Inactive hub over second Active hub (newly installed) with solid green lights. Starting over in My Location deleted the first hub (Inactive) and the program only recognized the second hub (Active). I wonder whether the program will ignore one of two Active hubs? It took me about 3 hours to complete the installation of the hub.

Tonight, I am going to try to install a couple of Osram led lights.


#7

So, I bought about six Osram Lightify lights. I plugged them in before I started the syncing process, like a couple days ago. They work really well when I flip the switch. I have been trying all night to get my hub to find my darn Osram lights. First I followed the directions. Second I did some research. Third, I tried the research. The hub just keep searching for the lights. I tried rebooting the lights, too. Humm. I am a little perplexed by this problem. After trying the rebooting process of the lights and not working, I am getting the impression that my hub might need an update, but I cannot tell if it is fully updated.

Thanks to Tgauchat I know know what an IDE is, sort of. I was able to log on to the IDE. I sort of now what I am looking at, but having a difficult time fully understanding whether the difficulty I am having is due to operator error (most likely), a need for an update, the wrong set up, or whatever.

I’m going to try to reboot the lights again and try a hard reboot of my hub. If that doesn’t work, then I may to have to get some help.


#8

I can’t figure out what I am doing wrong. My Osram lights won’t connect. What should I do?


(Tim Slagle) #9

Please contact our support team. They’re awesome and can definitely help.

support@smartthings.com


(David Tucker) #10

try this to get the lights into pairing mode


#11

Hi djtucker,

On the ST app search for new devices do you mean: Marketplace - connect new device? If so, I don’t see a “Switch On” or a “Switch Off” button. I really appreciate your help, but i am still a little lost. I’m not giving up.


(David Tucker) #12

Yes, you got the right place in marketplace. Whilst the app is searching, do the power cycle on the bulb, until you see the bulb blink…then leave it powered on and the app should tell you it found something


#13

I am such a dumbass. I finally figured out what I was doing wrong. For the last three days, I was driving myself crazy and was pulling what little hair I had out of my head. So this is what I learned: In one of my earlier posts, I stated [quote=“Novice, post:7, topic:37635”]
I plugged them in before I started the syncing process, like a couple days ago. They work really well when I flip the switch.
[/quote]. That was my problem. I plugged in all the lights first and every time I would flip the manual “light switch” the lights would blink three times (the indication that the light was ready for pairing). Then, I would flip the manual “light switch” to off, then on the Smart Things app I would tap “Connect New Device” and watch the app search for a new device. Nothing. I even tried to reset the bulbs, by turning the lights on and off from the manual “Light Switch” five times (the lights would blink three times). Then I would follow the same process over and over and over. It still didn’t work.

So, today, I unscrewed one of the lights because I was going to throw it out of the window to see how many times I could get the light to bounce before it would break. But before I did that, I tried plugging it into a different lamp and IT WORKED!!! WOW.

It appears that I had to connect each light one at a time and that I cannot rely on the MANUAL LIGHT SWITCH to operate as the on/off mechanism to turn on and off the light for the set up purpose. The MANUAL LIGHT SWITCH had to be in the on position first, then I had to screw in the light bulb. About 1 - 2 seconds later, the app found the light.

For any beginner, who can’t figure out how to connect the OSRAM bulb, like me, this is what I did:

  1. take out old light (do one light at a time)
  2. turn on light fixture and leave it in the on position.
  3. tap market place.
  4. tap connect new device
  5. screw in the new light bulb into the turned on light fixture
  6. It should only take 2 or 3 seconds for the app to find the light bulb.
  7. Repeat process for next light bulb.

That took four days to figure out.

Next, I guess I am going to try to figure out how to configure my lights and start setting the light up for automation and Echo connection. Wish me luck


#14

I figured out the lights and Echo. It was super easy to set up. Once the Osram lights were connected it was easy to identify them and put them in a group. (No problems with the set up). It was also super easy to connect the hub to the Echo. I keep walking into the kitchen, just so I can tell Alexa to turn the lights on and off, because I’m too lazy to get up and turn the lights out. I think we could easily install similar lights in every room.

But, over the weekend, I’m going to install two Wemo light switches to see how well they work.


(Dean Smith) #15

Ohh, they’re awesome? Can they help me? I have a problem with the Windows Phone app.

In that it still doesn’t work.


(Jason Hearne) #16

I’ll tell you how well Wemo works. you’ll spend half your time wondering why they are offline and the other half pulling your hair out. My advice to you is avoid Wemo if you can. They are crappy, the app is crappy, and they don’t play well with ST. This is all fairly recent too.


(Chris ) #17

I’m new here and actually looking for some help and came across your topic.I have masters in mechanical engineering and bachelor’s in electrical, before a bad head injury forced me onto ssdi ( at 33 with 2 young kids) I designed a lot of robotics for large scale gas and oilfield development, controls for autonomous high speed rail systems, overhead crane systems in shipyards and did a lot of the programming. Now all my modding and programming is limited to my kids toys, their robotics competitions, and whatever random monstrosities i throw together. That was until I won an Iris system from lowes and made it pretty much unrecognizable. Now im on to ST and latest project. I actually have, well had 6 arlo cameras running with no hub (just through Asus router and Swann NVR) with just a few bugs here and there but otherwise full functionality and then some. I will have to post code as soon as my son’s orange juice is completely dried out of laptop…I do know groovy and Java quite well, right now I have 2 of the Samsung nooks acting as wireless touchscreen control pads using 2gig Technologies TS1 Z-Wave Wireless Touchscreen Keypad’s interface just hacked up and modded a little bit, Philips hue stuff in my kids bedroom, garage,sheds, monitored by aeon, and a nice laser setup from genie hooked into an aeon labs panic button as a very reliable and most accurate driveway sensor I’ve ever had.
Now the part I’m looking for help with is where in community to go to get list or guidance on devices/apps that integrate flawlessly or with little effort. Right now I have cast on one hand and nerve damage in index and middle finger of other and am right in middle of transitioning to smart things and writing code. I am doing most of it from my Galaxy S6 and Galaxy Tablet, so a nudge in right direction would begreatly appreciated. But for now I need to finish off the easier stuff until cast is off. One of my major is that I know there is excellent code and help on here is my schlage Camelot. I’ve tried it all and get different error each time even using latest version. I need 6 codes, I need timestamps on codes (for my kids), I need locking / unlocking of door to arm/disarm system, smoke/CO alarm to auto unlock, use the built in pressure plate/ tamper alarm and somehow get it to recognize different modes of alarm. I managed to do this on Iris (which was only decent in version 1 because so easy to access and change their " encrypted, complicated code" what a joke.

Any guidance would appreciated beyond belief! Just typing this took forever especially with cast on dominant hand. As soon as it is off I will start uploading code.

Thanks again

Chris


Which Schlage Connect Lock Device Type Handler to use as a baseline?
(Keith) #18

Here’s a link for officially blessed off SmartThings Compatible Products. So far I haven’t had any issues with anything on the top of the list, so that would be a good starting point for things that already work. The bottom SmartThings Labs section is a list of unblessed products that may or may not integrate.


#19

Hey crussell, I’m sorry that you sustained a brain injury. I wish you the best. The smart thing hub with echo is nice to have. The combination really makes a normal everyday task, that most people would probably take for granted, and it reminds me of how lucky we are to be in a position to have this type of technology in our everyday life. It is even more incredible that the manufactures of these products have made it relatively easy to install, even for someone who for the most part only uses a computer for writing. I, unfortunately, don’t think I could dole out any advice about what to get or how it is programmed. I really wish I could help you. But, I would enjoy exchanging stories about your installation successes and maybe you could show me a thing or two, or a hundred.


(Chris ) #20

Thanks,

Fortunately only actual “brain” damage was my ability to convert short term memories into long term ones… so if I ever say Im going to post or send or explain something one day then the next I continue on with another topic or whatever I apologize, it just never committed itself to long term memory. What put me on disability is the exacerbation of my fibromyalgia, chronic pain, and spastic muscles which dont let me sleep. But what are you going to do, sitting is too boring so I hack and mod anything and everything I can. It sometimes takes longer especially in winter, summer days drain me too quickly, but at least then its fishing time.

This is an easy one, if you read my post a few above it I didnt do it the easy way the first time around but just changing out one part, swann nvr to samsung one made it basically dummy proof…


I didnt even go buy a new on with that thought I was just having problems with old one. You are just changing the cloud server to your hard drive on NVR (or if you dont have one hook a 3.1 usb ssd up to your router). You dont even really need a smart app to schedule anything, plenty of free android apps like ipcam viewer, that will let you set it up or my favorite and not just because Im a developer for their computer vision program is https://www.sighthound.com/products/sighthound-video Ive been trying to get this to integrate for months, if you arent familiar with it it allows you to view and even control almost any ip/network camera. If you have hd analog or just regular analog (cctv) a cheap encoder will allow those too all with just one app. Well two thats why ive spent all my time trying to make it work, then sighthound on a 2tb hd on my Asus RT-AC5300 router would take everything that wasnt originally meant to go to NVR (I think thats why 1st one fried) When this cast comes off in 20 days then i can get code uploaded and maybe get some help