STHM Not Working

Smartthings in general has been pretty reliable until now

Massive problem for me that STHM has decided it doesn’t want to work anymore

Under the home monitor no matter what I do it just says “Security Tap to set up” and I’ve lost my arm/disarm buttons

I’ve tried removing everything alarm related and reset it 100 times but I can’t get it back to life, also noticed in IDE it says “Alarm System Status - Armed (Stay)” even if I completely reset it

What’s going on?

What is the language on your mobile device set to?

Language? English UK…

Try changing it to US English and see if the buttons return

Odd suggestion but no, no difference, just says tap to setup

I have even tried downgrading the app as I wondered if it was the newer version but nope…

Not that odd, there is a known bug where the app on devices using a language other than US English can experience issues. Two are graphs not loading and the buttons in STHM not loading.

Did you refresh the app after you changed the language… perhaps force quit and open the app back up.

If still not resolved, only thing I can think of is to uninstall STHM and reinstall. Or contact ST support through contact us in the app. Or perhaps others in the community might have some ideas on the issue.

1 Like

How do you fully uninstall STHM?

Menu > SmartApps and click on More Options (3 dots) in the upper right of the screen and select Delete, then select SmartThings Home Monitor

1 Like

Can’t see that option anywhere, maybe that’s only on the classic app? I can only “reset” it which I’ve tried

no, that’s the new app.

menu (3 bars in the upper left of the screen)
More Options (3 dots in the upper right of the screen)


I’m a moron lol, thanks I’ll give this a go

It’s back! Thank you so much!

This is a big pain though as now have loads of automation’s to redo :frowning:

Same issue, I’ve managed to remove the smartapp as above but after reinstalling it the issue comes back. There’s been multiple issues over the weekend. I’m about done with St.