STHM & SHM Server error

So a couple days ago I was suggested to migrate to the new app.
To tell you the truth, I am already working with both of the apps for more then a year, every app has its advantages.
As a part of my home, I am working with SHM (And now with STHM) to secure my home, using third party alarm system as well that is arm/disarm depends on the STHM status.
After the migration I did my tweaking and everything worked just perfect for a couple of days.
Yesterday, I went to sleep, the system updated its state to ARM-STAY, and everything was just perfect.
Today morning, I have realized that the STHM is not disarming from the automation, so I’ve opened that apps.
Both of the new app (SHM) and the classic app (STHM), are trying to load the security widget for several minutes and then shows “server error”.
The system is stuck on arm-stay, and I still getting alerts when some one opens the door or a window. Also lights and siren are starting to work due to this alert.
I cant disarm the system - The widget is not working, the automatons cannot change SHM/STHM state, has to disconnect some devices (like siren and stuff).
I have tried to force close apps, clear data and cache data, reset the smartthings device… noting worked.
I have read that I can reinstall SHM and STHM smart app from the IDE, but couldn’t find those.

help… :pray:

You cannot use them both at the same time. A bit like having two anti virus products running at the same time. They will both constantly try to override the other, so neither will work properly.

I am not trying to use them both, just the new STHM. It worked just fine until today.
Now I cannot do nothing , getting server error all the time. Screenshot attached.

Any steps I can do to revive it?

If the language of your phone is not set to a default of US English, try changing that and see if that resolves the issue. I remember seeing where another user had seen this issue.

FYI… removing STHM is done from the app. Go to menu (3 bars in the upper left of the screen), select Smartapps, click on More Options (3 dots in the upper right of the screen) and choose delete, then select STHM.

Removed smart home monitor from both apps, and added it back only to the new one.
That solved it.