[ST Edge] ONVIF-compliant IP Camera Motion Detection & Video Streaming - Testers Wanted!

@Dennis be prepared to wait if you open a support ticket. I am also missing the camera group. I have many cameras added to the Smartthings app but can’t get the Create Camera Group option. I have tried uninstalling, clearing data. Nothing seems to solve the issue. I would be interested in knowing who got it to appear after a while and what they may have tried. Since my support case is about 1.5 months old and I am no closer to getting a resolution. I have heard nothing from the engineer and the support person keeps telling me they are still waiting for an update from the development team. I even asked if they can escalate the issue based on the age of the case. They say it is escalated. Very slow process

Thanks for sharing, that’s useful insight about the resolution progress. I have not yet opened a support ticket because I didn’t think it would yield much result; ergo, based on personal observation, ST devs tend to address problems which are based on internal priorities. However I had wondered if adding another real camera, instead of virtual, would fix it but it doesn’t seem likely from what you’ve said.

Seems to have been an update by ST on device rotation, previously rotating a device with a camera on screen failed to rotate and resize the camera image

Now device rotation successfully rotates and re sizes the on screen camera feed

Icing on the cake would be to allow LAN cameras to display stream on there own device page and subsequently to display on a capable Samsung Tv, i continue to hope

That’s a good sign!

It does show a commitment to retain camera integration and offer some fixes


The latest version of my API Browser+ web app adds a new feature to create a camera group. So if this ability has disappeared from your SmartThings app, try using this tool so you can get your camera group created. Note that you will need at least two camera devices to create a group. If needed, you can create a virtual camera device using my vEdge driver, and include it in your group.


There are ST oddities still remaining when adding a camera

For whatever reason one if my cams was using test driver and not reporting movement at all, i deleted it and re added using the current driver, the camera was found and movement is now functioning perhaps a bit too well but thats for another day and probably my settings

But, the freshly added camera could not get added to an existing camera group, the camera add part of the camera group could not see the camera existed, it took about an hour before the camera became available to add to a group

Hi Tod, Tod would it be possible to disable some of the settings in a camera config, perhaps with an on off button on the device page

My cams handle all the settings such as motion timeout and revert after, i find adding your settings into the mix ontop of the cameras own settings unnessaraily complicated, perhaps even a parameter value on each setting that disables a setting, perhaps typing the word off in a value or 100

Disabling a setting in the camera driver would then leave the camera in full control

Is it something that could be added ?

Hi guys,

Someone else with this issue:

All cams is off to stream but it was responding normally.

@TAustin could you help?

In device settings:

  1. You can disable the motion auto-revert
  2. You can effectively disable the minimum motion/linecross/tamper intervals by setting those values to 0

@nayelyz - Please see @Dienzora’s post above.

I’ve just started getting this too. Looks like SmartThings may have disabled video streaming in the app. The driver is not getting any request for the streaming URL. Can you look into this please?

Hoping this is just a temporary issue… :unamused:

Thanks for the tip on setting zero values Tod

So far, i see no disruption to video streaming, region issue perhaps ?

Thanks for reporting that - maybe video streaming is down on just some servers.

My outdoor IP cams that use this driver are all down.

My indoor Nest cams with direct integration are all working.

Hi, @TAustin

By this, do you mean that when you click on the plugin to see the video stream, no command is sent to the driver?

I asked the team related to the official integrations about video streaming and they haven’t got reports about issues in the service, so, it doesn’t seem a general issue.

I would love to know if the team have any intentions of allowing users LAN camera streaming

My holy grail is viewing my LAN cameras in the Smartthings app on my TV

So while this works, I’m using it to turn on a light and then automatically turn it off after a minute, but the problem is that it it triggering motion and it cycles non stop, what kind of combinations of settings can I do to alleviate this issue?

When you have a camera group defined with two or more cameras, and you click to open the camera group, normally that initiates a request to the respective drivers to get the stream URL and then the video stream is displayed for each camera. What is happening now is that when you click on the camera group, it just displays the blank stream screen for each camera with the word “Off” as seen in this post. And no request is ever sent to the driver for the stream URL.

Have you tried adjusting the device Setting called ‘Minimum motion-active interval’? This will limit the repeated motion triggers. So for example, if you set it to 300 (seconds), you’ll only get motion activations every 5 minutes at most.

The other thing is to check your camera’s own settings and see if there are any options you can adjust there.

Decided to give this a try and got some interesting results.

I have 9 cameras from Amcrest. All have static IPs. Everything is on the same subnet. All but #208 are hard wired. All but 208 are port forwarded through my NVR.

I enrolled in the driver and searched for new devices. All 8 cameras showed up and I renamed them and added admin username and password. All other settings are default. Video Stream setting is Sub Stream and all cameras indicate resolution of (varies)w x 480h

All but 208 responded immediately when refreshed and I was able to get reliable motion detection.

I did not have the option to create a camera group in the Android App.

I went into the API browser and was able to create a camera group and I also added 2 virtual cameras just in case. I was unable to add the virtual cameras to the group they don’t show up as an option.

On doing this, camera 209 showed up in the camera group and gave me a single current frame(time-stamped) and displayed “LIVE”. None of the other cameras gave me a picture.

Reading the notes on your github I saw that the password needs to not have an ‘@’ in it, and of course mine did. I figured I should give myself the best chance of success before reaching out so I added a user account to each camera with admin rights for now to see what would happen. I also noticed I had ONVIF authentication OFF on most cameras so I turned that ON.

Once I did this, the combination of both of these changes killed most of the connections in SmartThings. The notes below indicate that a lot of that was due to the ONVIF authentication setting. I also used a third account as I suspected possible issues with the case-sensitivity of the password based on the way it was showing on the setting screen. In any case, having an ‘@’ in the password didn’t seem to make much difference. Camera 209 seems like it indicates there might be a issue with the case-sensitivity in the way the settings store the login info.

As it stands now for testing I am using the admin passwords on each with ONVIF authentication turned on where they allow it to still respond. I have changed my admin password to include no special characters.

Occasionally, I’m able to get one frame out of 207, 209, and 210 when I initially open the camera group but it takes 30 seconds or longer and never refreshes. Motion sensing remains very reliable.

Amcrest cameras are made by Dahua if that makes any difference.
If there’s any further info or logs you need, let me know.

Thank you

Each camera has three user accounts (note capitalization) and all three users are admins with full control for the purposes of this test

admin   A****111
User    A****111
nvr     a****111

Camera number is just the last 3 of the static IP
Model number of the camera is also listed. Those ending in E are POE cams

201 IP2M-842
ONVIF Authentication Must be OFF

203 IP2M-842E
ONVIF Authentication Must be OFF

204 IP2M-842
ONVIF Authentication Must be OFF

205 IP2M-852E
Only admin password responds with ONVIF Auth ON

206 IP2M-841
Only admin password responds with ONVIF Auth ON

207 IP4M-1026E
Only admin password responds with ONVIF Auth ON

208 IP2M-842 (on Wi-Fi)
Not Responding

209 IP8M-2496E
No option for ONVIF Authentication
admin: Responding
User: not responding 
nvr: Responding (?!?)

210 IP4M-1026E
Only admin password responds with ONVIF Auth ON