[ST Edge] Driver for Ring Keypad 2nd Gen

As far as I know, you cant pair the device to 2 hubs or shouldnt. So the device would need to be reset, and then connected (paried) to the ST hub.

Without any configuration, when you arm ST from the APP, the keypad should respond accordingly. You can then build your routines to arm, disarm, etc. This is where you get into the realms on your own as everyone has a different setup.

For me, I do both Away Armed, and Disarmed using presence and for me it works extreemly well, only thing I use the keypad for is to set Home Armed at night, as a backup if presence doesnt work or for a house sitter to gain access if I’m on holiday.

1 Like

Has anyone experienced recent connectivity issues with the keypads and this driver? For the past several weeks it’s been really spotty and I’m not sure how to reset or refresh short of removing and re-adding again. Sometimes the keypad will arm and disarm and sometimes it will not. One of my keypads is within 4 ft of my hub.

Could there be any issues with all the ST firmware updates??

Yes.

As @SlySi mentioned, the physical keypad can only be used with one system, or the other, not both at the same time. Once you exclude it from your ring base station, you can add it to your smartthings/Aeotec hub, but then your ring account will no longer see it. The same is true for the ring contact and motion sensors.

1 Like

I am having the exact issue that you had, and your post is the only one online that I can find. I am trying what you said - multiple cords etc, place on top of hub. Did you find the exact issue? Maybe I should return my keypad for another? I am so frustrated. Any help is appreciated.

Welcome Plan_9

My go to wouldnt be a faulty keypad, more like a pairing issue or the correct driver isnt installed properly.

Completely remove the device from ST and factory reset if it has been connected to any other type of hub (Ring), ensure you have enrolled to (or installed) the correct driver from hmorsti and then follow the pairing instructions here.

Once paired it should show as ‘Ring Keypad’ or similar.

1 Like

It actually seems that it won’t pair because the fingerprint of the Canadian Version is different. Getting a USA version to test instead.

@hmorsti may add the fingerprint for you, I believe he has added a couple already. You could also download the driver, add/change the fingerprint yourself and install it manually using the CLI, there is a post from Nov 22 above explaining how.

Hi. Did you find the driver for iris keypad?

I had some questions about some of the capabilities.

We have an alarm with siren, strobe, both, and off commands. Siren seems to do both. Is this a quirk of smartthings or the driver? The siren for medicalAlarm also does not make a noise and just strobes instead.

Then there’s the refresh and monitoringActivated capability and I can’t quite tell what this does, they make no noise on the keypad itself and nothing appears to change. There’s also the chime and I haven’t been able to use that in the app routines but was able to access it via the rules api.

Just curious what these do and if they were necessary.

There’s also the other feature that I noticed was the Bypass required. Which I believe occurs when a sensor is open and you try to arm. We have the bypass required tone but there’s no functionality to recognize the enter key to register input. So say a sensor is open, a virtual switch is turned on. When the home attempts to arm if the vSwitch is on, then the keypad plays the bypass tone. The vSwitch will turn off if the keycode is input and the check/enter key is pressed allowing the home to be armed.

I am posting this so others can see my exact issues.

I have tried to install the ring v2 driver for 2 different v2 hubs. One was on a factory reset hub. I accepted invites and installed the driver. When installing, it does not identify the keypad as ring, it installs it a as a Z-Wave device. The installation promps for a qr scan, but the scan results in long processing tIme resultung in failure. I have used both android and iPhone to try to install on BOTH hubs to No luck. When i try to install the device, I get a message that “the QR code scanned is different from the one you originally selected” Add instead does not properly install it.

HMORSTI drivers show as being installed on my hub. The driver on “zwave device” cannot be changed after being added to ST

The Model on back of keypad is 5AT257





I can successfully, exclude the keypad, restart hub (no batteries inside) and it still wont read durung the next attempt.

I apologize for my newb level of smartthings in advance. Im a quick learner and have a level of understanding beyond the average person. Any help would be appreciated as i am going crazy trying to get these keypads to recognize.

Thanks,

1 Like

The 1st you should do is go to the ST Advanced Web App Samsung account and check the fingerprints (Mfg. Code & Model). If they are all 00000000s exclude the device and repair it next to your hub.

If it is not 0000000’s post the fingerprint here and ask the developer if it is included in his driver. If it is not ask him to add it.

1 Like

Thank you for responding. No matter how many times I exclude and repair, ST will only show 0’s for mfg code and model. Any suggestions?

Are you pairing the keypad right next to your hub? You need to do that when you get 000000’s.

I can try to pair side by side or on top of hub, It seems to only add it as a Z-Wave device with all zeros. I keep trying to add and exclude it and re-add it. I have tried both security levels when adding. It only shows up 0’s for me. When trying to scan the qr, it processes indefinately as the fingerprint doesn’t match.

You could try adding it using Scan Nearby, or Partner devices > Z-wave. Initially I would try skipping the security part.

I’ve scanned nearby, qr code, partner devices z-wave. Each time after connection failure, I have done z-wave exclusion (successful) then a 10 second reboot of hub (no batteries inside v2) before trying to re-add. Each time I only get 00’s on web interface. Regardless of keypad placement during pairing attempts. Thank you for your help in this matter.

You are welcome. Sorry I didn’t help you solve your problem.