[OBSOLETE] Rboy enhanced zigbee keypad DTH

Is this a device handler or a smart app?

So it works with Lock Manager but does it work with [OBSOLETE] Keypad Coordinator - Bring out the power of your Keypads

1 Like

It’s a device handler and it works with all the legacy/older SmartApps that relied on the custom keypad DTH (see first post).

It has added new capabilities to allow it to work the SmartApps that use “lock” capabilities like Lock Code User Management, lock manager and SmartLocks.

What are the main differences or advantages from this one?

Does it work with ArnB’s Delay and Xfinity 3400?

Thank you!

This DTH retains compatibility with the older DTH so works with the Apps you’ve mentioned (on request from users, see below)

We’ve added new capabilities of locks and user programming so that it can be used with SmartApps that are designed to work with locks. It has also new additional features like Alarms, Panic buttons for the IRIS keypads v2 and v3, enabling/disabling the keypad and lots more.

So you can use it with the SmartApps you’ve mentioned and the newer Lock/User management SmartApps (at the same time).

Yes it’s compatible with the Xfinity 3400 (see the screenshots) and the IRIS 2405, we’re working on adding more keypads models to it. If you have any requests for specific models please send them in.

I have a problem, I replaced the standard Centralight DTH with yours and the status says unknown. Did I miss something? Is that because I have no door locks? If so it would be nice if it could be removed if no lock present.

That’s the “lock” status, since it’s never been used as yet it’s showing “unknown”, just tap on it and it’ll initialize itself.
Not sure what you mean by remove since this is a lock DTH so it will show the “current” status of the last action taken (locked or unlocked)

EDIT: We have a new app coming out shortly that will complement this DTH and would probably address your question for the use of the lock

I have the device handler installed and am using your “Door lock code user management with notifications and automatic relock, Lock User Management v07.01.00” and am having an issue.

I have configured the lock “Xfinity 3400-X keypad” lock\unlock actions to the following:

Keypad Unlock Actions: Run a routine, Change mode to Home and Disarm Smart Home Monitor
Keypad Lock Actions: Run a routine, Change mode to Away and Arm Smart Home Monitor to Away
Manual Unlock Actions: Run routine, Change mode to Home and Disarm Smart Home Monitor
Manual Lock Actions: Run a routine, Change mode to Night and Arm Smart Home Monitor to Home

I hit one of the three button on the top of the Xfinity keypad and enter my code. It beeps to confirm and doesn’t change the SHM mode, the mode stays on Disarmed. If I manually change the mode to Armed(away) or Armed(stay) and push any of the three buttons on the top of the Xfinity keypad and enter my code, the SHM mode changes to Disarmed. If I just put in my code w/out pressing any of the three buttons on the top of the Xfinity keypad it also changes the SHM mode to Disarmed if in any other SHM mode besides Disarmed.

I’m not sure what I am doing wrong, is there something wrong w/ my setup?


Update to the latest version 07.05.01, it adds support for the keypad locks - you should also see a new option to directly arm/disarm SHM from the keypads.

Ok I’ve updated to 07.05.01. I did see a new option under lock/unlock actions for the xfinity keypad unlock actions that now says “control smart home monitor using keypad” instead of what it used to say and still says under Manual Unlock Actions “Disarm Smart Home Monitor” but I haven’t found the new option to directly arm/disarm SHM from the keypads.

Where is that option? I’m still not able to arm w/ the new version. I can disarm but can’t arm stay or away.


This is it

EDIT: And I verified it’s working fine with both locks and keypads.

under “Keypad Unlock Actions” the setting for “Control Smart Home Monitor using keypad” is enabled, it will disarm the SHM but I can’t for the life of me figure out how to get it to Arm (away or stay) the SHM.

is there a step by step walk through manual that I can follow to ensure I have the proper things setup?

I chose the option to “Seperate actions for each door” and then configured the keypad and manual lock and unlock actions but it just won’t work.


You’ve done it, that’s it (see the first post for step by step).

I tested it here with the Xfinity keypad, IRIS, UEI and Centralite and it’s working fine with all of them. I suspect something else may be going on with your account. Best way to check, open IDE Live Logging, Tap the Away button on your keypad, enter your 4 digit code and look at the logs. The SmartApp should send say sending an arm away signal to ST. Then look into your SHM logs to see what may be going on.

This is what you’ll see in your logs

8:54:34 PM: trace No individual routine configured to run when locked via keypad for Iris 3405-L Keypad
8:54:34 PM: trace Did not find per user lock actions, falling back to global lock actions
8:54:34 PM: info Arming Smart Home Monitor to Away
8:54:34 PM: trace No user Test specific lock action found, falling back to global actions
8:54:34 PM: trace Lock event name lock, value locked, device Iris 3405-L Keypad, description Locked by “Test”, data {“usedCode”:“1”,“codeName”:“Test”,“method”:“keypad”,“armMode”:“armedAway”,“microDeviceTile”:{“type”:“standard”,“icon”:“st.locks.lock.locked”,“backgroundColor”:“#00a0dc”}}
8:54:34 PM: trace Iris 3405-L Keypad locked by user 1 via keypad

It’s possible that your actions/routines are interfering with your SHM, turn off all actions and turn them back on one by one until you see which one is interfering.

In addition to the above, on the first page of the SmartApp, scroll down to the bottom and under advanced settings and enable Detailed notifications, now it’ll send you a notification for actions it’s taking (arming/disarming, running routines etc). That will tell you if the SmartApp is sending the signal to arm SHM.

1 Like

I’m experiencing the exact same issue using a Centralite 3400-x. Disarm works as expected, however, I can’t arm SHM no matter my settings.

My issue was that I had specific actions defined for locks per user. I was trying to setup the General Settings\Lock/unlock actions and the user\custom actions/notifications settings appear to conflict. I removed the General Settings\Lock/unlock actions and defined the user\custom actions/notification settings actions and it is working good now.

The only minor issue I have now is that when I ARM(AWAY) or ARM(STAY) using my phone app (I have the rules setup to lock the Xfinity) the keypad doesn’t turn red like when it is armed from the keypad itself. I’m not sure if that can be fixed or not, if so that would be awesome. Right now we are putting in our code everytime we can to leave the house to disarm as we don’t know the SHM state w/out looking at our phones.

Glad you figured it out. User actions take precedence over general actions when defined.
You can define the direct keypad arming/disarming also in the user specific actions so that some users can arm using the keypad while other can only lock/unlock.

This is by design, in this instance the keypad is being used as standalone lock device and not a general security keypad. The purpose of the light is to show the status of the lock device (locked or unlocked). So when you lock it via the keypad it turns red and when unlocked it’s green/white (depending on the keypad model).

so if you lock the keypad from the keypad it turns red, but if you lock the keypad from the smartthings app it doesn’t, right? what’s the difference? The keypad is locked, knows its locked, but only turns red if you do it from the keypad. So it doesn’t seem to have anything to do w/ your smartapp, has something to do w/ the device itself? Or the device handler?

Part of the issue is what’s the status to display when locked, some keypad have “partial” or “on”, other have “away”, “stay” and “night” modes. The DTH cannot decide what mode the keypad lights needs to be in since it isn’t a one to one mapping.
The led state is set by the app and not the DTH, the app controls what led to show, in this case when the user directly arms/disarms SHM the app updates the LED to reflect a successful processing of the user command.

BTW, by ST design DTH’s cannot read SHM state so it’s difficult to synchronize the keypad LED’s with SHM, it always needs to be done by the app. In this case the app is reflecting the last successful command sent by the user on the keypad.

Always open to suggestions and feedback

This has now been resolved. I had per user actions defined and was attempting to configure using the general lock/unlock actions.


I’ve tried resetting the iris keypad many times and following the setup instructions above where the pairing button is pressed while 1 (or 2) batteries are put in. I have the device handler installed but can’t get it to ever show up when I try to “Add a thing” from my SmartThings app.

Any other tips or steps I might have forgotten?