Sonoff SNZB-01 pairing

I use:

I do find that if you use ‘Scan Nearby’ it seems to pair silently (nothing seems to happen but when you look afterwards it has paired).


I was able to make it work. Are you seeing the button status change in the app when you press the button?

For me, SmartThingss detected button presses but I could not assign any actions. Actually, I could assign actions to some devices but not others. So instead I used WebCore which worked with the device I want to use.

definition (name: "Sonoff ZigBee Button", namespace: "smartthings", author: "Darren Blanchard", runLocally: true, minHubCoreVersion: "000.022.0002", executeCommandsLocally: false, ocfDeviceType: "") {

i basically changed runLocally: true to runLocally: false

1 Like

Hi All

i have a new issue that just happened with SNZB-01 . I have been using 2 of these for a month now with no problems. So i bought a few more, now when i add new buttons it wont save the description of the actions for each assigned button press.

The button works fine, single , double and held all work and perform the actions i have set, but in the app it just shows “No actions assigned” its a bit annoying as it means if i cant remember what a button press is assigned to then i cant look at the device in the app to check.

anyone else have this?

BTW my 2 original buttons still show the correct descriptions for actions that were set previously but if i try to add a new action it no longer shows the description for this anymore either

see this below , all 3 types of pressing have been assigned but only the pressed one that i setup 2 weeks ago will show the correct action description ( the other 2 still work when pressed though)

ideas ?

SNZB-01 does pair but I can’t use it. it shows with the name Thing.
I have followed instructions to install device handler before pairing.
I am trying to use it from the Android platform: it says it is offline.
So I try from the iOS device, it says it is active. but there is no additional info - just that it is connected (no battery level no nothing).
However when I am trying to use automatisation it is not visible as a device that I could use…

You may have to manually change the device type on the IDE to sonoff zigbee button. In the IDE go to devices, pick your button, chose edit at the bottom, and then change the type to Sonoff zigbee button. It will be near the bottom of the drop down list. That is the device handler you should have loaded
See post 6 above for more details.

Thanks for prompt replay. Sonoff is not listed among available types.

Go to the very bottom of the list. Custom DH are not in alphabetical order. They are at the end of the list.

1 Like

indeed! the very last one. :ok_hand:

but still not full success.

attached is status on browser, in android it says “checking” (translation - I don’t know how to change language settings in the app) .
in iOS shows crossed cloud icon - so it is off line apparently. Does not show any history nor battery level.
IDE says however it is ONLINE

Battery level on many devices takes time to show up, so don’t worry about it till tomorrow.
Have you tried the refresh button in the web app?

Dear Paul,
Thank you very much for all the help. It seems to me that as a battery-operated device its range is shorter - it was too distant from the mesh (other devices like plugins and switches worked well as it is an adjacent room to the hub). When I moved it closer it started to work! In fact, in another home, I had similar problems with the range of SNZB–4. But the latter did not require additional actions with Device Handler. BTW I wonder why sonoff does not make life easier? is it difficult to have it compatible from the start?

You are welcome. I’m glad you got it working.
Easier would be nice. After you do the 1st custom DTH it gets much easier.

This code working for me Thank you.

1 Like

Following your instructions I managed to install it.
The only trick, after installing the DTH, was to put runlocally: false (as somebody explained before).

Thanks for your contributions.

1 Like

After spending too much time with the Darren Blanchard code, I tried the Anidea code above, and it worked the first time perfectly. It still shows standby on the battery, but it registers the buttons presses.

1 Like

I would like to use the Sonoff SNZB-01 button. I have installed the device handler, published it, updated the device type, but I still cannot figure out how to add the device. The device type does not show when I select Sonoff in the add device procedure in the ST app. What am I doing wrong? Thanks.

The only thing you are doing ‘wrong’ is expecting it to be listed.

If you use ‘Scan Nearby’ when adding a device you should get more joy.

I have tried that with no success. Any advice? Should I press the Paring button multiple times? Thanks.

Use eWeLink switch to pair it.

1 Like