Sonoff SNZB-01 pairing

Will try it. Thanks.

John V.

I would really like to get the Sonoff SNZB-01 button to work with ST, since the ST button is no longer available (you can find them on eBay, but they want a ridiculous amount for them.) Here are the things I have tried without success:

  1. Add the Sonoff Button DH and publish it.
  2. Try to pair button with “Scan Nearby” - No success
  3. Try to pair with eWeLink Zigbee Button - No success
    4 . Tried to pair using Sonoff Smart Switch - No success
  4. I have noticed that, in the IDE My Devices tab, there is a button labeled “Create Device.” I have tried using this to add the Sonoff. (I.e, eWeLink) button, but it seems to have no effect. What does Create Device actually do?

Anybody have any ideas? I can use all the help I can get.

Thanks.

The DTH shouldn’t be a factor in whether the device pairs or not. It will, however, make the difference as to whether it just pairs as a ‘Thing’ or something more useful. Starting with a device with a battery properly fitted and the back off, the process should be:

  1. Select ‘Add Devices’ in the app.
  2. Select ‘Scan Nearby’.
  3. The LED on your hub should flash green (if you have more than one hub you are prompted for which one to use and the selected one will flash green).
  4. Use a fine pointed implement in the hole to press the RST ‘button’ on the device and keep it pressed for about five seconds until the red LED flashes three times.
  5. Wait.
  6. If the device pops up with an invitation to rename then it is paired.
  7. If the pairing process times out take a look to see if the device was added anyway (it would be in the room called something like No Room Assigned in the app or listed in the IDE) as sometimes they pair silently.
  8. If the device has paired use the IDE to change the device type if necessary.

How does that match up for you?

By the way ‘Create Device’ will create a device object for you. For some device types this is equivalent to adding a device (for example a virtual device which only exists as the handler code, or a Wi-Fi device that is already working on the network). However Zigbee and Z-Wave devices need to have been through a handshake with the hub first for the Zigbee address and Device Network ID to be meaningful and Create Device doesn’t initiate that.

1 Like

Thanks so much for your reply. You are absolutely correct. After the “Scan Nearby” timed out, I had a new device named “Thing” in “No Room assigned.” I went into the IDE and changed the device type to “Sonoff Zigbee Button.” It then showed up as a button with the usual “Pressed,” “Double Pressed” and “Hold” options. I then tried to set up an automation using it to control a Zigbee Smart Plug. Everything went fine until I hit “Save.” The Create Automation stalled and never allowed me to touch “Done.” Any ideas?

John V.

Not really. If that driver still contains the metadata for running locally you might try removing it (runLocally: true, minHubCoreVersion: "000.022.0002", executeCommandsLocally: false,) as that will confuse things anyway. Whether it will baffle the Automation creator is another matter.

Well, things have gone from merely strange to really weird. I got the button to let me assign an action to pressed, but, when I pressed it, nothing happened. I then deleted the Sonoff button and changed the DH to RunLocally false. Now, not only am I unable to add the device, but all the devices that were showing in “No Room assigned” are now showing in “Broom Closet.” Go figure.

I find that when I add devices with ‘Scan Nearby’ (and possibly direct from the IDE too), they all pop up the next time I add a device by brand or type and get moved to whatever room I had selected for the new add. It is rather irritating. I don’t think I’ve seen it happen without that explicit new add though.

I have successfully added 3 of these devices today using the orangebucket/Anidea-for-SmartThings DTH. However some observations… These did not work at first just after pairing and editing their profiles via the IDE. They showed up but no events logged. What I noticed was that the NextHop value exposed by the the IDE for the new button was zero (coordinator addrerss I think). But if I took the battery out and then in when next to the hub the NextHop value would change to 65535 (broadcast) sometimes - if it was 65535, the button works (including battery status).

So my guess is that these buttons that work might just be doing so because they are broadcasting all of their events…

For these three buttons I have yet to see a Route be displayed via the IDE Devices - just NextHop.

My questions are as a zigbee newbee: Is it ok for a device to just broadcast it’s events? Does this cause other battery operated devices (that are asleep) to wake up and burn battery?

Best,

Rich

Hi, Guys, there are two versions of SNZB-01.

The first/older one is single press only. Model number in IDE is KF01. It pairs as a “Zigbee Non-holdable button”. You can change the DTH it to “SmartSense button” and it works locally. It’s faster than the Smartthings Button.

The second one supports single, double and long press. This is the one most of you have. Model in IDE is WB01. It pairs as a Thing and requires custom DTH to work.

Both look exactly the same, including the markings on the back.

The KF01 is the only local zigbee button I can find, other than Smartthings Button.

1 Like

Hello,
I have been posting for help in the past. Paul_Oliver helped me to set up successfully SNZB-01. Now I bought a few switches and tried to pair with another smarthings hub (in another home).
Everything seemed to go smoothly. It showed in the app, I can program actions, however, it just does not work (physical pressing does not trigger actions) . I have tried another handler GitHub - orangebucket/Anidea-for-SmartThings: Assorted SmartThings bits and bobs.
without success either. I even tried the second Sonoff (out of the box) with no success either.
Also, in both cases battery is showing 0%. Even after hours from pairing.

This code working for me!!!
Thank you very much!!!

P.S. My device model in IDE, is WB01 !!!

what DH did you use?

Finally got it to work after 3 days of trying various DH’s.

After reading some comments on this thread I decided to try Anidea DH .

I started by removing all previous DH’s that I added previously for this Sonoff button, and I also removed the device itself from the smarthings app.

After adding the new Anidea DH, I went to Add Device on ST app and instead of picking “Scan nearby” as most suggest, I switched to “By Brand” and looked for “Sonoff” There were 2 Sonoff entries: one “Sonoff” and other “SONOFF” all uppercase. I picked the uppercase one and picked Remote/Button.

Then during pairing, I followed the normal procedure of pressing and holding the RST button on the back until the lights started blinking. Waited patiently and it eventually added it as a “eWeLink Button” instead of the dreaded “Thing”.

Although this DH gives you options such as Press 2,3, 4 times and Toggled down 1, 2, 3 times… only Single Press, Double Press and Held are supported.

Battery reporting works too!

Hope it helps someone.