Sonoff SNZB-03 Motion Sensor paired fine, I deleted the device from hub and now can't pair it again

I bought 5 of the Sonoff SNZB-03 motion sensors. I paired them all to my ST hub (V3) and they were working fine at first. Then 2 of them went offline. It appeared to be a signal issue, I realized they were all communicating straight to the hub since I had paired them all right next to the hub.

Before learning that you can heal the Zigbee network by powering off the hub, I thought I would just delete the devices and pair them again.

I deleted the devices from the ST app, but then repeating the same pairing steps yielded no results. Any devices that were previously paired to the hub aren’t able to be added again. Does anyone have any ideas for pairing these sensors again? I tried removing the batteries and holding the pair button down for about 30 seconds (5 seconds puts it in pairing mode) but nothing works.

what device handler are you using for them?

login to IDE and check that they were actually deleted :slight_smile:


Not sure how to find which device handler I’m using. Just whatever was assigned by the app. Here’s some info from one of the working sensors, does that describe the device handler? If not, where would I find the information in IDE?

I have verified that the devices are in fact deleted from the hub in IDE.

The Zigbee Motion Detector is the device handler and the correct one to use. Using other device handlers can cause them to fall offline so I was just checking :slight_smile:

Now, trying to reconnect it… you can try both the scan nearby option or choose sonoff from the brands list and selecting one of the other device selections they offer… it should still find the motion sensors that way.

not sure if rebooting the hub will help

1 Like

I’m frustrated that I didn’t try this before considering that I listed the solution in my original question.

I had been trying to add the devices that I previously deleted using the “scan nearby” option which worked originally but wasn’t working after deleting them.

I power cycled my hub and tried again and both devices were detected immediately.

The solution of “turning it off and on again” is so rudimentary that I’m embarrassed that I hadn’t tried it before turning to the forum, but despite my embarrassment, I’ll leave this thread up in case some other weary internet traveler makes the same silly mistake.

Thank you for your help @jkp

image

1 Like