Sonoff SNZB-01 pairing

So I have read most of the threads regarding these Sonoff zigbee devices and I have a SNZB-01 which I am trying to pair. I have follow the instructions previously listed in various threads but what I am having issues with is the actual pairing. I have setup my DTH, placed my app into ‘Scan Nearby’, taken the back off of the button, used a pin to press the RST until the LED flashes x3 times but eventually the scan times out … I have also tried repeatedly pressing the RST pin until the LEDs flash during the scan but still no joy … well no joy most of the times … I have (at the beginning) managed to enrol it as a ‘Thing’ (forgotten how now) then change the DTH and rename it then re-enrol it but I have been trying to recreate this for testing purposes (before I buy some more) and I cannot; after many, many attempts, recreate and pair this device.
Does anyone know a tried and tested approach to always get this device to pair/enrol, rather than ‘scan nearby’ and press the RST button until the LEDs flash?

[UPDATE] I have a few zigbee devices in the house including an Ikea Tradfri outlet in the same room I am attempting to pair my device … so not knowing too much about zigbee and how it creates a mesh I thought having a zigbee device so close it would pair easily but I eventually went out to the garage where my ST hub is an placed the device on top of the hub and attempted to pair that way … and eventually it paired and then after resetting the DTH it re-paired again and although it does work now it is very laggy, I think because it is connected to the Hub rather than the nearest zigbee device. If this is the reason unsure how to improve my zigbee signal and to make it more reliable.

[UPDATE] I had better luck pairing using the eWeLink (ZigBee Switch) option rather than the plain ‘Near By’ option … this has now connected my SNZB-01 via another nearby ZigBee device acting as a repeater and so now my device is much more responsive

I was able to pair my new SNBZ-01, and I see it in the SmartThings APP as “connected.” But, SmartThings does now see it working. I used the Device Handler Sonoff-Zigbee-Button.groovy by Darren Blanchard and Pablo Poo. I’m novice/new at this so patience is appreciated. Is there a way see if a button press is even creating any output from the device? What is a good approach to troubleshooting? -Thanks, Court

If you go into the app and then into Automations then set up an automation for the button to send a message when the button is pressed then this should be a good way to test.

Hi…i have the same problem with a sonoff snzb-01 & smartthing… have you got it to work?

You need to install the Sonoff-Zigbee-Button device handler (dh) to use this button.
If you install the dh before pairing the button it should automatically link to that dh. If it doesn’t you need to go into the IDE and manually change the device handler the button is using.
In the mobile app the tile for the Sonoff button will NOT have have a virtual push button when using the Sonoff-Zigbee-Button dh.

Ups…first news about dh…can I install dh in SmartThings app into Mobile?

BR,
Mario

No, you have to install DH’s from the IDE https://account.smartthings.com/login using a web browser.
You will need to login with you Samsung account.
Go to My Device Handlers.
Go to +Create new device handler
Chose from code.
In a new browser tab go to smartthings/Sonoff-Zigbee-Button.groovy at master · darrenblanchard/smartthings · GitHub
Click in the “Raw” tab.
Copy the code and paste into into the screen that opened with “+Create new device handler”
Click the create button at the bottom
on the new screen that opens click save, then publish, and then for me.

And you will have the device handler.

Then repair the device and it should pick up the correct DH.

Guys,

Got SNZB-01 and following Paul’s step by step instructions I manged to pair it with ST Hub. It now shows up in my ST android app in the STANDBY status. To test it, I added a quick automaton (if pressed then turn ON a lamp…). The test does not work. In, addition I noticed a couple of weird things:

  • battery shows up as 0 (and it is new)
  • In my devices WWW interface) I see button constantly being “Pushed”
  • In my devices WWW interface) I see NunberOfButtons 4 (but the actual device has only one button)
  • no events in history

All these tell me that there is something messed up (driver ?) in info exchange between SNBZ-01 and ST Hub.

Any comments ? help pls …

Walter

An update … I noticed wrong driver being used and pointed (manually) to Sonoff ZigBee Button. After this change I see :
still battery=0
NunberOfButtons is now 1
button is now standby
tests still dont work

Couple things to try:

  1. Close mobile app, clear the cashe on your phone/tablet, and then reopen the mobile app. That might solve the problem.
  2. if that doesn’t work play with the device in the new “beta” web portal. It doesn’t have problems bring offline devices like the mobile app. This might wake the device up.
  3. Initially don’t worry about battery reporting as it can take hours before it starts working.

It looks like you haven’t published the device handler as it is showing ‘draft’. I’ve never really known what that means in reality.

The ‘standby’ value is being used to initialise the button attribute and strictly speaking is not valid and the app would be entitled to barf when it sees it. However it is only there until an actual button press turns up.

When you put the Draft version of a DTH local, it will run in the cloud. If you are modifying a DTH in IDE and not publishing it, the draft version is the unpublished version, also in the cloud.
This is the version that is used when you are using the IDE simulator.
It is very useful when you want to see the live log of a local DTH, that you only see the methods of the dth that is executed in the cloud, such as configure()…The rest is not seen.
I use it a lot Draft version for debugging changes in local DTHs.

That’s why I was telling you yesterday, if you came in live logging traffic from your ikea button, if it’s a local dth, you have to put the Draft version to see it.

Tried all your suggestions and still no luck:

  • no Draft anymore
  • cleared Smartthing cache on my Samsung phone and later reinstalled
  • deleted driver and device from IDE and reinstalled
    I am still sitting with device visible to IDE and mobile app but pressing button does not do anything.

Paul, you have mentioned “beta” portal. Can you please point me there ?

Thanks, Walter

http://my.smartthings.com/

Any Luck Walter? I’ve gotten as far as you, with the exact same state.

Edit: Well, nevermind! I took the battery out of the switch and put it back in, and now everything seems to be working perfectly, including the battery sensor. It seems a bit slow to respond (1-3s), but that’s fine.

I have been following this thread and have been able to only get one of my SNZB-01 buttons to work. I have tried a few of them same results. I am guessing I am missing a step or some setting. Here is what I have done so far:
I have added the DH and saved it and published it. I verified the device is using the Sonoff smartthings/Sonoff-Zigbee-Button.groovy at master · darrenblanchard/smartthings · GitHub
DH.
The button shows up in Smartthings mobile app and When I press the buttons it reports correctly ( pressed, double pressed and Held) as well as the battery.

I have tried to connect it to a newly added bulb. Set up the actions in the button tile but it will not respond.

I have done Zwave repair in the IDE.
I tried the battery removal and replace.

What am I missing? Any help would be appreciated.

Update; it will run a scene but still will not control any lights. I am really stumped

Yes it is a weird problem, I’m having same issues. Smartthings recognises the button press single, double and held, I can see it in the app and I can assign actions to them but nothing happens. I tried removing and adding many times

If I change IDE to the Zigbee button then double click works.

Really stumped :frowning:

Ok changing the runlocally from true to false helped fix the issue, now I can control lights and other switches with it.

Sadly now it runs in the cloud of course :frowning:

Where did you make that change? I’m having the same issue.

I can´t make it work with ST hub. I tried the “Sonoff ZigBee Button” device handler and it doesn´t work. :frowning: