SmartThings WiFi Plug not synching and not updating ( 7A-PL-W-A1) ( TEMPORARY SOLUTION FOUND!)

Hello,
Recently i purchased 3 samsung wifi plugs ( 7A-PL-W-A1) and non of them are working correctly once added to home.
I do have about 10 more on my system that work just great. ( these where purchased a while back)
issue is : after initially adding them , they report the watts and on off state but after unplugging them and re-connecting them they stop reporting data.
Also I am not able to update their firmware, it keeps telling me firmware update available and i click on update but no matter how many times i do it , the device wont update its firmware.
Interesting observation.
from the smarthings (new app) home screen if i click on the on off button it seems to turn on and off the device but once i go into the device itself it no longer works and shows device is off when its actually on, clicking the on button from inside the device section keeps trying to do something but ends up giving message " a network or server error occurred. try again later " i know there is no network error as i can turn it on and off from the main page of the app but not from inside the device detail page.

I am thinking this must be due to the device not being able to update to the latest firmware.

any suggestions on how i can get them to work? thank u

1st **update
talked to smartthings support for about an hour and they asked for screenshots and told me someone from tier 3 or something will contact me regarding this issue. I will update the post as i get more information.

*** TEMPORARY SOLUTION ***** ANDROID ONLY
So after thinking about it, I realized that this must be an app issue and not a server issue, so I deleted the smartthings app from my phone and got an older apk version ( 1.7.42-22) from apk mirror and it did the trick, I was able to update 5 of my new plugs to the new version and they are all reporting the watts and working properly. I have not updated the app to the newer apk version from the play store since im not sure how long it will take samsung to fix this but for now this seems to work. Please understand that installing an apk from outside the play store could have malware or something, so if your comfortable then you can use this technique.
Im pretty sure this wont work for ios since i dont think ios people can side load apps that easily.
anyway good luck everyone

***2nd update
I just purchased a new plug from amazon ( link below) and it was the new firmware on it already. I dont know if all the new ones being sold have the new firmware but the one i bought had it and no need to use an older apk version to update.
Here is a link to the exact one i bought from amazon.

I have a similar issue, and others have reported similar.

I have removed my device and reinstalled it.
On the third attempt the status situation along with being able to control the device is fully functional. Power use is not

I reported the issue and will follow up with their reply.

1 Like

I have removed and re added the device i want to say about 3 to 5 times now and still the same results. I am starting to think this is due to the new smartthings app. As i mentioned i have about 10 others from a few months back and they all work perfectly and im pretty sure that is due to their firmware being the latest.
Yes Please update here if you hear anything back. I am also planning on calling smartthings tomorrow and if i get any real help i will update the post( im doubtful since i called few days ago and they told me to return them as they are defective) this is not correct since i bought another 1 today and same issue is happening.
Cheers

Well.
I got a reply…
Kind of.
They thought the outlets were showing OFFLINE and not OFF.
Suggested I reinstall the app & devices, which we’ve done.
Asked for screen shots and more info but ill do that tomorrow.
More when I get more.

I have the same problem. My plug used to work but since the migration it does not work correctly. It keeps telling me a firmware update is needed and I have tried at least a dozen times (and ways) to update the firmware. Nothing works. This is frustrating.

Yap, same issue for me. Besides the frustration, i actually rely on the power usage data to make sure some of my devices are working correctly so not getting that data is really bad in my case.
I am going to call smartthings again today and hope they can help fix this, i will also report back with any helpful info if i get any.

I have noticed that the firmware version of the plug that will not update is 923. My plugs that are working have firmware version 1281.

Yes, That is the same with my devices. I have given this info to smartthings when i talked to them.
Hopefully they will have a fix.

This starting happening to me the other day as well. After migrating to the new app, my wifi smart plug 7a-pl-w-a1 stopped responding to the app. I removed the device from the app and attempted to reconnect it. Everytime I attempt to connect, I go through all the steps and get to 99% completion and an error occurs and tells me to contact support.

I just noticed that pretty much all of my wifi smartthings plugs have stopped reporting to the IDE.
this issue is getting bigger and bigger, hopefully someone from smarttings will notice this post and help out.

I also have this same exact issue with the wifi plug with firmware version 923. Looking forward to hearing a solution.

Same boat here. Says there is an update for the plug, but nothing happens when you try to update it. Shows as off, but the power is on. Need a solution as well!

Hello Vic_sarkis. Any news? I’ve been trying to update for days and it doesn’t work. I have several devices like this and I have never had this problem. Without the update it does not monitor the power.

Hi Carlos, Unfortunately i dont have any news yet, still waiting. I emailed them yesterday no answer and called but after being on hold for over 45min i hung up. I will try to call again today. As soon as i hear anything i will update this post.
Also your situation is exactly like mine. Hopefully they will fix it soon

I just spoke with smartthings customer service and she said they are aware of the issue and are working on it. Also she said i should hear back from them sometime next week.
Just wanted to update everyone.
cheers

1 Like

Ok so after all this time i got a response from samsung support and im going to copy paste it. It is not a solution as non of these ideas are applicable or helpful.

(SmartThings)

Sep 10, 2020, 1:35 PM MST

Good Afternoon.

My name is ****** and I am contacting you on behalf of Samsung Smartthings. I was wondering does the network name you have and password have any special characters in it? If so, please only make it a basic password because that can cause connection issues. Also, please try to turn off mobile data while trying to add the plug into the app.

Before adding the outlet one more time within the application, please go into the settings of your phone, reset the network settings and connect the wifi and turn off mobile data.

If you have any additional issues, please respond to this email or call in to speak to one of our phone agents at 866-813-2404; we are open between the hours 9AM-9PM EST. I want to thank you for being the best part of Samsung and have a great day.

SO, AS OF NOW ZERO HELP FROM SMARTTHINGS / SAMSUNG!

1 Like

OK so I have the same issue, new WiFi outlets they are selling right now are straight up defective with v923 firmware not being able to update to any newer firmware version. I actually have a support case open right now on the matter and currently there is NO fix as they do NOT have enough support cases open to justify calling this problem as a “KNOWN ISSUE” I called to get an update this morning and the support agent was RUDE AS HELL!! So I hope Samsung is monitoring this thread as you will be loosing market share as I will be doing my best to WARN the public as to the garbage you are selling and your incredibly offensive customer service agents interacting with the customers.

My advice to this this group is to either create a support ticket TODAY or ASAP so Smartthings will classify this problem as a “known issue” and actually give it some attention. Their phone number is 1-866-813-2404 or support@smartthings.com it’s better to call so you can get a ticket number right then. The other is to return this defective crap if you can. The market is very competitive and is flooded with devices like this so customers should not be held hostage holding onto defective devices just because the big corporation doesn’t feel there is a problem and is not motivated to fix the problem.

The main point here is let Smartthings know you have a problem!! The support agent said they do not consider this thread as a valid means of considering this problem as a “known issue” nor will they investigate it just because everyone is bitching about it here. You have to open a support case with them. Sitting on this forum hoping the problem will correct itself through osmosis will leave you disappointed I guarantee.

I hope this message finds you well and was helpful and most of all motivates you to take action to get this issue resolved.

I have the same problem. I called earlier and submitted a ticket.

They said they would send it to their review team. Well see where that goes…

So i got another email today telling me that they are taking this issue a few steps higher up the chain. I will again update this when i hear something. If they ever give me a fix or tell me how to fix it i will update the main post.
Stay tuned.

Here is the email I received. Hope a fix comes soon.

"Thank you for contacting Samsung SmartThings Support.

I regret to inform you that this is a known issue we are currently investigating where SmartThings WiFi Plugs are not having their Firmware Updates applied when told to via the App.

We hope to have this resolved soon and thank you for taking the time to report this to us.

We apologize for inconvenience caused.

Feel free to write back for any further assistance."

1 Like