Samsung WiFi Smart Plugs (Model 7A-PL-W-A1 ) No Longer Connectiong

Hello all,

I have a handful of WiFi Smart Plugs (7A-PL-W-A1). They were working without issue up until this morning when I enabled WPA3 on my wireless network. My SmarthThings hub as well as a number of other devices reconnected automatically following the change. I tried removing and re-adding one of the devices but it fails on the last step “Registering Device”. Is there anything else I can try to fix this, or do these particular devices not support WPA3. Thus far I haven’t been able to find anything on this doing general searches on the internet.

Thank you,

There have been some password and firmware issues with that model in the past, I don’t know if that has anything to do with what you’re seeing or not.

SmartThings WiFi Plug not synching and not updating ( 7A-PL-W-A1) ( TEMPORARY SOLUTION FOUND!)

Interesting read. Currently the outlets are on Firmware version 1281, haven’t been able to find if that is the latest and greatest as of yet. When time permits, I’m going to roll back the WPA3 change and see if there are any updates available to the devices. More to come…

1 Like

You have any success with this, all of my plugs are out now too and I tried the older side load trick which didn’t work.