SmartThings Community

Smartthings ADT Hub Stuck on checking for updates


(Chris Stanley) #1

So i had my system almost fully set up last night and needed to add 1 last adt window/door sensor. I could not get it to pair for the life of me. I ended up having to restart my modem and router. Now when i did this obviously my smartthings adt hub disconnected, and when the internet restarted the hub itself said it was connected but the smartthings app said it was disconnected. I tried arming the system from the panel and it worked as should, again the app would not show it as armed but as disconnected. I tried this several times but nothing different. I then tried performing a factory reset on the hub (disconnect power cord, took off back panel plate, disconnect battery harness, wait 30 seconds, plug everything back in, hold the two front buttons until the screen lights up and then release). This seemed to do the trick as it did indeed reset and i was asked to put wifi password, but here is where it gets stuck. After i connect to wifi it goes to checking for updates and just hangs there. Ive tried performing multiple factory resets, resetting modem and router. Ive contacted Samsung who is no help. Im pretty much stuck now, ive even tried taking out the cellular module and resetting afterwards and still no go. Any suggestions or help would be grateful! I bought it off an individual brand new sealed so no return or warranty options are available to me.