SmartThings Community

SmartThings (Samsung Connect) UI Update - iOS 1.6.31 (May 2, 2019)

(Jimmy) #22

I’m using Mike Maxwell’s super old Aeon HEM V1 Laundry DTH.

#23

Ok. I know that’s not the one I’m using. I remember seeing that one when I explored all of the DTH that exist for this device.

#24

Again, it was loading fine two versions back of the new app.

GEN1 of the HEM.

#25

Same for me, and while I was checking to see if it still works (just got the update), the app crashed again. As soon as the app stops crashing and I can see if it’s working, I’ll post back. It may be a while though because the app crashes 100% of the time for me…

#26

I had a quite a few custom device handlers in my list and I tried all of them. Including the laundry one and none worked other than the DTH by @johnconstantelo. Not sure if it’s the latest (last updated Feb 2016) version. I don’t get a white screen in Android it just says it can’t connect to the device.

#27

@Nezmo, it finally loaded:

I went ahead and added this to a new repo I have for DTH’s and new app changes:

https://raw.githubusercontent.com/jsconstantelos/SmartThings/master/devicetypes/jsconstantelos/my-aeon-home-energy-monitor-gen1.src/my-aeon-home-energy-monitor-gen1.groovy

(same metadata as the other btw)

(sidjohn1) #28

None of those DTH’s have been updated to support the new app
Start here:

#29

I updated with the code you just linked to (there were some minor differences to what I had). But still no dice. Blank screen in the new app.

I also tried changing the DTH to the stock one, going in to config for the device in Classic and saving. It did not resolve the blank screen in the new app. It’s almost like once a problem occurs you can’t recover.

Also noticed that device name changes in Classic do not sync with the new app. And yes I have tried going in to device config in the Classic app and saving.

#30

Oh no. When did that start? I had a very bad time getting sync to happen. I still have nightmares about it… Support can help, and hopefully it will be simple.

#31

Not sure to be honest. I recently renamed all my Harmony activity switches and not a single name change synced to the new app. I will contact Support. Perhaps that is why I do not seem to be able to correct issues like I mentioned in my prior post. It’s like the new app simply doesn’t pick up anything new on a device once initially set. States update, but not changes to DTHs.

Reported to Support (#735202) and tagging @Brad_ST for any possible insight.

1 Like
(Mike) #32

I know. Those are the original DH. I did start at that thread. Added what I needed and still didn’t work.
Thanks

(Mike) #33

My harmony activities definitely do not show up in the new app. Even though it sees the Harmony Hub. It’s so dumb

#34

Name changes don’t sync from classic to new, but will sync from New to classic. At least on Android. Been this way for awhile for me.

#35

That’s odd. Mine show up in the new app.

#36

Great, so I have to do it manually. Sigh.

This is cute. Trying to edit one of the longer-named devices. I get the same no matter where I place the cursor and try and backspace. Is ANYTHING tested in these releases?

#37

I started only making make changes in the new app some time ago because of this “bug”.

#38

I haven’t run into that but it looks like they must have put a new character limit in the new app. I doesn’t surprise me since we know that are limiting us to 20 rooms if created in the new app.

#39

Which would be somewhat okay but I can’t even delete any characters to fix it.

EDIT: I’m an idiot. You can hit the x to delete the whole name and re-enter. Still fussy in my mind.

1 Like
#40

It’s all frustrating. Never any release notes. No documentation.

2 Likes
#41

I made this change. It is much neater showing a fan icon instead of a switch in Connect. I’m not so happy about the look in Classic but it’s not a big deal. I had to make some webCoRE changes to use fanSpeed versus lowSpeed(), medSpeed() and highSpeed() from my old custom DTH but all is good.

Thanks

2 Likes