SmartThings (Samsung Connect) UI Update - iOS 1.6.31 (May 2, 2019)

So I was looking at my iOS storage today and discovered that the SmartThings app is now the largest app I have… by a large margin. Nearly 336 mb and that does not include the app data. With my data it was almost 1 gig. Removed/reinstalled and down to 358. But I lost all my settings by doing so. By comparison, my next closest app was individual MS word and excel at 256 mb each.

On my iPad

App Size: 336.7 MB
Documents & Data: 20.3 MB

On my iPhone

App Size: 359.1 MB
Documents & Data: 46.7 MB

Welp my room order decided to move itself overnight😞


HEM DTH update:

Not sure if you can load the app but was wondering if your DTH is still working for you? It died on me today. I get the “can’t connect” message. I changed the DTH and changed it back. Had to force stop the app and clear the cache to get the app to see the new DTH. But in the end, the only DTH that is working for me now is the stock “Aeon Home Energy Meter”.

I’m on shard 1. Maybe that’s why it still worked for me yesterday. Server side changes causing this you think?

I can actually load the app! The HEM is working:

Thanks for the reply John.

That’s just weird that it’s a fail for me today. I’m glad it’s working for you and that the app loads. Seems like things are changing daily.

1 Like

tagging @Brad_ST , we were discussing this a few days ago on slack.

They have changed settings for SHM. Trying to figure how to set up alerts now.

ughhhhh, the list for picking lights isn’t sorted at all

Where do you find it? I no longer get anything other then selecting sensors.

“Set Response”

I have looked everywhere but do not see it

Can’t find it

Never mind, found it, very hard to find. Can they make it any harder to find!!

Seriously, that has to be the most hidden thing in the whole app. They confuse you by having the enable button on the right.

For me on iOS, choose SHM>tap gear icon in upper right>tap Security then you get the screen above

After months of holding out, I finally installed the new SmartThings mobile app for iOS, so I can try to help someone using a Xiaomi Button DTH I’ve worked on.

What a joke.

I have tried adding the unofficial and completely undocumented bits of code that supposedly get devices using custom DTHs working in the new app, but I get the “white screen of death” when viewing any of them with one exception:

  • Aqara Motion Sensor (and that DTH didn’t even have the extra code added yet!) - but I get an error “A network or server error occurred. Try again later.” and it shows capabilities not included in the DTH (Vibration Sensor, Button, & 3-axis sensor)

Also, I initially got the “white screen of death” for devices using official SmartThings DTHs, which was only fixed by logging into the IDE and manually switching to a different DTH from Samsung’s “canned” list and then back again to the correct DTH.

I am not sure how I develop custom DTHs to get devices working in the new app when all I see is a white screen upon viewing them, and there is little or no official documentation explaining how to update custom DTHs to integrate to SmartThings highly-touted updated platform.

Overall a wholly wretched first day experience with this app.

1 Like

I think the enable slider is new? Before there was no way to disable certain parts of SHM without deleting the whole thing and starting over.

Your ‘Xiaomi Temperature Humidity Sensor’ version 1.3 works fine for me in this version of the app.

I do have the white screen error on other devices with custom DTHs though, including one I’m writing. The Virtual Presence Plus by Austin Pritchett also suffers from the white screen bug.