Smartthings Hub Not Connecting - Going to need to replace

So for some reason my Hub no longer is connecting. The light is blue which means it is not getting an internet connection, however my router says otherwise. The hub is 2nd generation.

Unfortunately Smartthings stated that there is no way to port over all of my devices, which doesnt sound like a big issue, but i have over 200 devices that will need to be manually re-added. Not including all of the scenes and routines that will need to be recreated as well. UGH!

I have been looking at all of my options, as perhaps this is a good time to switch, as everything will need to be recreated.

I did notice the newer Smartthings Hub (3rd Generation) connects over wifi as well as via ethernet. Is there anything newer than the 3rd generation?

Just trying to get ideas on what options would be best.

There is a newer hub but it does not support z-wave.

Back to your current hub situation… some questions:

  • have you tried a different ethernet cable?
  • tried plugging into a different port of switch or router?
  • if connected to switch, have you tried a port on the router if available?
  • have you rebooted the router?
  • have you made any recent changes to your network?
  • have powered down the ST hub and removed batteries if using?
  • booted up ST hub with no batteries?
1 Like

Thanks for your response.

I have tried multiple different ethernet cables, so I ruled that out.
I swiched the ports on the original router and that didnt work, so i switched to a different satelite to see if that would work and it still did not.
I dont have it connected through a switch.
I did try to reboot the router, and that did not resolve the issue, also tried rebooting the modem.
There have been no network changes. and whats interesting, when i log into my router, and look at the smarthings hub that is connected, it is showing green, so i know its getting the connection.
I do not have batteries in the hub, but i have disconnected power and the ethernet cable and rebooted, still nothing.

As a test… change your dns servers in your router. You can change them back after the test. Enter google dns servers: and or if they are set to google already try

Any type of blocking on your network… pihole or adguard or router?


I thought my reply back to you went through, but it didn’t! This worked! Thank you so much, it was able to reconnect! I sincerely appreciate your help, I have been moping around for about a week trying to figure out what I was going to do. I was so bummed just thinking about reconfiguring everything!

Thanks again!

Hey, I have a simlar problem. @jordan.c.emery, do you mind saying what exactly worked, here? Changing the DNS or was something blocking your network? Thanks.

What is the color of the led light on front of hub? Which hub?

Try a soft reset of your hub first which wipes out your network settings on hub.

soft factory reset by following these directions:

  • Disconnect the power cable from the Hub
  • Using a pin or a small tool, hold down the reset button on the back of the Hub
  • While continuing to hold down the reset button, replace the power cable
  • When the LED on the front starts flashing yellow, release the button

Give it a few minutes to try and teach ST servers. Watch led light on hub.

1 Like

Hi @jkp, thanks very much for your quick reply!

Here is my situation:

  • The hub has a green light. I can also see the little ethernet-socket LEDs madly flickering away in green.
  • It is a V2 hub from Dec. 2016; the back says Model STH-ETH-200.
  • Strangely, if our internet goes down (it can be flaky sometimes), once it comes back up, my phone with SmartThings (ST) app will give a notification that hub connection was restored, and then a few hours later, hub disconnected. (It will not notify about connectivity any more until the next time our internet is lost and restored.)
  • In the meantime, nothing is ever actually truly connected. Even during the short time window that notifications say it’s connected (above), I can’t turn a controlled light off and on, and sensors have no temperature readings, etc. Nor any of the rest of the time. Also I had a particular light programmed to come on at night (relative to sun down/up) and that hasn’t worked either.
  • Best I can recall, connectivity stopped working on or around July 20, when there was a big wind storm and we lost power for 20 hours. (Many others in our state also lost power for quite a while.)

I have no problem with doing a soft reset but thought I might bounce the situation above off of you first. In case you recommend anything else first. If not, I’ll reset it.

Thanks again for any help you can give!

If you have already tried rebooting both your ST hub and router and that has not resolved the connectivity issue… go with the soft reset of your ST hub. Follow the instructions as written and release the button when you first see flashing yellow… do not continue pressing reset beyond that or it wipes out everything on the hub.

If you continue having issues or wish to speak with ST support before taking any action… do contact ST support.

1 Like

Thanks @jkp … this fixed it!

I meant to reply long ago before but at first I wasn’t sure if it took. (In fact it wavered in the first 10 - 20 minutes after that; sometimes worked, sometimes didn’t.) So I decided to wait a week before replying. Then kept nbot being in a position to reply when it crossed my mind. Anyway, here’s the reply.

Possibly what happened right after I did the soft reset is, it was getting software updates or something for awhile. (I’m not sure if it was completely offlline since July, because every now and then it would say it connected (then soon disconnect again) … I don’t know if it would have to get a bunch of updates after a soft reset. Does that wipe all updates since day 1?)

Anyway … thanks!

1 Like