My Samsung SmartThings hub may be dead! Help

Hello, I have a 2016? Samsung Smartthings hub V2(?) hub that is presumably dead or dying… It loses connection occasionally and now just won’t connect at all- The blue light is on but my app says the hub is offline. The device is plugged in with ethernet that I have verified to be functional with another device. Diagnostics says it’s offline, too. Is it dead? Any other thoughts/options? No network changes other than switching ethernet cables with one that was verified.

Even if it were working, there are no migration utilities to make an easy transfer to a new hub, correct? I only have about 40 devices, but am not liking the idea of reconnecting everything to a new hub.

Options? Ideas? New hub recommendations?

good luck -jim

Edit- I just realized my hub has 4 AA batteries that are as old as the hub. Maybe replace them?

More details please:

  • have you tried powering if off for several minutes (with batteries removed) and powering it back on with batteries left out.
  • how many Edge drivers do you have installed?
  • when did this start?

Btw… ditch the batteries and consider a UPS backup…. Just my opinion. But do ditch the batteries and do not replace.


Maybe 6 months ago, I would get an infrequent notice on my phone that my hub was offline. A little bit later it would be back online all by itself. It has become more frequent the last couple months- maybe once every week or two. A few weeks ago it didn’t restart- I unplugged everything after work and it eventually began working after the restart. It went offline yesterday and I haven’t been able to restart it- the light is still solid blue 12 hours later.

I haven’t done anything other than unplug ethernet and power. I didn’t even remember the hub had batteries until last night(they’re still in there). I’m too scared to press the reset button. I don’t know what an edge driver is so I’m guessing I don’t have any :^) I will try removing batteries and powering off for longer when I’m at home.

Regardless of outcome, changing hubs is a big deal, correct? I have to manually reset/reinclude all of my devices?

good luck- Jim

Yes, it is basically starting from scratch.

If you haven’t tried already… contact ST support.

try… removing the batteries.

try a soft reset (only resets the network settings)
soft factory reset by following these directions:

Disconnect the power cable from the Hub (and yes - you NEED to remove the batteries)
Using a pin or a small tool, hold down the reset button on the back of the Hub
While continuing to hold down the reset button, replace the power cable
When the LED on the front starts flashing yellow, release the button

contact ST support… can’t stress that enough.