SmartThings New App not showing all devices vs. Classic App - 40% missing

Hi Folks!

Avid Smartthings user - been on classic app forever without issue and have bunch of devices including customer DSC device handlers. I recently installed the “new” app and at first everything appeared great. Added some new leak sensors and new valve controller via the new App - worked great and showed up perfectly in the classic app too… Didn’t think much of stuff and then went in today to configure another device i’ve had forever (GE Switch) and it isn’t in the new app - only in the classic. Upon further inspection, the new app was mixing about 40% of my devices. Strange enough it had one DSC device and missing 10 others. I signed out of the app and signed back in (reco in other threads) and issue remains. What should i do? I LOVE the new water detection features/smart app in the new app and would love to stop using the classic.

Did you look in the menu (3 bars in the upper left of the screen) and look under devices?

Yes the full device list is short by 40%… missing variety of stuff - switches and dimmers etc. Any ideas?

Contact ST support. It is possible they need to sync the devices between the two apps.

Try to kill the new app and restart it. I’ve seen it happen due to an interrupted connection and restarting the app fixed it.

I tried signing out, killing app and reloading to no avail. Opened support ticket to see if they can fix

1 Like

Still no response from SmartThings support. Any other suggestions? I am pretty much back to Classic and just using new app for its more capable water leak notifications etc

There was a trick that worked for me when I first moved but that was a couple of years ago. It may or may not work. Option 1) Login to IDE, go to Devices, click on the device , choose edit and then update. Yes, you need to do it for each device. Refresh the new app and see if they show up. Option 2) open the Classic app, go to each device, choose settings (the cog in the upper right of the screen) and click save. Chances are low that either option will resolve the issue.

Last thought but one you might hate me for suggesting… remove the device in Classic and then install from the new app.

Or you can continue to wait for ST to respond. If you are in a region where you can call support, that is generally the best method to contact them and speak with a tech directly and get a quicker response.

Thx appreciate the tips! Will try the IDE angle