[RELEASE] Sonoff, Sonoff TH, S20, Dual, 4CH, POW, & Touch Device Handler & SmartApp ($5 & $10 Smart Switches)

I just updated the DH, deleted the child devices and then changed the device name in the Sonoff App for the 4ch device and it all started working again. Thanks @erocm1231 …I thought I was going to have to install the Tasmota firmware to get it working again.

…On a slightly different topic, has anyone managed to get a switch working that isn’t close to wi-fi router/ extender? I have an outside light where I need to put the switch in the base of it - I tried a Sonoff Basic but it wouldn’t connect - it’s about 15m (45ft) away and through a window and the wi-fi signal is strong enough for a good connection for my phone when standing next to the light. I’ve put an X10 switch in at the moment but would be good to find a better solution.

Hey Eric. Checked logs and figured out issue with smartapp. I had made minor change to handler name by mistake. The child devices add now but the checking status thats for a lot of stuff is showing up again. Also when click into the device the switch capability is not shown.

Have it working I think Eric. Thanks. I was copying raw code from 4ch device handler but it was not the latest. When I checked the log for insertions and deleted items I could see the code change. Edited manually and sorted!! Thanks again

1 Like

Nice! Update worked like a charm, easy. Have been using these to control some Christmas Lights and thought they would never work again with the new app. Thanks Eric for all the work.

1 Like

I am trying to get Sonoff-Connect to work on the new iOS app. Sonoff-Connect successfully finds my three sonoff-wifi-switches, but when i select them and click the next button it says “processing” and then i get a white screen with “< Sonoff (Connect)” at the top and “Next” at the bottom. When I hit next, it take me to an identical white screen. If I keep hitting next the Smartthings app eventually lockes up. When i restart the Smartthings app and go into Sonoff-Connect it shows my three switches as installed. But no Sonoff switches are showing up under my devices.

Note that i did update both the device handler and the smartapp to the latest versions in git. What am i doing wrong?

I think the problem is in the new App because i tried out Tasmota connect and got the same problem. I found this post which seems to have the same problem.

https://community.smartthings.com/t/smartthings-new-app-not-showing-all-devices-vs-classic-app-40-missing/193111?u=daniel_paulsen

@Amishman, did you find a solution or get an answer?

I just added my first TH16 with DS18B20 sensor and everything is working fine. Temp is correct (in the classic app).

I’m not sure yet if temp is supposed to show up in the new app or a child device is supposed to be created for temperature. Still scanning this thread as to how this SmartApp handles the new app.

@Paulih, on your slightly different topic: Maybe you’ve found this out by now, but some Sonoff owners with signal strength issues have added an external antenna with good results. Like this: https://community.blynk.cc/t/sonoff-with-external-wifi-antenna/18645/10

@BartschLabs, I did see something similar a while ago but the thread I read didn’t seem to have as good results. I’ll give it a go, thanks.

1 Like

Is there anyway to change the Auto Off to under a second, 0.5s to simulate a push button?

I’m currently using Sonoff.ino.generic.bin on a SONOFF RE5V1C, should i be using another bin file?

Thanks

I Have a TH10 set up with a DS18B20 probe. The switch part of the sensor works perfectly. The tempature doesn’t show unless to go to history and look at the “log”, it reports correctly there. It also doesn’t show as an option to use tempature to trigger an event using automations only the on/off functions. I have read through a lot of this post but not seeing a soluition. Am I missing something or will it just not work with the new smartthngs app. I believe I have the correct smart app and the correct DH installed (getting them from the updates in the top of this post)

@TJK, I think that is the way this DH is written. No temp in the new app. The classic app does show the temp, but it doesn’t make any sense to get it running if you don’t already have it.

Re automation, you should be able to use temp from this device for rules in webCoRE.

After working with ST support I ended up resolving my problem by deleting my Samsung Account, creating a new one, and setting everything up from scratch. Now everything is working properly. Support said that my account was somehow assigned to the UK instead of the US.

Ok, I got one working using webCoRE. Now I have one i’d like to put in another building anyone know if there is a way to conect to a different router than my smartthings hub is on? Still the same internet I just have two routers (one configered as a AP)

Hi i need help, i have flashed my TH10/16 and i the smartthings website i can see the temperatur, but why cant i see that temperature on my smartthings app on my Iphone? i have tried so many things here please help

@TJK, you probably have to choose Manually Add Device when adding a device on a network that is routable to the network that that SmartThings hub is on. This is because Discover Devices probably listens for a broadcast that isn’t forwarded by the router.

@Akhen, you won’t be able to see the temp in the SmartThings app using this Device Handler. If you want to see the temp in the SmartThings app, I recommend that you flash the TH16 with Tasmota firmware and use [RELEASE] Tasmota (Connect) for Sonoff, Tuya, SmartLife & other ESP8266 devices) for your Device Handler.

I tried that to Yesterday, still no temperature.

With the sonoff i Can at least see the temperature inside SmartThings webpage under devices but not in app

If i use the tasmota firmware and setup the temperatur sensor i cant see any temperatur inside the tasmota page