SmartThings Motion Sensors Only Reporting Temperature. (is it the DTH the Device or the Firmware)

Hello,

My first post. I have a “buttload” of smartthings devices in my home. I am very adept at solving problems with these badboys as I have not been in a constant tangle with the system since they made the “move” to the new platform. So I feel I may have missed a critical problem with the Motion Device handlers or Firmware.

I have a few motion sensors that have stopped reporting motion. Upon going through the zigbee discovery they join. However the device’s capabilities never update in the IDE. I get Temperature. That is all. This leads me to believe that the device handler is the issue. I’ve tried several of the assorted device handlers in the IDE I’ve tried custom ones and official. I cannot get these sensors to sense motion. They join and complete what I can see of a handshake given I don’t have the internal IDE event feed that I used to.

Is anyone aware of a problem that is specific to firmware or these (SQUARE motion sensors that have the Little motion sensor circle in the top right corner)? these. Just an FCC Id of 2AF4S-STS-IRM-250?

I had a sensor that was working, then I wanted to re-assign it to a new job. Following the removal and re-addition. The device entered my now small bucket of motion sensors that only report temperature.

I am as familiar as is possible with the common problems with these old sensors. I hope somebody here can shed some light for us. I cannot reliably search the community history but have been at this on and off for a few months.

To summarize my question. (Is there an event in recent history IE the last 2 years or so that caused motion sensors of this variety to lose their minds and only report temperature events and fail to report the device capabilities in the raw handshake exchange?)

Seems DTH related. I can’t buy sensors anymore because they’re discontinued. :frowning:

Updated to remove the salt.

login to IDE at https://account.smartthings.com click on Devices, find your motion sensor and click on it. what Device Type is showing for it?

1 Like

SmartSense Motion Sensor

  • manufacturer: CentraLite
  • model: 3325-S

that looks like the right device handler. you may want to report the issue to ST support.

Yes indeed. I have tried to contact them. I Wonder if OTA updates will happen through a repeater or if OTA need direct access to the hub for that. Hmm.

Just added another Motion sensor to the list of ones that now no longer reports motion. I was wondering for a moment if it had to do with OTA firmware updates but one that I just pulled off the wall to test a remove/re-add is now no longer reporting motion. Only temp. :frowning:

I have the same issue with my 2 year old Samsung motion sensor and I thought I was going mad. Something has broken…

@Vfxgrimm, @impee - I’ve just tested with my motion sensor and everything works fine. (I just had to place a new battery inside.) It works with stock DH and with my custom one as well.

Where do you see that no motion is detected? In the app at the device’s page or is it not triggering an automation?

@GSzabados

There is no motion detected in the IDE also in the app.

Each of the devices pair immediately. They register temperature changes very reliably. They only do not report motion. I popped one open and checked the circuitry for damage and corrosion. There was no sign of any.

An update to the OTA question I had was whether or not the devices would still update to the latest firmware. The devices have all now updated to the latest firmware. There were a few mixed in that were on older firmware.

I’ve tried with several packs of batteries. I’ve seen it where batteries age on the shelf and can make it so devices don’t pair. Each of the sensors that I have connected has a brand new battery.

The biggest sign for me is the one I pulled off the wall to remove and re-add. It was working fine. Once it was re-added, it now no longer shows motion.

It seems to only happen to the SmartThings sensors that have the Small non faceted (smooth not ridge-y) IR ball in the top right corner of the sensor. (there were two variants of these hardware wise If I remember correctly) I have both of these variants and they both are exhibiting the same problem.

I even went so far as to try to change the handshake definitions in the DTH a while back because this is only happening with sensors that shake as a “3325-S” Every one of the sensors I have an issue with will pair as a “3325-S”

These are the 3 That I have online for testing. All of the same physical model, however internally there are two variants from two manufacturers. They all identify as “3325-S” during pairing not “Motion V4” which I have not had any problems with.

I just checked my faulty one, it is also: model: 3325-S

I have checked the IR sensor leads themselves on one of them and reflowed the solder on the connection just in case the mechanical force on the cover was causing a stress break in the solder that holds the sensor to the board. No change.

@Vfxgrimm ,
the fingerprint of the centralite model 3325-S is on the dth SmartSense motion sensor which has many models and manufacturers.
For what it’s worth, I’ve ever had trouble pairing devices correctly due to these problems:

  • The fingerprint that now exists in the dth is not exactly the same as that of the real device and when re-linking it again it failed me with some samjin motion sensors (smartthings), which have one more input and output cluster and Heiman smoke sensors with same model and different fringerprint clusters.
  • If I have a modified dth that also fits with the official one, I had to delete the modified dth and after linking the device to publish it again.
  • If I have deleted a device that does not work well and I link it again, I have had to activate the safe mode in the hub so that it does not automatically recover the previous device bad configuration.

I will try the tip you mentioned to see if there’s anything being recovered by the hub when pairing. That sounds like it could be an issue that I can track down if that’s what could be causing it. :smiley: I’ve never heard of a “safe mode” on the hub though. I’ll look into that. I’m checking in the IDE now to see if that is an option that’s available.

I’ll also try to go back to an earlier DTH and self publish after pairing the devices and then attempt to apply it to the device. An interesting idea.

Thank you.

1 Like

In app open smartthings hub

I had a similar issue a month or so ago. The device was reporting temperature but no mition.

  1. I removed from smartthings
  2. I reset the device, I think you use a thumbtack or something to depress the button while inserting the battery or something, and wait for the LED to do something, do not exactly remember
  3. Then re-add it back

Then it picked up motion correctly.