ST Motion Sensor - 2014 - only reporting temperature


(Morgan) #1

I have a 2014 model of the ST motion sensor, and it had been working perfectly and then today it just started reporting temperature only. I’ve had this happen one other time, but then i just reset the sensor and it started working again.

I’ve rebooted the hub, and reset the sensor. It is connecting and giving temperature to ST but just no motion detection at all. Any ideas?


#2

Having the same issue here. Three 2014 SmartSense Motion Sensors are not reporting anything except temp.

Looking in live logging, they are reporting ‘motion has stopped’ in the IDE, but nothing about motion starting, and nothing is listed in the ‘Recently’ tab in the iOS application.

I’ve tried removing the device and re-adding it, and I have the same issue.

I emailed support and they said it appears to be working properly, which sucks, as it always takes two days to get anywhere with support since the first email is ALWAYS dismissive… or the strange email saying, ‘can we have your permission to look into this’

This helped for a temporary solution


(Ray) #3

For my case, whenever I have zigbee mesh issue. My ST motion sensors will only report Temp. How good is your mesh and do you have smart bulbs nearby acting as your repeater?


(Fast, Good, Cheap...pick two.) #4

Same issue here


(Piotr Bizior) #5

Not a mesh issue in this case. Last night SmartThings implemented faulty change and rolled back, but broke few things apparently, users are reporting older motion sensors showing only temperature. I reached out to the support, but no response yet.
From what I found based on community here, which is great btw, is that you have to remove the older motion sensor and add it as “Samsung SmartThings Motion Sensor”, it will not detect the type automatically, but it will add successfully and report both motion and temperature. I tried this work around with 1 this morning and was successfully able to, however I’ve 11 motion sensors, some of them are not easily accessible and fixed to the ceiling/wall up high, on top of that before removing the “thing” from SmartThings, you will have to make sure it’s not used by any smartapp, so this would be huge pain for me to do that for all my motion sensors.

What I don’t understand is, how someone at SmartThings/Samsung is getting away with a change like this, obviously not properly tested, and the roll back that brakes even more. This is, in the enterprise world, not acceptable.

I had high hopes for Samsung taking over and improving the platform, but my recent experience is everything but what I expected.

Thanks,
bizior.


(Tom Manley) #6

Thanks for the reports everyone. We found the problem. Yesterday we released a change to many of the SmartSense device type handlers to improve how they decode the ZigBee messages to indicate changes in sensor state. We did this to account for some bugs that would show up when the battery got low or the cover was removed from the sensor. We made a mistake with the SmartSense Motion/Temp Sensor that broke motion detection. We’re fixing this right now and will release the change as soon as possible.

A few months ago we actually moved the fingerprints for the older motion sensors to the SmartSense Motion Sensor DTH. If you have already changed the device to use that DTH I suggest you leave it there. We certainly didn’t intend to break the old device type handler, but anytime a new 2014 motion sensor is joined it will use the SmartSense Motion Sensor DTH.


(Piotr Bizior) #7

@tpmanley: thanks for clarification Tom, I guess your testing before “go live” process needs improvement.
I was able to find solution on the community post, still waiting for support to contact me back. Oh well, I guess it won’t be needed, until next time…

Thanks,
bizior.


(Morgan) #8

Argh. Like half of my house uses these motion detectors and has totally upset the family. It is very frustrating. I’ve changed a few to the newer models of the ST sensors, and it appears to be working. But I’ve now had several of my Zwave switches that the motion sensors were working on are not non-responsive.

I’ve rebuilt my Zwave mesh, and re-joined some of the switches but it is still not reliable at all.

What is the ETA of the fix? Also, my older 1st gen ST motion sensors are working, but not the 2014 which make no sense at all.


#9

Change your device handler to “SmartSense Motion Sensor” is the fix


(Tom Manley) #10

The fix went out about 6 hours ago. I mentioned it on another thread but forgot to do so here.