Motion Sensor not detecting motion


I got a smartthings starter pack yesterday and everything worked fine apart from the motion sensor which did not detect motion. It detected the battery level and temperature fine but no motion no matter how hard I waved at it. I made sure to disconnect and reconnect multiple times and swapped the battery. I tried everything on the knowledge base page for “motion sensor stuck on detecting motion/no motion”. I finally gave up and went to the store to exchange it. I just got home, set everything up and the exact same thing is happening. This is with a whole new starter kit, they swapped the entire bundle. Am I doing something wrong or am I really unlucky and received two faulty sensors? Is this a known issue and is there a fix?


Support Article

1 Like

I’m having the same issue with a kit I got a few weeks ago. Did the same troubleshooting and have support looking into it (albeit very slowly due to holiday support load). The Aeotec multi sensor I got is working amazingly for all metrics. The ST seems to be blind.


I mentioned in my original post. I have already tried everything on the knowledge base page.

That’s good to know. Which one do you have? The gen6 version? I might buy a couple of these if the ST motion detectors are not reliable. The alternative I have seen are the Fibaro motion sensors.

Yes, it’s the Gen6. I really like it, and the extra measurements it provides (a little overkill, but whatever.)

I’ll keep pressing ST to replace the one that came with the kit, or swap it out for another similarly-priced thing (like an other open/close multi).

Thanks for the info. I’ll log a support ticket and see what they will do.

Did you get a solution? I have exactly the same issue. It reports the temperature but never detects motion. I’ve tried replacing the battery and trying the reset instructions but after installing I get regular battery status and temp but never any motion detected. I’ve sent two emails over three days to support but have not yet got a response. I have the ST motion sensor that came in the kit.

I have UK support looking into my issue as it is still ongoing. No solution yet. My 3 Fibaro sensors are working perfectly. I’d recommend getting them over any more smart things sensors.

Did anyone ever get a solution to this? I recently got a kit and am having the exact same issue.

Dido. Same problem here.

I’m having the same issue with a new motion sensor. Setup is fine and detects temperature OK. I turned on extra logging and it says connection is healthy but no motion detection after all troubleshooting.

The sensor that came with my kit got stuck on (ON) I tried all sorts of things to get it to work then I contacted SmartThings and they sent me a new one that I received yesterday and it worked fine till tonight, this new one is stuck on (OFF). could this be a problem with the hub itself? with the second failure now I’m kinda disillusioned with SmartThings.

I got the kit last week and am having the exact same issue. Tried everything but it does not detect motion. Has anyone found a solution yet?

I’ve had two working motion sensors do exactly the same thing. They report temp when reset, but no motion. I’ve tried removal, resetting, hub powered off for 30 minutes, device type changes, new batteries. Nothing works.

Given two failures, with exactly the same symptoms, I’m suspecting device firmware, or hub firmware issues.

You’re probably right. I had a smartthings motion sensor which detected motion okay but would not report temperature. I lived with it as it’s primary task was motion detection. Away, the recent OTA firmware upgrades to the sensor fixed the issue. So it sounds very similar to your issue just the reverse.

While I’m not so happy with the SmartThings sensors, I was very happy with the online chat support experience with “Luis”. Once I explained the issues, troubleshooting process and provided an order number, he agreed that the two (of seven) sensors should be replaced. I soon after received an email indicating new ones were being sent out, and prepaid shipping and customs forms were attached.

This is much better than my last experience, so kudos to ST for the support efforts :slight_smile:

In addition to the HUE motion sensors, I also just added several Fibaro sensors. They are my favorite so far due to the small size, simple but very versatile mount, and easy LUX value integration with SmartThings. One of these are mounted in our entry way and saw -20C last night. No issues. They use a 3volt lithium which is a good choice for cold temp performance and longevity.

I’ve experienced a high failure rate with these sensors. The first one I had, which came with the kit, worked fine. I then bought a second which was dead on arrival, it wasn’t even detected by the hub. I sent it back, the replacement worked fine.
Last week, I ordered 2 more. One works fine, the other is detected and reports battery and temperature but doesn’t detect motion.
The replacement should be with me tomorrow. Hopefully this one works.

I have had some inexplicable issues with SmartThings Motion and Multi sensors and in every case replacing the battery with a new battery has resolved the issue.

Hi, Did you get a resolution to this, my motion sensor which was working, is now showing same behaviour, only temp is logging and showing change. Tried reset, brand new battery, even toggling device handlers, and leaving without battery for 48hrs to drain any charge, and update firmware. It detects no motion as soon as added, then nothing. Thanks, TB