SmartThings Community

SmartThings losing connection to TCP hub


(Glen) #1

Lately, My SmartThings hub has been losing connection to my TCP hub, which controls my lights.

It’s happened several times in the last week, and overnight the last 2 nights.
It might have been happening more than I was aware of, because the lights weren’t dimming reliably due to another bug (http://community.smartthings.com/t/scheduler-quits-after-some-minutes-hours-or-days ), for which I recently implemented a workaround.

The only way I have found to reconnect (temporarily) to the TCP hub is:
On my cell phone app, I go to SmartThings Labs -> Tcp Bulbs.
On the Connect your TCP Lights to SmartThings page, my username and password are already entered. I click Next, then Done. It seems to work for 1-4 days after this.


Smartthings + TCP Connected - need some guidance
Need help with TCP lights
Official Ecobee 3 Integration
[RELEASE] Initial Setup for Ecobee3 & 4, Smart-SI, EMS, Smart-02 thermostats - My Ecobee Device
[RELEASE] Initial Setup for Ecobee3 & 4, Smart-SI, EMS, Smart-02 thermostats - My Ecobee Device
TCP Lighting Integration Issue - 10/27
TCP Bulb Reviews?
Native ST ecobee 3 intergration?
TCP Lighting Integration Issue - 10/27
(Greg) #2

This has also been happening to me as well but slightly differently.

I was completely unable to turn on/off TCP from ST. But schedule on at sunset was still working. Turn off at a time was not working. I fixed it by going into TCP connect, where my credentials already were (like yours) and hit done. So far I’m at one day of it working fine.


(Jeff DeWolfe) #3

I get the same here when trying to control from my Harmony remote. After the “re-login”, even though the credentials are already there, things start working again. I tend to go a few weeks or more between having to do this.


(Bernie H) #4

I just gave up on TCP because of this. Only had two bulbs replaced them with GE Links and they work flawlessly. Such a difference. Will be Ebaying the TCP’s just not worth the hassle.


(Greg) #5

This is continuing to happen to me. I submitted a ticket. @glen is your working ok?


(Jeff DeWolfe) #6

Had to re-login to mine this past weekend. Very annoying. As soon as Cree releases some BR30’s that are connected I plan on throwing this TCP’s out. Very frustrating.


(Ernie) #7

I have set up Tasker and Autoinput to automatically login to TCP from ST app once per day. So far it appears to be working.


(Glen) #8

SmartThings support said they’re working on it.
In the meantime, they said I should try what has worked for some people–reset my TCP password on the TCP app.
I did that last night. We’ll see…


(Glen) #9

Resetting the password did not help.


(Jeff DeWolfe) #10

Mine stopped working again last night. Had to re-login and working again. This is getting old…


(Austin Fonacier) #11

Yup I ended up throwing my TCP bulb in storage. Enough is enough.


(Greg) #12

Mine only works briefly after hitting done in TCP connect. It then stops working with ST altogether until I open TCP connect and hit done again. Going to remove ST scheduling of TCP lights and just use the TCP app for it.


(Paul Montag) #13

Same problem here. I need to re-login to the TCP connection app daily in order to get my TCP lights working.


(Jody) #14

This may be of interest to some. I just discovered that TCP lights are controllable via the Greenwave channel on IFTTT. This allows turning the lights on based on ST triggers and some other stuff. Can’t turn them off as motion stopped is not an event that is reported to IFTTT by ST.


(Jody) #15

Not sure what is going on at TCP, but my bulbs worked for a bit this weekend and then today they completely stopped working with SmartThings or via the native app. Is there any development happening with TCP at ST @Tyler @thegibertchan


(Jeff DeWolfe) #16

Mine also were not working last night. Had to re-login through the ST app and they worked again.


(Greg) #17

I was having to do this several times a day. I gave up and just use the TCP app now.


(Jeff DeWolfe) #18

Seems to have definitely gotten worse. I had to re-connect again today…2 days in a row. I hate these things…


(Doug C) #19

Can’t seem to get Auto input configured properly in tasker. Any help is appreciated.


(Ernie) #20

Where are you running into problems? Also if it helps @Dewayne_La_Rosa posted his script at the following site.
http://pastebin.com/xrPF13jF