Official Ecobee 3 Integration

Is there a way to change to the polling limit, so the Ecobee3 remote sensors function more like traditional motion sensors?

Hi there,

FYI, if you have any question or issue about My Ecobee Device and related smartapps,
a new ST community wiki has been created for that purpose.

Please consult the following link about My Ecobee Device:

http://thingsthataresmart.wiki/index.php?title=My_Ecobee_Device

And, you can browse the different smartapps available at

http://thingsthataresmart.wiki/index.php?title=Category:Unpublished_SmartApps

P.S. There is a troubleshooting section under My ecobee Device and some complex smartapps that can help you solve most of your issues.

Regards.

1 Like

Hi, thanks for your help. I’m getting this error:

10:16:14 PM AEDT: error physicalgraph.app.exception.UnknownDeviceTypeException: Device type ‘My Ecobee Device’ in namespace ‘yracine’ not found. @ line 350

can you advise? I get this on the last page when I’m selecting the intervals and press done. the error message is:
Failed to save page:othersettings

Hi @cwbattler, please follow the readme’s instruction steps at my github, as I believe that you didn’t follow all the required steps.

P.S. If you need extra support, then a support fee will be required as I have a full time job and support takes a lot of my time.

I hope that you will understand. That’s why I created the sections about My Ecobee at the ST community wiki (see my prior post).

I’m having to re-log into this app every few hours it seems. Anyone else having the same issues? I’ve updated to the latest version and am still experiencing this.

The best way to deal with those connection issues is to report them to ST, and hopefully, they will address them
when they realize that there are a lot of ST users out there who are experiencing them.

I did report some connection issues myself quite a long time ago (linked to the security certificate amongs others), and here what ST support responded at that time:

Chris Porter (SmartThings)
Jun 30, 6:02 PM

Hi Yves,

Thanks for letting us know what you are seeing. My developers have been aware of this happening for a little while now also, and have worked on it. I will let them know your thoughts about it being the security timestamp being outdated.

I don’t have an ETA around implementing a revision to the code, but developers do currently know it is not working consistently for users, and are addressing it.

Thanks for the heads up, and the suggestions.

-Chris P.
SmartThings Support

In the meantime, I’ve observed that these issues come and go. In a specific week, they will be a peak of connection issues, and then few days after, the connection issues will disappear, and they will be no issues for more than a month.

I suspect the ST platform (and sometimes also the ecobee servers) to be the root cause of those connection issues. This could be some connection pool management issues at ST or others.

In brief, as I said in the community wiki and many times in other threads, I don’t have any control on those connection issues in my code.

Examples of other ST connection issues:

Stock Ecobee device

TCP Hub

However, I’ve implemented some defensive coding to notify the ST users of any connection issues. That’s the best I can do on my end.

And, if you read carefully other threads (like the one I posted in my previous post), ST has connection issues with other devices as well (ex. TCP hub).

P.S. What make ecobee more susceptible to losing its connection is the fact the ecobee is the only cloud provider (that I know) that asks to refresh its authorization token every hour. My code has the required algorithm to do it, but if there are connection issues at the same time, you’ll then need to manually reauthorize ST to reestablish the connection with ecobee.

Bye for now.

I’ve just emailed ST support. Have to re-authenticate ST/ecobee3 every few hours as well. Yvesracine, thank you for the amazing apps/integration!

I also contacted Support yesterday as authentication is lost within hours. Very frustrating. I have 2 ecobee 3s.

Hi @sn0wL, @shellprompt,

I made some changes today to MyEcobee device and ecobee3RemoteSensorInit that would hopefully reduce the number of connection & timeout exceptions

You may want to try the new beta versions at my github:

Let me know how it goes.

P.S. You’d need to copy and paste the code for both the device and the smartapp, save & publish.
Regards.

EDIT. I still think that the ultimate resolution of those connection issues is still on the ST side, but this may alleviate some of the issues till then.

EDIT2: The code has since been promoted to the main branch…

I’ll email ST support later today as I’m having the same issue. I’ve already had to re-authenticate 3 times this morning. In the mean time, I’ll also try your beta device and updated smartapps Yves. Thanks for all your hard work.

Also, I noticed in the live logging that my harmony connect smartapp was attempting the action below every second. I deleted that smartapp then re-added it to take care of that problem. I don’t know if this has any bearing on the ecobee re-authentication problem but those who are have problems may what to check their live logging and report.

debug	Adding subscription	
debug	Adding callbackUrl: http://XXX.XXX.XXX:XXXX/api/harmony.automation?smartthingscb
debug	addSubscription, params: [appId:XXXXXXXX, param1:subscriptions, action: GET:executeSmartAppGet, POST:executeSmartAppPost, PUT:executeSmartAppPut, DELETE:executeSmartAppDelete, OPTIONS:executeSmartAppOptions], controller:smartAppApi], request: [attributeName:heatingSetpoint, callbackUrl:http://XXX.XXX.XXX:XXXX/api/harmony.automation?smartthingscb, deviceId:2a08f94f-fda4-42c6-9079-93ce1bc08a63]

Hi Yves, great work with the Ecobee3 integration with SmartThings.

I have one difficulty I would like your input on. I am using the ‘ecobeeChangeMode’ SmartApp to change the Ecobee3 to ‘Away’ when SmartThings changes to ‘Away’. The problem I have is that when I return home, the Ecobee3 does not return to ‘Home’ automatically when it senses motion, like it would if it had set itself into ‘Away’. I have to manually press the circled ‘x’ on the Ecobee3 to go back to ‘Home’.

I know I could use another ‘ecobeeChangeMode’ SmartApp to change the Ecobee3 to ‘Home’ when SmartThings changes to ‘Home’, but I’ve found that SmartThings can lose track of our phones even if we are home, and can cause the SmartThings mode to change to ‘Away’ then back ‘Home’, which could make the Ecobee3 go to ‘Home’ even if it should be in ‘Sleep’.

Thanks again.

HI @Bobby,

For your use case, please look into the monitorEcobeeTemp or ecobeeSetZoneWithSchedule smartapps at the ST community wiki:

http://thingsthataresmart.wiki/index.php?title=Category:Unpublished_SmartApps

Those 2 smartapps will ‘resume’ your scheduled climate at the ecobee portal based on indoor motion sensors. Otherwise, you can do it with another ecobeeChangeMode, but this will create a HOLD at your thermostat.

Regards,

EDIT: This is also ecobeeResumeProg that can be used to ‘resume’ your scheduled ecobee program (i.e. Home) when you’re back home.

Please look at the configuration section under the ST community wiki:

http://thingsthataresmart.wiki/index.php?title=My_Ecobee_Device

Hi @macattack, I can confirm that the above trace is not related to my Ecobee device or smartapps code…

Thank you, yvesracine.
I updated the device type, and MyEcobeeInit smartapp to the beta versions. I hope this will work.

Thank you so much for the hard work. I really hope Samsung/ST or Ecobee buy your code

1 Like

I am just delving into the home automation arena and installed my first ST hub and a couple of z-wave outlets last week. I am slowly adding in a few components to learn how it works. Over the weekend I started to incorporate some User supported devices, a MyQ hub with two door sensors and my ecobee3 with three remote sensors (using @yvesracine device and apps). Everything installed fine and I have implemented a couple of basic rules to see how things work. I do have one nagging issue though with the ecobee3. Every few hours I am start receiving the following message, with varying number of errors:

“MyEcobeeInit> too many exceptions/errors or unauthorized exception, doRequest>exception groovyx.net.http.HttpResponseException: Internal Server Error for null (8 errors), press on ‘ecobee’ and re-login.”

If I go back into the MyEcobeeInit app the login credentials are missing. After I re-login it will work again for somewhere between 1 and 12 hours before I start seeing the error messages again. I there something I can try adjusting in the configuration? Or is this just a ST/ecobee server issue?

I am seeing this behavior too. I just implemented this yesterday. However, whenever I go to the init program, it shows that I am still connected. Do we really need to reenter our creds at that point? It looks like it is still talking, but just hitting some intermittent comms interruptions?

As a matter of fact, I just got the exception two more times and opened the smartthings app and looked at the ecobee and it said my fan was running, so I opened the ecobee app and sure enough everything is the same. So I do not think it is required to keep logging in every time that exception is thrown.

Wow, Now I am getting them every few minutes… Have to turn that off for sure!

I let it go awhile this afternoon and it wouldn’t right itself. If I don’t re-login I get 2 error messages every 10 min like clockwork until I do re-login. After I logged in it was happy again.

Hi @sn0wL, @rda2w, @CheezWiz, @shellprompt,

FYI, after some testing on my end, I have observed the following facts:

(1) Before the peak of connection issues that we’re all experiencing with my custom Ecobee Device now, I had been able to correct any connection issues by re-authenticating with ecobee, and this action would “reset” the connection and any connection issues would disappear after.

(2) Now, even if I try to “reset” the connection by re-authenticating with ecobee, the connection issues stick. The only way is to uninstall the Service Manager and delete the device to create another one.

Also, since yesterday, somebody has pointed out to me that the ecobee’s access token expiration time is now expressed in seconds (not in minutes like before)…

This is a recent change that was implemented just yesterday:

https://www.ecobee.com/home/developer/api/documentation/v1/change-log.shtml

The change does not explain all the connection issues in the last week, but it explains the fact that I can no longer ‘reset’ the connection with ecobee since yesterday.

There may be also more rate limiting done either on the ST or the ecobee side that I’m not aware of.

I implemented more defensive coding into My Ecobee Device, MyEcobeeInit and ecobee3RemoteSensorInit to avoid connection issues in the future.

MyEcobee device at home has been now stable for a while, and hopefully it will work also for anybody
who uses it.

Please let me know of any issues, especially with ecobee3RemoteSensorInit as I cannot test
it at home (I do not have any ecobee3’s remote sensors).

So, in order to correct their current connection issues, ST users need to

(1) Remove My Ecobee device and any ecobee3’s remote sensors from all smartapps

(2) Uninstall MyEcobeeInit, ecobee3RemoteSensorInit

(3) Get the latest MyEcobeeDevice, MyEcobeeInit and ecobee3RemoteSensorInit code at my main branch:

(4) Re-execute MyEcobeeInit and ecobee3RemoteSensorInit

Regards.

Hi Yves,
Thank you for the response. I tried the ecobeeResumeProg, but it didn’t work as expected. I set the smart app to resume program when SmartThings’ hello home mode changes to ‘Home’. When my wife got home today, I saw in my notifications that the smart app had told the Ecobee3 to resume program. But when I got home, the Ecobee3 was still on hold from when it was put into ‘Away’ this morning with the ecobeeChangeMode smart app.

I looked through the Events List for the Ecobee device, and verified that the ecobeeResumeProg did run. Is there something I should be looking for as far as an error in the event list?