Smartthings Link not working


(Xiang Ji) #1

Just got the preordered Smartthings Link (NVIDIA Shield dongle). Paired two bulbs and one motion sensor. Everything was fine. Then after 3 hours the hub suddenly went offline, showing “check your internet connection”. My Shield is on. Internet is fine.

Now I try to reconnect the hub by either disconnecting the USB cable, uninstalling and reinstalling the app, restarting my Shield, etc several times each. Still not working. Whenever I try to open the Smartthings app on Shield, it froze at the entry screen. Hub is still shown as offline on my phone app.

Anyone has the same issue? What can I do?


SmartThings Link for Nvidia Shield Constantly Offline
SmartThings Link for Nvidia Shield Constantly Offline
SmartThings Link frequently goes offline
Smarthings Hub and ST Link Integration
(Neal (www.zebrablinds.com / www.zebrablinds.ca)) #2

Contact ST support: https://support.smartthings.com/hc/en-us


(Paul Osborne) #3

Hi @Xiang_Ji, as noted by @ZebraBlinds contact support. There is an update to the shield that should be coming very soon (I believe 10/30) that should address an issue that I believe is consistent with your experience.

For now, try rebooting your shield device. The issue may occur again, however. Sorry for the inconvenience.


SmartThings Link for Nvidia Shield Constantly Offline
(Ashraj Dhindsa) #4

Similar issue, my SmartThings link disconnects randomly and reconnects whenever it chooses its time to wake up again. Wonder if this has to do with 5ghz WiFi, will play with it to see what works. Looking forward to the update.

P.S. sorry not trying to hijack a thread, just some info. Some things had issues being added to link where as on the v2 hub I had previously they worked easily. I got them to work by messing with settings from a computer. Aparently the link doesn’t see some of the things “Type” so it must be manually set, for example unofficially philips Hue Color bulbs are supported without Hue bridge, but now you must go and choose them to be ZLL RGBW Bulbs. Either way not a major issue. Still having issues getting my First Alert alarm to sync though.


(Ashraj Dhindsa) #5

Just an update. Nothing seems to work. Now the link hub is just refusing to work. I unplugged everything and restarted the Shield and it seemed to work for a brief second but then stopped working again.

That’s all it shows on the app.


(Joe) #6

Same unhappy cloud on my Shield.


(Ashraj Dhindsa) #7

Ok this is getting even worse now. As of today, SmartThings app keeps popping up while I’m trying to watch Netflix. Same message about hub being unresponsive.


(Paul Osborne) #8

@IOT @dualtronic As noted earlier an update to the shield should be coming very soon that updates the device to run hubcore 0.17.112 (current has 0.17.110). This resolves an issue with these same symptoms.

One potential (but not guaranteed) workaround for this particular issue is to disable IPV6 in your shield network settings (after confirming that you are getting IPv6 DNS nameservers). With that change, you’ll need to reboot your shield. That workaround, if it works, should not be necessary with the 112 hubcore software.


(Ashraj Dhindsa) #9

Thanks for all the help. I have managed to get it working temporarily by deleting app data and restarting a couple times. Looking forward to the update.


(Paul Osborne) #10

The issue seen previously occurred mostly when the hub software has to perform DNS resolutions, although it could theoretically happen in some other circumstances. Typically once connected we don’t need to do DNS resolutions again so long as we are able to maintain the persistent connection so you might be good for some time. If you are on Wi-Fi, it is not unusual for the shield to temporarily drop and reconnect which might give the problem a chance to come back. Even on wired, a reconnect is sometimes required as we have to cycle out instances in or behind the load balancer as part of deploys (infrequently).

112 should be coming soon.


(Paul Osborne) #11

The update containing hubcore 0.17.112 is now live. Update away and please let support know if you are having the same issues.


(Jeff F ) #12

I installed the NVidia Link the other day. I removed the items from my regular ST hub and added them to the Link. (I will be moving the hub to another property.) My Hue and Zwave items registered to the link, but then when I deleted and re-added Smartthings to my Google Home assistant, only the Hue items show up, not the Zwave switches. I moved them back to the regular hub and verified that when I do that, Google Home assistant can see the switches, but when I move them back to the Link, Google Home does not register them.


(Logan Jinks) #13

I am having similar trouble. My app will send notifications to my phone saying that my link will lose and regain connection multiple times through the day. And even though my Shield TV is connected and functions correctly the ST Link won’t work at all, and won’t work until I reboot the Shield TV.

After reading through this thread, I made sure all of my devices were up to date.


(Ryan Spillers) #14

Same here. Software update has been installed. Hub shows offline until I manually reboot the Shield, then will go offline after a short period of time. Lather, rinse, repeat.

FYI, I’m using ethernet connection on the Shield, not WiFi.


(Xiang Ji) #15

FYI for me updating Shield to the latest firmware solved the issue.


(Ashraj Dhindsa) #16

The main issue with has been fixed with the update, but now the hub goes offline at random times throughout the day. I am connected to WiFi on 5ghz and I have full signal strength. Sometimes when I wake up the shield the hub connects again. Something is like timing out the connection randomly while the shield is asleep. Happens maybe once or twice a day.

Update: switching to 2.4ghz has improved stability, hopefully this resolves the issue.


(Ryan Spillers) #17

Hello, I recently purchased and installed the SmartThings Link for my Nvidia Shield TV. I bought the package with the lights and motion detector. Here’s my situation.

I got everything set up and the motion detector installed with no problem. A few hours after setup, the app was telling me the Hub was offline. I rebooted the Shield TV, and everything came back online. Then, a few hours later, the Hub went offline again. It’s been 4 days, and the Hub is offline more often than it’s not. Sometimes, it will come back online on its own, but when I reboot the Shield TV, it comes back on every time, albeit only temporarily.

I’m using an ethernet connection on my Shield TV, not WiFi. I’ve also updated my Shield TV to the latest software (Hubcore 0.17.112), referenced in this thread https://community.smartthings.com/t/smartthings-link-not-working/103131/3

Please help!


#18

I do have the same issue here with the Link. Paired my Aqara sensor successfully with the ST app, thing work nicely for some hours then it break. All devices I paired became unavailable, manually trigger the sensor for reconnect to the hub seems not possible too. I have disabled ipv6 since day one I got the Shield TV and the unit run with wifi. I also noticed that the Link get disconnected from time to time as I got the notification from the ST app whenever it gets disconnected. It then get connected back again itself without touching anything.

We really need to get this sort out.


(Donna) #19

I am also still having this problem. All updates have been done and still not working. Mine is connected with the eathernet as well. Please help because this is getting really aggravating. Spent the money on this thing and it’s pretty much useless because it’s offline all the time. It’s no use if I’m not home to reboot and there’s no way to reset it from your mobile.


#20

Same here. I read somewhere else that having the Shield forget all wireless networks and then reconnect to WiFi would help, and it did - for a couple of days. Now it’s back to randomly disconnecting. I’ve got the latest updates for Shield and the SmartThings Link.