SmartThings Link for Nvidia Shield Constantly Offline

Hello, I recently purchased and installed the SmartThings Link for my Nvidia Shield TV. I bought the package with the lights and motion detector. Here’s my situation.

I got everything set up and the motion detector installed with no problem. A few hours after setup, the app was telling me the Hub was offline. I rebooted the Shield TV, and everything came back online. Then, a few hours later, the Hub went offline again. It’s been 4 days, and the Hub is offline more often than it’s not. Sometimes, it will come back online on its own, but when I reboot the Shield TV, it comes back on every time, albeit only temporarily.

I’m using an ethernet connection on my Shield TV, not WiFi. I’ve also updated my Shield TV to the latest software (Hubcore 0.17.112), referenced in this thread

Please help!

Unfortunately, this is a known error. See the following active thread:

For me updating Shield to latest firmware solved the issue.


A post was merged into an existing topic: Smartthings Link not working

Any headway with this issue?

This is the feedback from Nvidia.


Thank you for your patience.

I have been working with the engineering team on this issue and have found out a solution for this issue.
Please see if this works out for you as well.

-> If the device is connected via Ethernet, please disconnect it for testing purpose and connect it to WiFi
-> Go to the WiFi Settings
-> Forget all the Saved WiFi networks in the list there
-> Connect the Ethernet cable now and test if it works fine
-> If the device is indeed using WiFi, please connect to your network after forgetting all the Saved Networks.

Do keep me posted on the status to help you further.

NVIDIA Customer Care

My Smartthings Link has been offline for 2 days now. Restarted Shield multiple times. Pulled out from USB port, changed ports, attached to hub, and did everything possible. Smartthings App says Link is plugged in. But says Hub is offline.

Removed wifi 5Hz network completely, did Forget Network, changed to 2.4 WiFi network.

Removed IPV6 too. On LAN, only running IPV4.

Nothing works. Says Hub offline. And Internet works fine. Able to do everything else from the Nvidia Shield.

Updated firmware as and when new firmware is out. Flaky. Too much mind time going into this. Would deeply appreciate a fix.

Same here. Everything was updated (HubCore Version 0.17.112). I even reset entire ST setup on my Shield but couldn’t get this fix. Also try with disable sleep mode, use cable instead of wifi…whatever I can think off. I have 8 Aqara sensor all can only worked for few hours after been successfully paired. Once issue occurred, there’s no way to bring it back online unless to repair the sensor to the hub again. I also notice the ST hub was some how offline itself from time to time and went back up itself, but definitely there’s internet connection.

Same problem here, though connected wirelessly (5ghz ac connection, 100-150mbs download per on my Shield).

Went out of town for over a week and my ST Link was inactive the entire time.

I think this may have to do with my Pioneer A/V receiver, into which the Shield is connected via HDMI, automatically de-powering the Shield when I turn it off. While I believe the Link is designed to continue operating in Shield’s “sleep” mode, I don’t think it will work if the Shield is powered off, as it appears to be by the A/V Receiver.

I’ll experiment by leaving my A/V receiver on all the time, and seeing if the Link disconnects still.

Assuming this is the problem, how do I set this up so that I don’t need to leave my A/V Receiver on all the time (an incredible waste of electricity and perhaps longevity of the receiver)?

After playing with this a bit more, I think I may have solved my problem. First, I went into my LG TV “settings” and turned off “SmartLink”, which evidently has something to do with using the LG remote to control other devices attached to HDMI (whether to the TV, or the attached AVR, I’m not certain–but presumably the TV). I never used that feature.

Next, I went into my Pioneer AVR SC-1223 settings, and drilled down to “HDMI” setting of some sort. I basically enabled all the “control” settlings, but did not enable ARV (which already was not enabled), since all my sources connect to the TV via the AVR, and I always keep the TV sound off.

Now, when I hit the power button on the Pioneer remote, it puts the AVR in “standby” mode. The display on the AVR is off, but a single red “HDMI” led remains lit. Under this configuration, the AVR (or the LG, not sure which) is not turning all power to the Shield off, allowing the Shield to “sleep” and maintain control of the SmartThings Link. Hooray.