SmartThings iOS update 1.6.77 (January 19, 2022)

1.6.77 for iOS was released today

1 Like

Excellent, I like a good news thread …

1 Like

I guess iOS just isn’t going to get the ability to change icons.

Please tell me the network connection delays are resolved, no more accepting terms, login only required once, geofencing operational, widgets work properly, device and room orders are stabilized…

Confirmed NOPE to my biggest pet peeve - the network connection delay. Oh well, par for the course.

Also NOPE to the reordering of rooms, unless just an artifact of loading a new version mine were all out of order.

Scenes are gone. And routines that including running a specific scene now just say “run scenes.”

If this is true for everyone, this is waaayyyy worse than the login issue.

I just updated to the latest iOS update and now I keep receiving a Network Connection message and can’t control anything via the app anymore. Anyone else having this issue?

1 Like

My scenes still show

Hmm maybe it’s just a glitch. My routines are now gone as well and names of a lot of my devices have reset to “GE Switch” and things like that. And my virtual devices aren’t showing names at all.

Try signing out / signing in

1 Like

That solved it! Thanks so much for the help!

It’s good it went away for you. I’ve experienced this since June. It lasts until the app “warms up”.

Ah, thank you for the post!

This update has fixed the repeated notifications to agree to the “updated” privacy notices. I think I’ve signed away my rights to SmartThings about 50 times in the past month :face_with_monocle:

Unsure if it will fix the more pressing and far more frustrating bug that logged out users.

Ok yes, better, thanks

What about the phone presence issue? Always need to have Smartthings app running in the background for it work correctly but of course it would sometimes log you out for no apparent reason. All of this started when we upgraded to iOS 15 in September. It is January and no fix form Samsung. They say it is a security issue and you should call Apple. Why should I do this? This is clearly an issue both companies need to resolve. Without phone location presence Smarthings is really useless.

Seemingly, the update also pushed the “SmartThings server” bug to our app.

Your action will be completed when your phone is able to connect to the SmartThings server.

I’d heard of the bug without hitting it: that little luck ran out today. Nothing would open: not the hub nor any devices. Closed and opened the app multiple times.

What worked: log out of the app and log back in, which fixed the issue.

But why? I can’t remember the last time we’ve needed to micromanage an app this frequently. SmartThings, a modicum of concern for your users would be appreciated. This bug has been known for at least a month.

I can only find solace that maybe ST Edge needs a lot of backend tinkering (please roll out smoothly) and / or Z-Wave has good hub support, so we could jump ship when convenient.


Interestingly, this update again did not add any “Notice” to the app’s internal changelog area.

EDIT: formatting