SmartThings iOS client 1.6.59 (January 25, 2021)

new iOS client was released today

Guess we should check our scenes to see if we’re having the same issues as the Android release…

scenes are fine but the app is slower than ever now. only tested on one device so far.

i am focused on the storage to see if that issue is resolved.

1 Like

Yeah, I haven’t noticed any scenes missing, but editing a scene is horrendously slow. It took me 125 seconds to edit one of my smallest scenes that has only 3 devices! :weary:

1 Like

I had Automations with multiple changes to a single device (ex: 7:00am change Upstairs Thermostat cooling temp to 77 and heating temp to 72). It went and randomly deleted one of the 2 actions on a single device in all my Automations. Looks like it is saving when I add it back, but it does not. I have had to recreate any Automation like that into 2 separate Automations. Side note - Looks like the limit on number of Automations has increased.

I’d also suggest checking any Automations that were using Location Mode as a precondition to make sure that they still are. Some Android users (like me) found that the precondition had been deselected in every Automation it was in, and for some (not me) it seems it actually makes a difference.


woo… when did they redesign the automations screen? i can’t remember the last tIme i looked. i don’t remember there being columns. iPad.

That on iPhone or iPad? iPhone looks the same and is also horrendously slow.

oh well, i was hoping they had fixed the storage issue but it still exists. just shot up to 700 mb.

sorry, on iPad.

is the sunrise/sunset issue resolved in automations?

Maybe my install is messed up. The animation from the splash screen is gone. Might have to try the dreaded uninstall and reinstall.

on my iphone, that screen only appears for about 1 second. no speed issues with the iPhone app but my ipad is horrific

I’m not really seeing any speed differences on iPhone or iPad (neither better or worse than prior to this version).

Nest camera live view still not working on iPad in landscape.

All of my automation and scenes are now missing. They are still running but I can’t access them in the app. All I see is the add automation page.

Probably the same problem as the Android update: Scenes and Automations are now created against the Rules API directly in this version of the app and syncing the two has botched some things. Have you tried logging out and back in?

App on iPad just logged me off. Restart of app got me back in after two tries (no sign in required). Once again lost room and device order.

Yes, I logged out and back in with the same result

That is new redesign or new approach. Now you have no problems, since there is nothing on your screen. All problems solved

I confirm i had to re-flag all the preconditions on all my rules after upgrading the app on iphone