SmartThings iOS app update (v. 1.6.67/1.6.68) June 2021


You can control devices from your favorite screen or from room screens but clicking on a device get tHe clouds with lines through them.

When I first updated… I could not control devices anywhere. Uninstall/reinstall at least got me control from the main pages. Argh!

So forget about dimming or color changes , etc.


my device details page took f o r e v e r to load, but it finally did and now opening others is snappy :man_shrugging:

If @Automated_House says his is working fine…

If you open a device? Do they load?

I tried uninstalling/ reinstalling and logging out again but no luck

Updated three iOS devices… same thing. Opening a device gets me the cloud with line through it for all controls.

Good thing I have homekit :slight_smile:

Siri… turn on my lamp

mine is being very hit or miss. Almost like it takes forever to download the plugin, but once it does all devices using that plugin work fine.

I didn’t have to delete and reinstall (thank goodness because reordering afterwards is getting old), but it did take a while for anything to load. And yes, device details show cloud for me too.

1 Like

I was seeing the clouds in device pages on my iphone and pulled down on 1 of the pages to get the spinning refresh wheel and now all devices are loading fine. Very weird.

Yep… tried that many, many, many times but no go

Woo hoo! I found a way to get it to work finally. On the device detail screen, click on the 3 dots in the upper right of the screen, click Edit, add a character to the device name (space does not work) and save. Reload the screen and everything loads now. Then Rename your device to original. Now all my other devices load too. My other mobile devices starting working as well.

Tagging @Nezmo

1 Like

Ahhhh - sounds like a plugin caching issue… sighs big suprise…

Thanks, that does appear to have fixed it. I only had to do it on one device too (did the trick on my iPad and then iPhone was also okay).

1 Like

Today’s update is working for me, and subjectively a bit quicker. I initially saw the cloud icon, but it went away after a few minutes, and it’s been fine since.

OMG… back to not working again. Had to edit a device name again to get it to work again.

Hate this app update!

And I go back in and it is not working yet again

I give up!!

1 Like

Same here.

I’ve run out of adjectives for this company.


This certainly makes it harder to migrate off the V1 by the end of the month.

Same here, it definitely undoes the purpose of having a widget when it opens the app.

I am also now getting non-stop weather updates, over and over. I don’t know how to turn it off without turning off updates that I may actually want to receive.

1 Like

App was not working completely. Was not able to switch on/off or lock/unlock devices. After uninstall/reinstall it works again. :slight_smile:

It worked! Thanks!

Awesome update. Does mostly great.

How do I search for a specific device now with the new app update?