SmartThings double-press button actions are broken (1 Sep 2020 outage)

I presume the hub has received a buggy update. As of today, none of my Samsung SmartThings Button devices’ double-press triggers are detected by the hub.

It doesn’t trigger the associated action, and if I have a button view active in the app it will reliably display when I have pressed or held a button, but not when I have double-pressed it.

As I use these all over my home, I can only say I’m disappointed in the QA.

Hub firmware 000.031.00004
Button firmware 00000014

12 Likes

Same thing here. Double-press stopped working on the new app but seems fine on the classic app. Yet another win for Smartthings Classic, long may it continue… oh.

Same here! :disappointed_relieved:

Same here! Does anyone know if this has been reported? It worked fine yesterday (9/1/20) at 1500 CST, but at 2100 CST it wouldn’t.

I had the same troubles with my button starting 9/1. I’ve passed this along to the Engineering Team to resolve.

6 Likes

I’ve had zero problems with my Button, so suspect you’re using the built-in Automations you can assign the Buttons. Delete them and use Smart Lighting instead.

I prefer not to use Smart Lighting, that’s just my person preference due to several reasons. Still, there should be no reason we can’t count on our ST button(s) to run automatons, regardless of other workarounds such as you’ve mentioned or whatever the case may be… Classic shows it functioning???

2 Likes

I have 2 Samsung Button working for a year with the new SmartThings app and yesterday both stopped working the double-press function.
I bought those specially by the double-press function.

:angry:

20200902_114435|498x499

I ran into this the first time last night and the problem continues today. It only seems to apply to double taps and doesn’t apply to local use (smart lighting app).

I still see the IDE recognizing the double tap action (as an event and it sees it as the most recent state when applicable). You can see this in the screenshots below.
https://monosnap.com/file/zCr7wJcdJPuoZgEeZafmOKfUlo8dvb
https://monosnap.com/file/DH04U1zd8XmPDAHU22tv2q4JlYpvSu

There is a growing Reddit thread on this as well:

Edit: Same versions as @Diggie - and given the above, I suspect this is a cloud issue (plus I don’t think this is a new f/w ver).
Hub firmware 000.031.00004
Button firmware 00000014

1 Like

I only use Smart Lighting to keep the process local instead of in the cloud. Executes immediately this way.
I do totally agree it should not require any workarounds.

2 Likes

see below…

I do like local control. Another reason I don’t use Smart Lighting is I need to change SHM mode as well as execute a scene with the double tap. I can’t do that through it (As far as I know…).

1 Like

Interesting, but Sharptools and Webcore can only recognize a press or a hold. I’ve not done too much with Webcore, so note sure if comparing the button press to a variable (or an argument) would work. If it does then that would be the solution so that your light control would be local, but of course the SHM change would still be cloud based.

With the New ST migration, webCoRE can no longer control SHM from what I’ve seen and been told. I setup automatons to do what it used to do.

1 Like

This started happening to mine yesterday 9/1/20. Please fix this ASAP

Same here since yesterday afternoon the double tap on my 2 buttons stop working, I really hope it’s fixed soon

I know that there’s a workaround with smart lighting, but that doesn’t help with others automations :frowning:

Add me to the list, too.

Thought it was the button, occasionally needs to have the battery removed and put back, but it’s not that.

I have the same problem. After weeks of working flawlessly all four of my buttons no longer react to the double-press. Rebooting the hub didn’t help, but then came here and see I’m not alone. I hope this gets fixed soon.

Same here. Really disappointed with Samsung. Human error on this level is hard to accept. Where’s QA?

Just adding my “also not working” to the mix. I emailed support and got the usual “reset your bla bla bla…” Tried showing them the Reddit thread. Emailing them back again now with this thread.