ST Automations All Stopped Working (26 April 2020)

I just set up ST 2018 hub today. Added a few devices, including a button, some smart plugs, and some Hue lights.

Set up a few automations, detect motion turn lights on, detect no motion turn lights off.

Set up button to toggle lights on/off.

Everything working perfectly no issues.

Add one more device to the mix, everything does not work anymore. Button detects press but events do not fire. I.e. button shows press but does not do anything upon the press.

Reset entire hub, all devices, re-added them to the hub. Still the same issue.

Manual events are fine (i.e. turning off light manually or using a scene manually).

Does anyone have suggestions?

I’m seeing similar problems today.

Older ST hub, with a couple of buttons.

I can see the buttons fire in the Android UI (Pressed, Double Pressed, Held).

I can see and control the devices (Hue Play lights) with Scene or device automation in Android.

But the configured automation on button press (simple run-scene) doesn’t work.

Exactly the same issue. I am able to see the buttons fire, events trigger. I see the “pressed”, “double pressed”, or motion detected events. Nothing actually happens though - I do not see any App Commands being issued or automation firing. As you mentioned the scenes and devices work fine with manual triggering.

It must be an issue in the cloud again.

I have the same problem. All of my automations quit working about 6-7 hours ago. All my sensors are working fine although for a while I was getting the network error when I tried to turn lights on or off and door sensors would not update. Those are all working fine now just no automations. All my Alexa Routines that use my Samsung devices are working fine. It’s just my Samsaung automations. I agree I think this is on their end.

I am experiencing the same issue. Didn’t change anything in my automations. But none of them are working . Reprogramming or Hub reboot didn’t fix the problem.

Same issue here with all my buttons. Button presses register in the IDE but do not trigger anything through my SmartThings hub or through Home Assistant which is integrated through SmartThings webhook.

I’ve had a ticket in with support. Of course they want me to wipe all of my devices and re-create then send screenshots of automation pages that doesn’t work. I am not about to do that. I have tried creating some new automations but and uninstalling\re-installing the app on my phone but none of that worked. Manual triggers are working fine. Alexa Routines are working fine.

I highly recommend you don’t do what I did and rebuild your entire network. Took me three hours for nothing :(.

Do not reset everything. I’ve already tried it and didn’t help. Just wasted a few hours of my time.

Looking at the debug log on it looks like the buttons aren’t triggering automations on the hub.

If you look at the location events for the hub. You can see the the activities happening across the hub. It is definitely seeing the actions from the button. And you can see it controlling the devices. The bridge missing is the automation.

I sort of follow what you are saying but why would the bridge be missing that?

Correct. Exactly the same thing I’m seeing.

Likely our developer friends screwed something up in the cloud :).

So does that confirm it is on the Samsung end of things?

Yes with this many people and same issues Samsung is responsible… whether it’s an infrastructure or code issue is yet to be seen. I’ll be interested to hear from the developer team.

I appreciate you posting all this. It makes me feel a bit better knowing this isn’t on my end. I noticed on their support page that it says there are not problems today but last Thursday and Friday they seemed to have a similar issue. This also seemed to happen to be once last Saturday or Sunday as well. It always starts with being unable to do even manual triggers then goes through this.

Yeah. I’m surprised they haven’t posted anything yet but probably want to find a solution so they don’t look bad :).

Does anyone have an architectural view of how ST handles the automations? I’m assuming that it has a cloud based view of the automations which are synced with the hub, and the hub does the actual work.

So it looks like the automation in the cloud wasn’t pushed to the devices.

FWIW, at 2:00 AM Pacific time it was working. at 9:00 AM Pacific time it wasn’t.

Hi everyone. We are aware of the issue and are looking into it as we speak.

The public status page has been updated as well so you can follow along there for more updates:


Although a little slow my automations seem to be working again

1 Like