SmartThings constantly asking to add Matter plug

As I post that I get a pop-up for the device in the screenshot.

@SteveyJ Thanks for the report, I don’t have experience with this particular device but with Matter, it is common for devices to use BLE to advertise that they are available for join. Once the device has joined a Matter Fabric it must stop beaconing. My assumption is that this device just hasn’t been actually joined and is nearby.

We’ve taken note of the issue internally and the support contacts are useful for driving priority. Just wanted to mention this as there seemed to be some confusion as to how the mobile app might see this device if it was not on your wireless network.

If you or others are curious, the ways a matter device may advertise itself to a commissioner are covered in the spec which you may download from the CSA. Google also has a document which summarizes a few of these pieces.

CC @JDRoberts

1 Like

Thanks for the reply…

I’m currently getting popups for two devices of the same type but I’m not sure why anyone would buy smartplugs and then not connect them.

Stranger things have happened; the devices should also stop beaconing after 15 minutes even if they aren’t joined yet (see spec snippet below). Once they have joined a fabric they should also not be sending announcements as well. In this case, it’s hard to say exactly what is going on, but it doesn’t seem unlikely that part of the issue might be related to the device not conforming to this portion of the matter spec (again, speculation).

As noted before, disabling the setting for “nearby device scanning” in your phone system settings is probably your best option near term if the popups are a significant annoyance as, based on your description, what you see is coming from the system service on your Galaxy device.

3 Likes

Hi @SteveyJ

I haven’t read the whole thread and I don’t know if it might be related, but have you tried in the smartthings settings app, disable “Ask to add devices”?

With this option activated, every time it finds a Samsung TV from any neighbor or when you walk down the street and there is a TV nearby, it shows you the pop-up window to ask if you want to add it to smartthings.

Hi,

I did have it off and it was still asking me. I hadn’t turned it off again after clearing the app data though so have just turned it off again.

I have this issue as well. And I know it is coming from my tplink dimmers. I had to switch them to a new network so I removed them from the kasa app to put them back in detection mode and added them back to the kasa app. I have linked the kasa app to smartthings app so the device appears there when I add it to the kasa app. But even if it does, I still get the matters prompt every time I unlock my phone. The only nly way I was able to get rid of it, was to remove the device again from kasa, add it via matters either from Google home or smartthings and then add it back to kasa… Completely nonsense… I have alot of switches to change… Thank god only a few are matter enabled…

1 Like

Can I ask what model phone you have? The reason I’m asking is that Samsung has some partnership agreements that are supposed to simplify adding matter devices that only apply to galaxy phones. So it wouldn’t surprise me if they keep trying to add a device in a way different than the actual matter spec handles it.

1 Like

I have the same issue on two Samsung/Android devices. It is driving me mad as every time I unlock either of the devices I get two prompts to join. Im not impressed that it overrides you blocking notifications.

Ive been holding off buying a new phone as I’m waiting for the S24 to come out.

Change of plan…Can anyone tell me if this is a Samsung or Android problem as I’ll now be looking to replace my existing, old phone with something that gets rid of this problem.

Thanks and sorry for the moan!

Ian

I have the issue specifically with smart light bulbs. Whenever they get power again for example when turned on by a switch they start to broadcast the beacon again and smart things obediently obliges … The setting not to look for new devices is conveniently ignored!
I’m caught in an endless loop because when I try to add them and then could disable them it tells me the lamps require a hub even though no hub is required for Alexa or any other integrations.
So I’m caught in an endless loop asking me if I wanted to add them and then telling me I need a hub. Each time the bulbs get power again the spiel starts all over.

I think I cracked it now for me. I had to completely delete all my matter devices in the respective device app. Then I had to reboot the device so that it goes in discovery mode and from there click on “add to other app” option when the pop up occurred.
Since my bulbs require a hub for being used with another app like SmartThings or Alexa I chose as the respective partnering app the manufacturer app (in my case AiDot) to register the matter device. The key was to not directly search for new devices in the manufacturer app as this does not create and register the matter credentials.
So I went for each of the light bulbs individually through this procedure before opening the manufacturer’s app. Once I was done with the registration process triggered by the SmartThings app for all devices (bulbs) I finally went into the manufacturer app and the matter devices automatically populated.
Again, it was crucial to not open the manufacturer app directly before, which would have automatically searched for manufacturer devices and circumvented the matter registration process.
No annoying pop ups anymore that new matter devices are found in my network!

1 Like

Okay i was having this same issue
So I have 2 different kasa smart plug models in my home.
Turns out I activated one of them under the wrong model number which was causing the problem.
You’d think the plug wouldnt work or connect at it all if you got the model number wrong but it was working with all features and cross apps like alexia. Everything was fine other than just the pop notification glitch.