Smartthings not working with matter for device already added to Google Home

Im trying to add my matter smart plug to google home and smartthings. It connects to google home just fine but when I go to add it to smartthings by using the multi admin feature, it just fails. When i go to add it directly to smartthings it just says checking for available wifi networks and doesnt do anything.

Brand and model of the smart plug?

And what model SmartThings/Aeotec hub do you have?

Matter is still very new and different platforms are rolling it out in a different sequence with different features and everything can be a little glitchy. But in most cases with a little extra work, you can get it to connect appropriately.

  1. did you connect the plug to Google home via matter or via a native integration? (This is one reason we need to know the brand and model)

  2. did you connect it using an iPhone or an android phone? And was it the same device for both Google home and SmartThings?

Also, did you use a Samsung galaxy phone? That has an additional integration option with Google for matter home that may or may not work well.

  1. is this the first time you’ve connected a matter device to SmartThings? If so, just take a quick look through the following checklist:

FAQ: What do I need to add a Matter device to the SmartThings app? Do I need a bridge router device?

  1. make sure the firmware on the device is up-to-date. This may require using its own app, even though you’re not supposed to have to do that with matter. :thinking:

  2. after you added it to Google home, what exact steps did you take to add it to SmartThings? In particular, did you use the Google home app to generate a matter pairing code for it? When you want to use a device with more than one platform, you start by adding it to one platform and then you have to use that platform to generate a matter code to add it to any other platform . So you can’t use the same process with each platform: the process for the very first platform will be different than for all of the others.

If you started with the Google Home app, and you then want to add that device to SmartThings via matter, you have to go to the device details in the Google home app and choose “linked Matter apps and services” and generate the join code from there. Then you open the SmartThings app, say you want to add a matter device, and use the code that you generated in the Google home app.

(You may have done all that, I just wanted to be sure.)

1 Like

What models of Matter Smart Plug and phones? I’ve only ever added Meross Smart Plugs (I wouldn’t currently recommend them) and I’ve only ever used the links between the Google Home and SmartThings apps rather than generating codes.

I tried with the first installation on both Google Home and SmartThings and using a Galaxy and a.n.other Android phone. Both phones were quite enthusiastic about detecting the presence of a Matter device and throwing up a prompt to install it when you least expected it. This led me down the Google Home path. I don’t think I’ve seen SmartThings detect a device as it claims to. On the whole I found things more stable if I dismissed those prompts and controlled things from with the apps.

Without question the Galaxy phone was the far more stable platform to work on and SmartThings was the more stable app. Calling Google Home from SmartThings on a stock Android was particularly glitchy and I am not sure it ever worked, but butter smooth on the Galaxy.

I found it particularly unhelpful that Google Home doesn’t bother to convert the vendor IDs to brand names for you, and utterly ridiculous that it doesn’t invite you to select the Home you wish to use. So you have to prep the Google Home to be in your desired Home.

1 Like

Just to update my own post. Today SmartThings was quite keen on prompting me about Matter over Thread devices and Google Home was prompting me for the home to use.

Today SmartThings took its time scanning for thread border routers but did find my GL-S20, even if it didn’t update the network name when I changed it. Google Home couldn’t find it.

I’ve been messing around with some Onvis S4 Matter over Thread plugs. It has been ridiculously difficult, particularly where Google Home was involved in anything.

As the Station has yet to make it to the UK, and a second hand V3 hub has thus far taken two weeks failing to make it the last mile from the Delivery Office, I decided to try a GL.iNet SL-S20 instead. There is actually some appeal in having a dedicated TBR. Does it work? Yes. Do I have a clue what I am doing with it? Not really.

The Google Home doesn’t seem to know what to do with this mysterious third party thread network so initial commissioning has to be using SmartThings. A Galaxy works much better that a more generic device. It is rather hit and miss but eventually the hit wins.

Multi-admin to Google Home is another story. Anything Matter commissioning related using Google Home on my stock Android device basically doesn’t work at all (it just hands with a twirly thing on the screen). On a Galaxy it is better behaved. It is even more hit and miss but again after much perseverance and with no rhyme or reason you usually succeed. Though having said that I have one remaining plug that Google Home finds various days of failing to install. Sometimes it searches for it and refuses to find it. Other times it refuses to connect to it. Most often it finds it, connects to it, twiddles with it, and then can’t register it at the end.

Using the Google Home to then multi-admin back to SmartThings has become even more hit and miss. SmartThings now offers to install a device on absolutely any hub it is has online, regardless of whether the device is already installed on that hub, or regardless of whether it is already installed on another hub in the Location. I thought it didn’t used to do that, only offering a hub on a different Location. Although I have succeeded with this a number of times over the last two days, I have no idea how as now when I do it SmartThings gets stuck on the ‘Prepare the device’ page. It is waiting for the plug to indicate that it is ready, and the plug is flashing away indicating that it is indeed in commissioning mode and there is a standoff.

1 Like

Unplug the plug and plug it in again when it shows this message.

I believe I have used that for an initial commissioning but this is the third one and when I replace the plug it doesn’t start in a commissioning mode, and if I start over I get the same problem.

I think I also get this issue if I try a SmartThings to SmartThings install.

1 Like