Smartthings button no longer working. Can't get through to customer service. Not sure what to do..?

My smartthings button stopped responding, so I replaced the battery, and repaired it to the hub. Still not working even though battery is 100%. What are my options at this point? I was hoping submit a warranty claim but can’t find even an option to do that…

Hey there! @Texmurphy4,

I’m sorry to hear that you having issues with your ST Button responding. I completely understand how frustrating that would be.

As you have completed the troubleshooting steps of replacing the battery and re-adding the device in your ST application and the symptoms are persisting. I would recommend creating a Support ticket so we can look into your concerns further.

You can reach out directly to a support team in your area using the below options:
US: 1-866-813-2404
UK support 0333 0000333

I hope this message finds you well!


Thanks. Was able to submit a warranty claim. Appreciate the response. Marking this as solved.

1 Like