SmartThings Authorization "Unknown Error"

Is anybody else getting this error when trying to re-authorize the connection of Sharptools to SmartThings on their Android phone using Chrome?

I’ve already had discussions with Josh in the Sharptools community and he thinks it is “ The error is being returned from the SmartThings authorization servers”.

If I go into incognito mode on my phone, I can get it to work. I can re-authorize on all my other Chrome browsers on my Windows computers and my iPad. Only the Android phone doesn’t work. I have already cleared out my history in Chrome, and even gone into the apps settings on the phone and cleared cache, cleared data, uninstalled all Chrome updates, and re-installed the current version of Chrome on the phone, all to no avail.

have you tried installing a different browser on your phone to test?

Just tested with the Samsung browser and a new install of Microsoft Edge. Both work fine.

one work around if i recall correctly was to use the sign-in with QR code.

and contact ST support to report the issue.

I always approach authenticating with Samsung with a certain trepidation. Usually if you get to it via a domain it is OK, but if you are going via a for things like the Developer Workspace and SASM then all bets are off. In particular, for the last few months Edge has given errors authenticating with Samsung, with the issue being the server apparently couldn’t cope with the size of the request or something. So the Developer Workspace and SASM have been strictly InPrivate/Incognito windows for a long time for me.

As an aside, the Developer Workspace has always been a mare, with the first battle being to find a login link that actually gets you anywhere near a login screen. That was always the start of the battle. I couldn’t actually rely on getting to it when needed, even using the private browsing. However it has recently moved from onto and is suddenly rock solid for logging in.

1 Like

When I ran into this in the past (logging into certain Samsung features), using incognito solved it for me as well. This kind of issue is not super common, but it’s common enough that many of the power users in the community have experienced it before.

Last time it happened to me, I looked into it more closely and it seemed to be something about the massive payload on the login page as orangebucket mentioned – if I remember correctly, there was a large number of cookies and several of them had large payloads. Using incognito starts a fresh session so it doesn’t have all the historical cookies that accumulate over time. That being said, using the Clear Browsing Data feature in Chrome and clearing all data, including cookies, for all time usually gets you the same effect.

Just showing the relative size differences. The example on the right isn’t actually experiencing the issue, but it demonstrates how the cookies can grow

Heck, it’s even happened to me when I’ve tried to login to the Samsung site to check the price on one of their discount programs, so it doesn’t seem to be unique to SmartThings. :man_shrugging:

It’s strange that, if it is the cookie payload, then why does it only happen in Chrome, and not the other 2 browsers I have tried?

I can see it is trying to get to the Samsung account login page. Here’s screen captures of frames of a screen video capture (since I can’t seem to turn it into a GIF):

The second pic is the dots spinning as it is connecting to the Samsung website to present the login screen.

I wonder if this has to do with my phone. It just dawned on me that I switched to a Samsung Galaxy S23 FE a little over a month ago. This is probably the first time I had to re-synch Sharptools since the change. I never had a problem before with my previous S20 FE. But then, that makes no sense, because everything else works in Chrome, and I can synch using other browsers or other computers.

I think I may do a full backup and a factory reset. Then just update Chrome from the Play Store, not log in to my account so I won’t get synchronized from my desktop, and see if that works.


I factory reset the phone. I did the minimum to get past all the initial Samsung sign on accept policies etc. Then I went into Chrome. After signing in to Sharptools, I tried the Manage Connections. It worked fine. It let me connect to SmartThings.

Now I’m reloading my phone from my SmartSwitch backup. I couldn’t find any way to not select to restore Chrome. So now let’s see what the restore process destroys.

Cookies are unique to each browser and can accumulate over time. I’m not necessarily saying it is cookies causing the issue in your case… just that I’ve seen that happen before and it aligns with what orangebucket noticed too.

That’s what I meant by it’s Samsung returning the error. If you check the URL that you are redirected back to SharpTools with, that’s coming from the Samsung / SmartThings OAuth servers. Unfortunately, it’s just a generic error code from what I’ve seen:


If it was happening on a PC, you could open your browser’s developer tools, switch to the network tab, tick the box to Preserve Logs and you would even be able to watch the series of redirects as they happen.

From the SharpTools side of things, it’s just directing you to a standard OAuth URL like:

In your second screenshot is that the SmartThings mobile app rather than your web browser? That didn’t happen before… it should just open the authorization screen in your browser directly. :thinking:

I’m able to reproduce that on a different device of mine. It looks like the SmartThings app has added as a Verified Link which means Android automatically tries to open the app when you are redirected to that URL (it won’t happen if you enter the URL directly).

I haven’t dug into it closely yet, but I suspect this was a recent addition or change to the app. If it was intentional to include the domain, they should at least be able to filter out the OAuth paths so it doesn’t break things like this.

I’ll reach out to SmartThings to make sure they are aware of the issue.

Edit: In the meantime, you could go into the App Settings on your phone, find the SmartThings app, and disable the ‘Open by default’ option (it might be named slightly different based on the phone type).

When I tested it after the factory reset and it worked, it must have been loading it within the browser as I don’t have the app on the phone yet. I am waiting for my phone to reload, and will try again.

1 Like

For anyone curious, you can reproduce this on the API App Example from SmartThings:

You can open the Sample App link above in the same browser you are having issues with and when you click the Connect to SmartThings link, it does the same thing.

Of course you would need to be on Android in Chrome with a version of the SmartThings mobile app that has the Verified Link

1 Like

You are brilliant. Of course I could do the synch with a bare bones phone because the ST app wasn’t on it! Once I restored my phone, I tested again and it failed again. So then I looked at your solution. In my case it’s App Settings->SmartThings->Set as default-> turn of the “Open supported links” and bingo, I am back in business. Too bad I didn’t wait for you to point out this tip. I wasted a lot of time backing up and restoring my phone.

The only benefit of the reset was it seemed to have cleared up a problem I was also having with the Samsung account. When it goes to the Samsung log in page, if I chose “Sign in with Galaxy device” it would fail saying my Samsung account needed to be updated. But the Play Store said I was already on the current version. So I would have to choose “Sign in with your account ID”. That problem has now disappeared.

So thanks again. As always, you have been very helpful!!


My Galaxy phone has this extra Verified Link. As it happens I have an identical phone that hadn’t been switched on for some time and so hadn’t upgraded the SmartThings app. I was able to confirm that the extra Verified Link was added by the upgrade process. I didn’t even have to open the updated SmartThings app for it to appear.

However the phone I am using at the moment is a non-Galaxy phone running the latest version of the SmartThings app. It does NOT have the api.smartthings com Verified Link.

1 Like

My apologies everyone. In my haste and frustration with my phone, I completely missed the following as explanations for why the other browsers “worked” in the synch to ST but Chrome did not.

The Samsung browser worked because its default setting is to open app links in the browser.

MS Edge worked for me because I automatically chose “stay in Edge” without really thinking about it because of course I want to stay in the browser, that’s where I was when I opened Sharptools.

So obviously, if you choose the opposite settings in either of those other browsers, they fail as well. I just thought they were working because I thought this was a problem with Chrome alone and not them.

Hi, everyone

@joshua_lyon contacted us about this, so, we asked the engineering team and they mentioned this is a known issue. While we wait for the fix release (there’s no ETA yet), the workaround is disabling “Open supported links” in the SmartThings app as he mentioned above.

The name may vary but you need to enter your mobile’s app manager settings, look for the SmartThings app, and disable the option to open certain links/web addresses by default.

Once we get more info, we’ll let you know.


Hi, everyone.
This week started a new release of the SmartThings app which should solve this issue. Please verify you get it installed and try to enter the link again without disabling “Open supported links” (or enabling them again)

The version with the fix for Android is 1.8.14.

1 Like

It is now working for me. Thanks!

Thanks for the update. Any updates planned for iOS?

Yes, it will start this week, I don’t know the exact time but this new version is 1.7.14. Please let me know if anyone has issues with iOS.

1 Like