SmartThings Android App & Smart Lighting No Longer on Routines Page

I have the latest Android App on an unrooted Pixel 6 running the latest Android 14. Smart Lighting used to be at the bottom of my Routines page. Now all I see is an I used to use called Lock Manager. The only way I can seem to get to Smart Lighting is to click the Discover button and then Smart lighting. All my “routines” are in there. Is this now the only way to get to Smart lighting? Is there some way to get it back on the Routines page in the app? Thanks!

Have you created any Smart lighting rules? Once you create one, Smart lighting will appear on the Routines screen.

Sorry. I meant to say that when I go to Smart lighting I can see all my rules (which I’ve had for years). Maybe I just need to create a new one and it’ll re-appear? Thanks.

EDIT: I tried editing rules and creating a new one, but SL still doesn’t show up under SmartApps like my Lock Manager app.

only thoughts are:

  • refresh the Routines screen
  • clear app cache
  • sign out / sign in
  • uninstall/reinstall app
1 Like

There is some weird stuff going on with Smart Lighting and the UI at the moment. I see ‘id_smartlighting’ instead of a UUID in the ‘sort order’, and incorrect UUIDs for new Smart Lighting automations in the same place. SL also keeps throwing up a banner when it is opened, as if it thinks it is the first time.

Another user has some SL automations appearing alongside scenes.

It seems to be working OK, it is the mobile app that seems confused.


Thanks for the suggestions. I figured I might have to try all of those. However, they didn’t work. Oh well. I don’t change Smart lighting rules much. And at one point I was converting many to Automatic routines. I guess I’ll just have to remember where it is located now.

EDIT: And I think I just realized something else: All my SL Rules begin with SL and they are all now listed at the last Manually Run Routines on my Routines page. It’s as if the last app update grabbed them all from SL and made them Manually Run Routines (when they should have been automatic routines if they were converted correctly because they all have timers). Maybe SmartThing is pushing us out of Smart lighting? And I’m in the US, where it was supposed to continue to be available. Weird.

1 Like

For what it’s worth Smart lighting is in the same place it always has been for me on Pixel 4a(5g) running Android 14 and Samsung Tab S5E running Android 13, both with the latest app.

At the bottom of the Routines page is a heading for Smart Apps that can be collapsed down. Smart lighting is in that section and disappears if you collapse it

My Lock Manager app is in that area but not Smart lighting. I’ll figure something out. Maybe time to convert all the Rules to Automatic Routines.

1 Like

Super wild! And seemingly typical of the “new” SmartThings experience.

As I mentioned in the update thread, only 5 of my 25 Smart Lighting rules/routines are showing under Manually Run Routines… and those 5 appear in both Manually Run Routines and when I open Smart Lighting. For me, the option to open the Smart Lighting app still appears at the bottom of the Routines page/tab. None of mine have SL in the name.

What a hot mess!

This is a longshot, but any chance the smart lighting rules have been divided into ones that run locally versus ones that don’t? :thinking:


All of my Smart lighting rules appear to be local. As far as I can tell without checking every single one, all of my SL rules are now also Manually run routines. Also as far as I can tell, SL is still running the rules (so it’s probably a good thing they were re-created as Manually run routines or else I’d have SL Rules and Automatic routines running at the same time (although I guess they wouldn’t have caused an issue because they’d be doing the same thing at the same time (i.e., turning something on or off)).

Further, I just noticed that Sort doesn’t seem to work any longer! I keep telling the app to sort alphabetically, and the order of routines doesn’t change. And SL still doesn’t appear in the SmartApps list on the Routines page. OK, I take that back. When I selected reverse alphabetical, it worked, and then it worked when I selected alphabetical, except that all of my “SL” names rules from Smart lighting all appear after my “Vacation Away” Manually run routine. I would have thought that the SL ones would have fallen before those named with T and V at the beginning, but that’s not how it’s working. Weird again. For some reason, the app thinks something named with "SL - " at the beginning falls at the end of the alphabet.

24 of my 25 Smart Lighting rules are local, not just the 5 duplicated to Manually Run Routines. :frowning: The one linked to Smart Life (cloud connected) is not one of the 5 that duplicated itself to Manually Run Routines.

1 Like

Yeah. Something triggered me to do that some time ago. The only thing I’ve got left are some rules that mirror/sync some dimmers.


Well, Smart lighting just came back! Not sure why. Lock Manager is now gone from the Smartapps list, though. As I noted earlier, the latest app update converted all of my SL rules to Manually run routines. I tried converting one to an Automatic routine, but I kept getting a network error when I tried to save. So, I recreated it new as an Automatic routine (I’m assuming it can’t be converted either as a general rule or because I still had a corresponding SL rule). Then I noticed that Smart lighting was again at the bottom of the Routines page (but Lock Manager is now gone (although I think I tried to delete previously anyway, so wasn’t sure why it was there, but that’s a different story). Anyway, unless I have some special SL rule that can’t be fully converted to an Automatic routine, I think I’ll give up on SL and make all the rules Automatic routines. For some reason, I have a recollection that Sunrise/Sunset works better in SL, though, but maybe not…

Was true in the past, but I have no problem with Sunrise/Sunset in Routines.

1 Like

Another update. I got Lock Manager back in the list by going to Discover and clicking it. Now both Smartapps are back in the list.

Also, I inadvertently deleted one of the manually run SL routines. I recreated it in SL. When I did, I got it again as a Manually run routine! So, somehow, SL Rules become Manually run routines automatically. If I delete it from Manually run routines, it gets deleted from SL as well. I guess I need to create them all as Automatic routines (because I can’t modify an SL Manually run routine) and only then delete them from manually run routines.

It still can’t cope with say, 02:00 to sunrise?

I have to set up a virtual switch to turn on at 02:00 and off at sunrise, and use that as a precondition to get round it.

1 Like

Yep, that’s what I do.


Now that you say that, I think I’ve had to do the same thing for one of my routines. I created a night switch that I use.

I’ve got the same issue, initially the smart lighting app still showed although it was listed as ‘turned off’ and I couldn’t turn it back on and after signing out and signing back it vanished entirely and I’m seeing the same “manual run’ routines everyone else is seeing. On the other hand on my iPad the smart lighting functionality is working normally.