SmartThing wont connect to Harmony Hub


(Rafael Del Rey) #1

I am trying to setup my harmony hub into SmartThings v1. I am using static IP address for the hub, which is fully updated. I have tried a lot of tips from other threads, but it looks ST doesnt find my harmony hub during the discovery process. Right after the Harmony Link login page, I get the “Connection to the hub timed out. Please restart the hub and try again”. I have power cycled it and waited forever, but it wont work anyway. Is there anything I should try?

Thank you,
Rafael


FAQ: Help with Logitech Harmony (Connect) and Triggers (SmartThings Classic)
Trying to connect harmony hub
FAQ: Help with Logitech Harmony (Connect) and Triggers (SmartThings Classic)
Alexa + SmartThings + IFTTT + Harmony to turn TV on and off by voice (2015 version)
Alexa + SmartThings + IFTTT + Harmony to turn TV on and off by voice (2015 version)
(sidjohn1) #2

https://forums.logitech.com/t5/Harmony-Hub-Based-Remotes/SmartThings-and-Harmony-Hub-Integration/td-p/1356134


(Scott G) #3

I have seen issues where people have old unused or offline hubs in Logitech and it causes problems. ST is all or nothing, so if it can’t connect to all Home Hubs in Harmony it fails. Try logging into Logitech and checking what hubs are listed. Delete any that are old and make sure all Home hubs are actively connected, then try again.


(Ron S) #4

Basically all your hubs should be online. If you have any old harmony hub there in myharmony? Remove it from harmony side. After that it will be a breeze. I had the same issue and stuck for a day.


(Rafael Del Rey) #5

Thank you,

It looks I had an old harmony hub in my account. I didnt even remembered that. I have downloaded the Harmony Desktop App (no web version anymore), removed the old hub and repeated the discovery procedure on ST. Still no luck. I then found a “SmartThing” device on the Harmony App. Deleted it (which required connecting the hub to my computer through usb cable), then tried everything again. No hub found. ST keeps trying to find the harmony hub until it get the “you are not authorized to perform the requested operation” message. Rebooted the hub, repeated… nothing,


(Ron S) #6

I had no activities on my ultimate home which couldn’t be recreated. So, I deleted the old Hub completely. Reset the new remote after deleting any reference to ST and restarted the process (trigger harmony activities from marketplace). It was then able to find everything and life was good.


(Derrek Krasnicki ) #7

I got the hub connected to smarthings but when i create a trigger to watch tv nothing happens when hit the button manually in smart things, I do have 2 harmony remotes, do I remove those and that should do it? Can you not have older harmony remotes and hubs?


(Marios Kimonos) #8

Hi I am having trouble with the logitech harmony (connect) app. it asks me to “Click to enter Credentials” and then i get an error: {“error”:“invalid_request”,“error_description”:“Missing or invalid argument”} I have no idea what is wrong.


(Brad Langhorst) #9

I am trying to reconnect my SmartThings hub to my Harmony hubs. I currently have 3 Harmony Smart Control hubs, with the third being added a few weeks ago. Unfortunately, I can’t get SmartThings to see ANY of my hubs currently and hope someone can help.

Originally, I had configured 2 Harmony hubs in the SmartThings app and had no issues with the SmartThings app discovering them or the activities on each hub. I added a third hub a few weeks ago and decided to add it to my SmartThings config over the weekend. No matter what I tried, the app wouldn’t discover it. I then decided to remove the 2 existing hubs from SmartThings, rebooted the ST hub and all of the Harmony hubs, and tried discovery again, hoping it would rediscover all 3 hubs. Unfortunately, it won’t find ANY of the hubs at this stage - It just sits there in discovery and spins forever (left it running for 10+ minutes). Any ideas or tips? The SmartThings app and the SmartThings IDE show this generic error: Connection to the hub timed out. Please restart the hub and try again.

I did read the post earlier that this behavior can occur if you have a “dead” or duplicate hub in your myHarmony account. Is there another place to go besides myHarmony to see how many hubs are in your config? The reason I ask is that I originally did have some issues adding the third hub and DID have a duplicate, but I deleted the duplicate weeks ago and now myHarmony correctly shows that I have 3 Harmony hubs and 1 650 remote. I’m wondering if perhaps there might be a remnant of a hub that I can’t see that is causing the issue. Any suggestions? I do have a support incident open with SmartThings and posted in the Logitech forums as well.

Thanks!


(Shawn) #10

I had some issues today and had to remove a bunch of stuff from ST, including my Harmony hubs. I currently have 1 Home Control, and 2 of the older version before you could control lights and stuff. It was a PAIN IN THE *$& to get the Harmony hubs back in ST. It took many times restarting the app to get the activities to add in correctly. Go through each hub and make sure the firmware is all updated also, that seemed to help.


#11

which app did you have to restart? I had 1 harmony home control hub previously and as soon as I added a smart control hub (fully updated) I could not add either of them again :frowning:


(Shawn) #12

I had to restart ST. I kept getting errors that there was a problem with my network.


#13

oh you just had to reboot the hub several times?


(Shawn) #14

No. I’d get the error and force quit the app on my phone. Go back in and try again.


(Brad Langhorst) #15

My issue was that I had an orphaned hub in my myHarmony account. I finally found it by changing each hub’s name in myHarmony and then syncing each hub. The hub in my living room wouldn’t sync the new name, meaning it was orphaned. I was able to correct the issue and ST added the hubs with no issues.