Harmony issues


(Brad Langhorst) #1

Hello, I am trying to reconnect my SmartThings hub to my Harmony hubs. I currently have 3 Harmony Smart Control hubs, with the third being added a few weeks ago. Unfortunately, I can’t get SmartThings to see ANY of my hubs currently and hope someone can help. Originally, I had configured 2 Harmony hubs in the SmartThings app and had no issues with the SmartThings app discovering them or the activities on each hub. I added a third hub a few weeks ago and decided to add it to my SmartThings config over the weekend. No matter what I tried, the app wouldn’t discover it. I then decided to remove the 2 existing hubs from SmartThings, rebooted the ST hub and all of the Harmony hubs, and tried discovery again, hoping it would rediscover all 3 hubs. Unfortunately, it won’t find ANY of the hubs at this stage - It just sits there in discovery and spins forever (left it running for 10+ minutes). Any ideas or tips?

The SmartThings app and the SmartThings IDE show this generic error: “Connection to the hub timed out. Please restart the hub and try again.” I did read on this forum earlier that this behavior can occur if you have a “dead” or duplicate hub in your myHarmony configuration. I originally did have some issues adding the third hub and DID have a duplicate, but I deleted the duplicate weeks ago and now myHarmony correctly shows that I have 3 Harmony hubs and 1 650 remote. I’m wondering if perhaps there might be a remnant of a hub that I can’t see that is causing the issue. Any suggestions? I do have support incidents open with SmartThings and Logitech but to be honest, SmartThings support was terrible.

Thanks!


(Edward Pope) #2

I wish I could help you, but have one device here and it appears to be ok. I do remember reading that there was some change again on the backend that caused some issues. But I cannot find it now. It may not be related. Have you tried to re-authenticate from the Harmony App?


(Michael Hess) #3

I just went through this last week adding a third hub. I removed everything Harmony related, then the app kept complaining while trying to re-do the harmony credentials, it would let me login and go back but then couldn’t continue in the smartapp setup. I literally just hit done a million times, exited the app, tried again, over and over, it magically took on attempt 97,451…


(Brad Langhorst) #4

Michael,were you also seeing the “connection to the hub timed out” error after you entered your credentials? This was shown on the discovery screen, where the discovered activities would normally be shown.

ST support was incredibly unhelpful and it was a very disappointing experience. After one email, the guy advised me to create a new Harmony login and recreate all my activities under it. Really, ST???


(Brad Langhorst) #5

Here is the error I’m seeing when I get to the discovery screen - discovery keeps spinning and never finds a hub:


(Michael Hess) #6

Yes that was my biggest hold up, enough back and forth and it would magically work.

Posted a few days ago about my experience:

So just keep trying, I’m on android, not sure if that matters. I can’t even remember how many times I had to enter my harmony credentials, and btw, don’t wait for it to discover anything, just hit done. Go back in after it creates it and I bet everything will be there.


(Brad Langhorst) #7

Yeah, not working for me unfortunately. It looks like I actually already have a second myHarmony account and from what I read, I may be able to just copy the hubs over to that account with all their settings intact if I connect them to my PC via USB. I’ll give Logitech support some time to work with me but otherwise, I’ll probably try migrating one hub to the other account and see if I can suddenly discover the hub - I suspect it will work fine.


(Michael Hess) #8

I’ve had an issue each time I added a hub, had to redo it all in ST, I’d suggest if you are going to go that route, move all over at once.


(Brad Langhorst) #9

Yeah, you’re probably right. My wife has to go on a business trip in a few weeks, so I figure that would be the least disruptive time for me to make that move.


(Ryan) #10

I have been turning to get mine to work for days , when I go to install it shows no hub at all . I can’t even enter my harmony pw and user name. I don’t know what to do any ideas ?


(Michael Hess) #11

Not sure on that one, as I’ve always gotten the auth screen. Other external things work? Like Alexa or something? Do the Live Logging in the IDE and see if anything pops up relevant to it.


(Ryan) #12

Okay seem to got it to work kinda. In the ST app it now shows my Hub and all my activities,but ever time I click done to won’t save it just errors out. So it’s still useless .


(Michael Hess) #13

Yup that’s what I had, restart again, and hit done before it searches for the hubs and activities. Timing seems to be key for some reason.