SmartThings with Logitech hub


(Dan) #1

I am having a problem getting my SmartThings hub (app) to find my Harmony hub.
I had a Harmony Elite and it connected fine, found the hub, found activities, everything worked.

Replaced it with a Harmony Home and now the SmartThings app cannot find the hub.
It says “0 hubs found.” I was able to connect the Harmony app with SmartThings to control lights with the remote but the ST app will not find the Harmony hub…

Since I got the other hub going, I know how to set it up, what can I do?


(Scott G) #2

Check your Harmony account to see if the old Harmony Elite is still there. The SmartThings hub discovery will stall or fail if there are compatible hubs in your Logitech account that aren’t active and on the latest firmware. You should be able to delete the Harmony Elite from your Logitech account, then retry the hub discovery in ST.


(Dan) #3

Is there a way to see your hubs through Harmony’s cloud or something?
I am finding nothing under my Harmony account on their website.

On the Harmony app, I just see my current (new) hub. I clicked “Forget” on my old hub.


(Scott G) #4

There used to be a login on the Harmony website to manage your account, but it appears to have been retired. I would suggest downloading the available software on a computer to see if it provides you more information than the mobile apps. I don’t know if “Forgetting” the old hub is the same as it being removed from your account.

Give that a look and if you still only see your new hub, then the issue must be somewhere else. @Tyler/@slagle, are you aware of any hub discovery issues with Harmony at this time?


(Ryan) #5

I’m having the same problem,ST won’t find the harmony home hub . Now the very first time I set everything up it worked fine. Then I had to reset everything and can’t get it to find the hub again. I downloaded the Logitech software and deleted the old hub but still ST won’t find it.


#6

I am having a similar problem. I have an Elite with hub already in my stem, and just added another hub with home control in another room. No matter what I do, the Harmony Connect Smart App will not see the new added hub.

The weird part is I was able to grant permissions for some things like virtual switches in the Logitech Software, but They do not work when added to the remote buttons.


(Dan) #7

I downloaded the software and found my old remote still on the account.
I deleted it, still having the issue…


(Jason) #8

Is your hub completely up to date? I know that others had issues until the hub updated to the latest release. If I remember correctly I had to click some sort of upgrade button in the app for my hub to update.


(Scott G) #9

Making sure the hubs are updated was going to be my next suggestion as well. If you go to the Menu in the Harmony App and select Harmony Setup -> Sync -> Sync Now, it should pop-up if an upgrade is available.

Hopefully someone from ST will chime in if there is a current issue discovering new hubs.


(Dan) #10

Looks like everything is up to date.
I have Harmony Hub version 4.9.40.

Anyone have feedback on this issue?


(Dan) #11

I reset the hubs, nothing.
I renamed the hub and reinstalled the smart app. Then it found the hub… Weird…


#12

I was able to get both of mine working. I removed anything involving the Logitech hub from smartthings including the app. Then I ran discovery again and it found both hubs.