Smartphone Presence Sensor not working in new V3 app

Hello… I’ve used SmartThings for over 5 years. I transitioned from the Classic app over the weekend to the Samsung SmartThings app. Now, my whole system that worked quite well is a mess! I have it setup on four smartphones (1 android, 3 iphone) for the home occupants. Before, I had them setup as presence sensors in the classic app. I discarded the former presence sensor setups I had with the classic app. Now, I just have them setup by their phone. However, the system is hit or miss, mostly miss, whether it detects their presence. I use each person’s presence to automate armed/disarmed status, lighting, etc. This is probably a dumb question… Do I need to setup each phone again as a presence sensor? Thanks.

In the new app, you need to enable “Use phone location”. You can do this by going to the menu (three bars in the upper left of the screen), click on settings (the cog) and choose Use phone location and enabling it.

That’s been done on all 4 phones. I went into the iphone privacy settings and changed it to ‘Always’. It’s still not updating the locations for all 4 phones.

I’ve seen reports here that presence sensing had issues on iOS if both versions of the SmartThings app are installed.

Have you totally removed the classic app from the iPhones?

I’m all Android myself, new app presence sensing seems to work fine.

1 Like

Thanks… I’ll have to check my kids’ phones. They were supposed to uninstall the classic app. I have the android. And, it is still hit or miss. It worked tonight coming home. But, I didn’t work when I left this morning.

1 Like

Not only on the new app but I’m using the classic app on an iphone. I have removed and added back the iphone as a presence sensor twice now. After the initial find and then “departure”, they stopped working.

Please fix!!!

Okay… I’m not sure what is left to try. I got one of my kids’ iPhones working flawlessly. The other is setup identically. And, it doesn’t work at all. The one that is not working has the most recent iOS update. The new SmartThings app is installed and turned on as a presence sensor (“Allow phone presence detection” and “Use phone location” set to ‘on’). The iPhone privacy settings says ‘Always’. The classic app has been uninstalled. Both of my kids have matching iPhone 8’s. One works and one doesn’t. Any other thoughts why this one phone won’t work?

I’m also having a similar issue. My girlfriend and I both have new phones and none of them are connecting. It still has the old phones on them that we added on the previous app. Can’t figure out how to add the new ones.

To enable presence sensor for the new app.

Go to the menu (three bars in the upper right of the screen)
Click on settings (the cog icon)
Change “Use Phone Location” to On

Note: you don’t get a device listing like you did with the Classic app but the sensor will appear in Automations

1 Like

Thanks! It confused me that it wasn’t available in the device listings. Got everything working as needed now, much appreciated!

1 Like

Has anyone had issues switching from old to new? My phones are the same. Switched over to new app. Both phones having updating location issues. Both have settings turned on.

1 Like

I’ve been on the new app from the start and have not used the classic app. I use an S20+ for pressence and my wife uses an iphone 11. They have been working wife untill recently and my wife’s Iphone is still working. My S20+ on the other hand, is not working at all. In the IDE, my phone does not have a device ID and under Type it says “placeholder”. ST support has been less than helpful because no matter how many times I say that I’ve restarted everything, and toggled location on my device, deleted it from the IDE, they just keep telling me to do the same things that have not worked. This is very frustrating and support is useless.

How are you using the Placeholder device? In WebCore?

The place holder device is my S20+. That is how it is listed in IDE when “use phone as a location device” is selected in the Smartthings app.

Exactly same thing happened to me.

After playing with the New app

I think everything is working correctly now
I have an s10
Wife has ios

As far as Today goes…the presence is working correctly so far.

I can not get this to work on the new app either. Worked perfectly in the old app. I have tried everything.

I check my phone in the IDE and it says last activity 4 days ago. Makes no sense.

I had to change my phone from “placeholder” back to mobile presence device in IDE for mine to start updating correctly again.

1 Like

I keep having the issue
Arrival/back home then within the Same minute Away/Bye Bye

5-10 minutes later…
Arrival/Back Home and stays that way.
This occurs on Both (tested separately) Mobile Presence-Classic App and PlaceHolder - New App
Android platform

IOS there are no issues

It has now worked once for each of us since I created separate automations based on each device. Worked ONCE out of at least TEN times that it should.

How can I get help with this broken feature? Do I call SmartThings?

This was honestly the Mose used feature for us and why we started smart home automations. Now with the new app, it is completely broken! Yes, I am frustrated.

1 Like

If you have Android 10, make sure you set Smartthings to not optimize battery, but also allow it the location permission all the time. Mine was set to only when using the app. So presence wasn’t working. Fixed for me.

3 Likes