Smart Lighting automations turning on randomly


(Sean) #1

I have a Smart Lighting automation when I switch on my wall switch i want my lamp module in the same room to come on. When I watch movies though, I will turn off the lamp module manually from the app. Until recently this was working fine. However about a month ago the lamp module would randomly come back on after 2-10 mins. I check the recent history of the lamp module and it shows that the automation triggered it to turn the lamp on, but the wall switch never changed states. Is this a recent bug?


Smart Lighting Automations Broken for 8 Months
#2

Sound like you have something trigger the light, do check the app related to that light


(Jason "The Enabler" as deemed so by @Smart) #3

Post a screen shot of the app setup that you are using for the light. It is probably something simple.


(Bobby) #4

Is because of this…


(Sean) #5

Thanks. I figured something on the back end changed since I hadn’t touched the automatons or switches. I waited till after this week’s update to post since I was hoping it would fix it :slight_smile:


(Bobby) #6

I think it’s a permanent change, although a fix may come to correct Smart Lighting. The problem surfaces when using Smart Lighting to turn on and off with one instance. A work around is to split the automation, or to change the handler.


(Sean) #7

I separated the automations… now its worse :slight_smile: It is sending an on command every 10-15 mins.


(Jason "The Enabler" as deemed so by @Smart) #8

I have not been able to reproduce this.

Have you completely deleted the rule and started it from scratch? Maybe there is a hung state in the system that keeps triggering this thing.

Also, what does the history for the living room light show? That seems to possible be where the command is coming from… Maybe you’re looking at the end product instead of the other end of the problem.


(Sean) #9

I completely deleted the automations. I may try excluding the switches and re-adding them as well. There was no activity on the switch that triggers the automation between 6:25pm and when i took the earlier screenshot at 9:49pm.


(Bobby) #10

Before you do that, try to change its handler in ide. Is your device useing the zwave switch handler? If yes, change it to dimmer switch. It will still be local.


(Sean) #11

I changed it from Z-Wave Switch to Dimmer Switch. It did fix the issue, but i hope the fix the bug they created. The lamp is slow to turn off when i turn the light off. Also the app shows that it is on but at 0%.


(Michael) #12

This is definitely an issue and support is aware and dev supposedly working on it. I have several rooms with GE outlets tied to GE on/off switches with a smart lighting rule to toggle the outlet when the switch is turned on. Smart lighting keeps repeating the last state anywhere between 10-45 minutes on all GE outlets.

In my case this hasn’t been a big deal, except with the outlet running my recirculating pump. I had to remove the smart lighting rule and use rule machine instead.


(Bobby) #13

Didn’t you change the handlers to dimmers? That’s probably why…


(Jason "The Enabler" as deemed so by @Smart) #14

No, I only did that on one light switch, but I changed it back.

It stopped doing it and I honestly forgot about it.


#15

Is anyone aware of a fix to this issue beside using IDE to change the device type? I’ve been experiencing the same issue, with a Smart Lighting automation set up to trigger a table lamp module when a Leviton wall switch is pressed. The automation repeats every 15 minutes 24/7. Apologies if this has been discussed or resolved elsewhere… I have not been able to find an update in my search. I should add that I’m not familiar enough with IDE to be comfortable using that tool or solution, so I’m hoping SmartThings fixes the bug.


(Michael) #17

@dlaii changing the device this isn’t going to fix this issue. I reported this several weeks ago:
Weekly Update from Alex - 06/09/16

@slagle did some digging and found out that those 15 minute “pings” are for a health check to ensure the ST cloud is in sync with the state of the switch. He mentioned development is looking into a better way given the downstream impact of what I and other are experiencing.


#18

@ritchierich Thank you for the quick reply and information. This is helpful. Sounds like my experience is exactly the same as yours.


(Tim Slagle) #19

They still are too. (Just as a FYI) :slight_smile:


(Michael) #20

It appears that yesterday’s update resolved this issue! :grin: I don’t have continuous state updates on my switches any more


#21

The issue has been resolved for me too. That’s great… what an annoyance it had been, but thank you SmartThings for working this out!


Hub Update Monday August 15