Routines Not Working that include dimmer switch setting

I noticed that about 10 hours ago some of my routines stopped working correctly. I created a new routine slowly adding everything that one of the malfunctioning routines had and narrowed it down to the dimmer switch set-point. The routine works perfectly until the dimmer set-point is used. I changed “I’m back” by removing the dimmer set-point and it’s now working again. Has anyone else had this?

Same here. On the computer with support for an hour. It is also effecting thermostats

And wemo …20 char worth of mentioning…

Same here as well, emailed support but who know when I’ll hear back.

My Good Night routine just turned on the lights and changed mode, but it failed to turn off ANY of the lights, change the thermostats or lock the doors. I really don’t want to delete and recreate but it seems like this is “the solution,” according to support.

I have all my apps that involve dimmer levels and mode conditions (example, “Only when mode is Night”) that are failing too. I’ve deleted and recreated. I will try to remove dimmer settings to see if this makes a difference.

You can remove the dimmer levels from the routines and that should work. I renamed my broken ones so support would have them to review, then re-created new ones with no dimmer levels and they’re working just fine (with thermostat set points).


I’m experiencing this as well. Kind of not looking forward to replicating my routines just for the thermostat -_-

There’s a known problem specific to GE zwave dimmers. I’m sure that’s not the only thing affecting people but I just wanted to add this link here:

It’s a general issue now, there are two other threads that mention this ( maybe someone could merge them?)

None of my routines work as expected. Smart Things showsw them as being executed, but none of the lights actually turn on. Baffling.

It’s even worse than that for me. I noticed this in my ‘Early morning’ routine, which turns on several dimmable lights and sets them to 10% (so as not to blind me in the wee hours).

It stopped dimming correctly, bringing on all lights to 100%. So, following advice here (and basic engineering debugging), I deleted and recreated the routine. Now it works, except for one particular dimmer (all are the new GE Z-wave dimmers with the rocker switch, not paddle). That one particular dimmer ALWAYS comes on at 100% when run through this routine.

Looking at the event information, the setLevel is being sent to the other dimmer switches, but not this one. Can you say frustrating? Oh, yeah, and being #97 in the support chat queue at 9 am PST makes it so much better… not.

I used to work at Samsung, prior to them buying Smart Things, and I REALLY want to believe in this platform. However, the instability makes it basically still a ‘hobby platform’. I can’t, in good faith, recommend this to any of my less technically inclined friends or family.

1 Like

My Routines are still not working with dimmer settings on. The stability and dependability is definitely disappointing when it has worked fine for weeks and weeks and then out of the blue you run into this for no apparent reason.

I think this issue does not apply to routines which dims hues. My goodnight routine dims a couple of hues to 10% and turns off a few. Good morning routine turns on these hues back to 100% with no issues. So is it ok to assume that’s limited to dimmer switches only?

Is NOT even that. Is applicable to people who tun on non dimmers and then select to set level below. As long as you only turn on dimmable things, you’re good.

Aah! 20 characters! And one!

Same issue here, using a Schlage RP200VZVNNSL. When executing the routine I see this error in live logging: java.lang.IllegalArgumentException: Command ‘setLevel’ is not supported. Supported commands: [on, off, poll, refresh, indicatorWhenOn, indicatorWhenOff, indicatorNever] @ line 322

I deleted my routines and re-added them. I built them back with no dimming involved. Now my SHM isn’t responding to the routine change. Same issue? Crazy routine bug?

I just sent this to support, I’m having the same issues as well.

Hello, I have been dealing with some issues with routines and apps not working and these are starting to become unsafe. At first the routines would not execute however in the app it said that it ran but it did nothing. I blew this off to being a bug and it kept happening and eventually all my routines were broke. I deleted all my routines and re added them. I did this several times and they are still not working. My latest issue is a very important one I have a heater in my 11 month old son’s room and it is suppose to turn on after the temperature goes below a certain level. This has been working flawlessly for a few months except last night it stopped working along with the goodnight routine which left all of the doors unlocked and all of the lights on. This is past frustrating now please give me some explanation to what is happening and I know that these issues are not just mine because I read the post on the community.

1 Like

Buddy, I don’t have kids and wouldn’t know but is it actually safe to put a heater in a baby’s room?

Submitted with due respect.