Automatic routines not working as of yesterday (17 Sept 2023)

Update: After disabling/enabling the problematic routines, this appears to be working again for me.
Others have joined the conversation and have far more complex routines than I have. Mine are simply based on time of day or sunrise/sunset. Thanks everyone for your input, and I may have to do some updating to make some of my routines do more than they are doing now. :slight_smile:
Update: Some routines for turning on/off lights will fire successfully when turning on, but not off, and vice-versa for others. This makes no sense, I would expect them to all either work or not work.
I’ve restarted the internet devices, the SmartThings hub, and cannot figure this out. Wondering if the mesh system might be causing some of this, but again this was working fine before restarting everything earlier yesterday. Thanks.
Starting yesterday (9-17-2023), automated routines stopped working. I can run manual routines without issue, but the automatic routines are not firing. There are no events in the logfile that I can see that indicate they tried to run and failed. Some of the automated routines ran, but others did not. They are enabled, so this isn’t a case where they have been manually disabled through the app.
Anyone else having similar issues?
The IoT devices are attached to a hubv3, and there are no internet issues that I can tell because I can run routines manually. Earlier yesterday (before I noticed an issue), I restarted my internet devices (cable modem and mesh router and satellites), and also restarted the SmartThings hubv3; this is done periodically as I try to not let things run indefinitely without a restart.

I am having the same problem. A bunch of my morning routines that use virtual switches didn’t work this morning. This evening, I’m finding that even simple see motion–turn on light automations aren’t working. It’s pretty frustrating.

I manually disabled then enabled the problematic routines. So far, one has worked and I’m waiting for the other to trigger this evening.

I am having the same issue. Motion is being detected, but the lights are not being triggered. I can turn my switches on and off in the app, so it has to be the automatic routine. Also, the routine works if I go into the setup and test the routine.

Something must be going on in the cloud.

I was able to get mine working again by manually disabling & enabling the automation. Not sure if this will keep working but I hope the issue is resolved.

Brian, thanks for the tip.

Here’s what I deduced:

Many of my motion → lights routines have pre-conditions, whether they are luminance, location mode and/or time of day.

I’m assuming that the latest app and the new way routines are handled, it created stacked pre-conditions that made the routine useless. I also found that I can’t use location mode as the prevailing pre-condition when using lux or time. I was able to get my automatic routines working again by moving home mode to the “all conditions are met” stack with time as the pre-condition, which the app pre-selects.

Here was the original rule with stacked pre-conditions that stopped working:

Here is the updated rule that works. I had to remove the luminance condition all together because I could not get the routine to work with it set as an “all” or pre-condition.

Not sure why this changed over the last few days, but at least I have automations back.

I didn’t have anything this complex, just a schedule based on either a set time, or before sunrise/sunset.

Wondering also if they fixed something in the cloud to make this work again, or just disabling/enabling the problematic routines was enough to get them going again.


Ah, the precondition thing might just be it. I’m pretty sure all mine that aren’t working have that. Disabling and re-enabling did not help mine.

What’s weird is that some of the automations were affected, but not all.
I’ll see how things go over the next few days.

I am having a similar issue. This have been working fine for quite a while but as of a few days ago, preconditions aren’t being honored properly. It has resulted in my bedroom light incorrectly turning on in the middle of the night twice now and waking me up. I have since physically powered off that light until I can figure it out. I have a V2 hub and my routine is as follows:

I have three hub modes: Home, Away, and Night. I have a routine when going to bed that I run which changes the mode to Night and turns off the lights. The routine is clearly ignoring the precondition that the mode is set to Home. As a test, I also created another manual routine that only sets the mode to Night just to make sure it’s really being set. I ran that both before and after running the nighttime routine but it didn’t change the behavior.

History shows everything changing as expected, including the mode.

I just tried changing my simple see motion–turn on light routine so that the mode was not a pre-condition, but one of two “If” conditions. It still doesn’t turn on the light when the sensor sees motion. Ugh.

But, if you remove the pre-condition entirely, then it works. Using pre-conditions of modes is one of my favorite things about Smartthings. Hopefully it’s something they’re going to fix.

1 Like

I would try updating the routine by just adding a blank space to the end of the name and save it. See if that helps.

After more testing today, I can confirm that the preconditions that are not working, are luminance and location mode. The latter hurts the most since many of my routines use a location mode precondition. I’ve removed them from the rules and used proxies like security mode or member location. Not ideal and hoping a fix is implemented soon.

The last three mornings around 8am, Night Mode has initiated by itself, which messes up other routines.

Same here, automations with precondition as location mode stop working everyday around 4PM (French time). If i switch location mode to night and go back to home, all my routines works again fine. but every day from september 17th this bug is appearing …

Adding @nayelyz to hopefully shed some light on this situation.

Hi, @JBR, @Fred79, @Alwas, @dieselou, @ZephyrEFI

Did this issue start happening for you around Sept 17th as well?
Can you share the current firmware version of your Hub, please?

Yes, it started on the 17 Sept. My hub is on 49.09. I’ve tested most preconditions and the location mode seems to be the offender. A time precondition seems to work just fine unless it’s paired with a location mode.

To add a data point, I am not experiencing this.

Latest iOS app (, latest prod FW on v2 hub (49.9). US.

First day I noticed it was the 19th. Firmware version 49.00009