Routines not working properly

android
hubv2
routines

(Santiago) #1

Hi,

Looking for help because I can’t find a solution to this problem. Currently I have 6 routines established for my open/close door sensor:

Arm Away: When I leave the house it sets my bedroom door to armed away.
Disarmed: When I pull in the driveway it disarms the sensor.
Good Morning 1: Disarms the door early in the morning during work days.
Good Morning 2: Same for the weekends.
Good Night 1: Arm (Home) door during weekdays.
Good Night 2: Same for weekends.

It works flawless while I am at home but I noticed that if I spend the night somewhere else, it is still disarming the door in the morning or setting it to Arm (Home) at night. I set it to not trigger if I am away but that is not working. Here are the screenshots of the configuration of my routines: https://imgur.com/a/Wglqf

Best,


(Jimmy) #2

Link doesn’t work


(Santiago) #3

Hi,

Thank you for pointing that out. I updated the link.

Best,


(Santiago) #4

Does anyone have a solution?


(Ron Talley) #5

Good Night 1: Arm (Home) door during weekdays.
Good Night 2: Same for weekends.

Your mode is changing from Away to Home during the Good Night Routine…


#6

SmartThings has both a “Home” Mode and a “Arm(Home)” Smart Home Monitor Armed state, which do different things, and this causes a lot of confusion. Similarly, there is an “Away” Mode and an “Arm (Away)” Smart home monitor armed state.

The following FAQ should help clear up that confusion:


(David Hamilton) #7

I have a specific Mode for each Routine. Each Routine has an Auto Function. IE (Morning routine will switch to Day Routine @ 10AM.) It also has a restriction option. “Dont Auto do this is I am in one of these modes”. So for all my daily routines, Morning/Day/Night/NightStay, it is restricted to with to any of these if my mode is set to AWAY. If Im not physically present or have set the system to arm, the mode changes to “Away”. You ca get creative with this option. This is how I keep that form happening.


(Santiago) #8

Thank you all for your replies,

Looking at your comments, my settings should be good however it isn’t acting properly. I am attaching some screenshots here: https://imgur.com/a/pU5dH
Arm (Away) is set to go off when I leave the house and changes the mode to Away. Let’s say I am out of town for the day and I stay at a hotel, Good Morning 1 shouldn’t go off because I am still away however, it still does. Looking at the screenshots, Good Morning 1 changes the mode to Home, however, under “Don’t automatically do this if I am in one of these modes” is set to Away so it shouldn’t go off, what should be different in this case?

Best,


(Jimmy) #9

are your goodnight routines set to not run when mode = Away?


(Santiago) #10

Hi,

Yes, both of them, here’s a screenshot of both of them: http://imgur.com/a/NEtPX
Is there anything that should be different?

Best,


(Jimmy) #11

hmmm, not sure what’s going on. Can you verify in the app that the mode is changing to Away when you leave your geo-fence?


(Santiago) #12

Hi,

It does change to away. I check that every morning when I get to work. The basic functions are working properly. I leave for work in the morning and it does change to Arm (Away), I pull in the drive way and switches to Disarm, I go to bed at 11 PM and it switches to Arm (Home). It is when I go on a trip and stay somewhere else that it doesn’t just stay on Arm (Away), it continues with the regular routines based on time.

Best,


(Jimmy) #13

not the smart home monitor (SHM) status. the system mode. go to the hamburger menu to see the mode.


(Santiago) #14

Hi,

What is the hamburger menu? I tried googling it but it isn’t clear.

Best,


(Jimmy) #15

Three lines stacked on top of each other. In the iOS app its the bottom right button.


(Santiago) #16

Hi,

The mode is correct currently (I am at work):

Best,


(Jimmy) #17

Hell, i don’t know then. Has support been any help?


(Santiago) #18

Hi,

I will contact them regarding this. I appreciate all your help.

Best,


#19

hi - Did you solve this as I have a similar issue. My mode is set to home and when I open a window It triggers the event. I have set to not do this when set to home. I’ve checked and rechecked everything I can and it triggers even though I’ve said not to when mode is ‘home’. Cheers Steve


(Jimmy) #20

What event is being triggered? Smart Home Monitor?